Samsung Galaxy S2 will not work with ADB


Last Updated:

  1. MikePhoenix

    MikePhoenix Member

    I have tried everything suggested in the tutorial in this forum. I followed all the instructions and ADB simply will not recognize this device that I purchased through T-Mobile. I have attempted it on 3 different systems. PDANet doesn't recognize the device when I try to install it. Samsung technical support was absolutely useless.

    If you want a device for development, I would suggest staying away from Samsung.

    Advertisement
  2. jonbonazza

    jonbonazza Well-Known Member

    That's a bit harsh, don't you think? I use a Samsung Galaxy S2 with ADB every day on both Windows and Linux and I have even used it a few times on a mac OSX box at work.

    It seems to me that you are just not setting it up correctly.

    A couple questions to start:

    1) Is your device rooted? If so, what ROM do you have on it?
    2) What OS are you trying it on? Linux requires a bit more setup than, say, Windows
  3. MikePhoenix

    MikePhoenix Member

    My device is not rooted.
    I tried with Windows XP, Vista, and Windows 7.
    I install the SDK, downlosd the necessary packages, plug in the the device, and enter "adb devices" on the command line and it doesn't recognize my device. Furthermore, PDANet doesn't recognize the device when I plug it in.

    And no, I don't think its harsh. The Samsung Tech Support was useless while their product was not working as it is supposed to.
  4. jonbonazza

    jonbonazza Well-Known Member

    Did you install the proper USB drivers? Where did you get them?


    EDIT: Also, The Galaxy S2 works just as it is intended. Just because a user can't get something working does not necessarily mean that the device or the manufacturer is at fault.
  5. MikePhoenix

    MikePhoenix Member

    The USB drivers are what was installed when I plugged the device in. Samsung couldn't direct me to any other USB drivers. All they suggested was PDANet, which wouldn't work.

    Respectfully, I must disagree. Everything I have read indicates that android devices are supposed to be able to communicate with the adb, mine doesn't despite the fact that I have followed all installation instructions for the software.
  6. PunjabiRemiix

    PunjabiRemiix Well-Known Member

    are the drivers installed through windows update? i dont know if this is the problem, but was the case for me with My T-Mo S3. Do this:

    1)uninstall drivers via Control Panel.
    2)Use USBDeview and uninstall any samsung related drivers like usb storage and what not.
    3)Reboot
    4)Most important step: Disconnect from internet, and install these drivers Link Below.
    5)KEEP Disconnected and plug ur device in and let it search drivers from HDD to force install instead of Windows Update.
    5)Reboot, and you can connect to internet and should be picked up by adb.

    Before trying any of this, is USB Debugging on?

    |MG| USBDeview 2.16 Download
    Download T-Mobile_t989_GSII_ADB_Drivers.zip from Sendspace.com - send big files the easy way

    Good Luck.
  7. MikePhoenix

    MikePhoenix Member

    Didn't work. And yes the USB Debugger is on.
  8. MikePhoenix

    MikePhoenix Member

    This problem was corrected when my phone was upgraded to Android version 4.0.4. Was running version 2.3.3 when I reported this last month.
  9. BB101

    BB101 New Member

    I'm having similar problem to MikePhoenix.

    My Galaxy S2 (GT -I9100) LCD screen cracked (under the glass!) and I'm unable to use the touch-screen. I need to recover data/photos from the device before sending for repair. The phone still powers-up and is visible as a 'Potable Device' in 'My Computer' on my PC (Windows 7 Home Premium 64-bit). However, when I try to 'Open device to view files' the folder is empty. I've tried using Samsung Kies but once it's found the device, a message saying "Connection Locked" pops-up and asks that I enter the password on the device. Since it's a pattern lock I'm unable to do so. I've tried using adb to pull data from the device but when running adb services it can't find the device i.e. no serial number is shown. If I run adb shell it returns an error message saying 'No device found'. I'm unsure as to whether 'USB Debugging' was checked or not on the device before the screen cracked. I've updated USB drivers via Kies. I tried sourcing drivers via PDANet but the installation cannot complete because it can't find the device! I've used different usb cables...... tried using One Click Pattern Unlock....... basically everything Google could throw at me. Do you have any other suggestions for me to recover the data?[FONT=&quot]
    [/FONT]

Share This Page