SAMSUNG GALAXY S2 won't charge turned on.


  1. eXclipped

    eXclipped New Member

    So, my Samsung Galaxy S2 is literally 1 month old, and I JUST started to have problems with the charging of this phone. Whenever I try to charge it, while it is turned on, the phone does not detect that it is being plugged in and will not charge. When I plug it into the wall outlet, this is what happens. When I plug it into my computer, this also happens. However, when I plug it into my computer or wall outlet while my phone is off, it begins to charge. Once I turn on my phone, it stops charging. I have read other forums that are SIMILAR to this problem, but none of them have solved my problem. I got it to work once using all the methods I have read about in past forums, but none of them have worked afterwards. As a side note, when I plugged it into my computer, while my phone was turned off, my computer was able to detect it and begin to install the driver, but once I turned on my phone, the driver download failed, and my phone stopped charging, and I was not able to find my phone on my computer. This is extremely frustrating because I REALLY love this phone (despite its poor battery life, and the fact that it heats up from time to time). Also, being only able to charge my PHONE only when it is off is just ridiculous.
    I have downloaded Android Assistant and checked the battery usage, and found that none of the apps/programs running use up more than 5% of my battery. Giving a rough estimate, I'd say the % adds up to 10% for all programs running (probably even less). I've turned off 3G, I've deleted some of my apps, I've cleaned my USB, I've plugged it into different USB ports on my computer, I've plugged it into different wall outlets in my house, I've turned off GPS, I've lowered the display to minimum, and NOTHING has worked this time. PLEASE HELP!

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    That's a puzzler for sure. Are you using the cable and charger that came with the phone. They can be picky. Is it covered by warranty and have you talked to Samsung tech or your carrier?

    Whichever carrier you have, you might get more help posting in that specific GS2 forum.
  3. damewolf13

    damewolf13 live~laugh~love VIP Member

    Welcome to Android Forums!
    If you tell me which GS2 you have and who is your service provider, I will move this thread into the correct forum, and you will probably be able to get some help.:)
  4. eXclipped

    eXclipped New Member

    What do you mean by "which GS2?" Do you mean the Android Version? If so, it is 4.0.2 And my provider is Fido.
  5. damewolf13

    damewolf13 live~laugh~love VIP Member

    I see that your service provider is Fido, and I am not acquanted with which version of the S2 they carried, but there are several different versions of the S2, and they are all Android.
    I would take your phone back to Fido, and have them do some troubleshooting for you. After all, your phone is still pretty new, and shouldn't be having this trouble, especially so soon after you got it.
  6. mogger19

    mogger19 New Member

    Have the same problem with my s2, took it to Vodafone who sent it to Samsung repair centre. They called me and said the engineers found liquid damage to the usb/ charger port and this was a chargeable repair. The phone has never been water damaged, when I tried to argue this point they just fobbed me off. I am going to get it repaired locally for half the cost I was quoted. This is apparently a common fault on the s2, a point Samsung denied.
  7. proximus1212

    proximus1212 New Member

    Hi!

    I was having problem that S2 won't charge using PC, and won't connect.
    I read about problems but didn't find the answer.
    So I did next:

    Connect usb cable to PC and to S2, turn the phone off. Mine S2 turn on automatically after couple seconds and start charging.
    The problem is solved.

    Try that and good luck!!!
    Best regards
  8. proximus1212

    proximus1212 New Member

    I must to correct my self.
    That didn't solve the problem!
    S2 is usb charging only when i resert my phone while is connected to PC
    If i unplug, and plug again he won't start charging.

    Does anyone have a solution?

    Best regards
  9. Atma

    Atma Well-Known Member


    Welcome to the forums proximus. :wavey:

    Have you tried a factory reset to see if it is a software issue?
  10. Kriss3d

    Kriss3d New Member

    Got a Samsung Galaxy nexus. Same problem. About 2 days after upgrade to 4.1.1 i couldnt get it to charge unless the power was plugged in while turned off. Now it wont even keep charging while on so i can only charge while off. Somhow I think it could be the software turning off the charging (as it would likely do when it detects battery full)

    I wouldnt buy the whole "fluid damage" as why else would it charge just fine when turned off..
  11. Noimportantone

    Noimportantone New Member

    Here is a quick work around. Turn off the device, unplug it. Then plug it back in and wait for the battery image display. Once it is displayed, turn the phone back on and whalah charging while powered on. It works for me and its free so suck it. Check out youtube.com/noimportantone on you tube or soundcloud.com/noimportantone for more help. Latez peeps.

Share This Page