Samsung Galaxy S3 General Information and Troubleshooting FAQTips

Thread Status:
Not open for further replies.

Last Updated:

  1. Miggs2002

    Miggs2002 Member

    That's is weird, I'll have to try and tempt a salesman to demo with sandpaper next time lol, cheers for the info, does that mean if I put the card in my pc and rename it to say mIggs' card will work?

  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    What you name the SD card is irrelevant to the operation of the SD card. Computers (Linux/Android, Windows, etc) can associate names with storage devices. The name may not show up on the GS3, but all of the data will be there.
    PattiCakeUS likes this.
  3. whippey

    whippey Member

    One thing I don't get with this high end phone:

    Samsung make this high end phone to, in effect, go against iPhone and other leading smartphones and they don't even bother to make a pc/mac software to go with it. I am struggling to transfer files to my galaxy as my Mac cannot read the Android phone. iTunes goes with Apple, its the basis of a smartphone to have a software where you could easily transfer movies, music etc to it.

    Am I missing something here?
  4. yoshx

    yoshx Member

    How can i heal back my lodspeaker? I was on skype used my loudspeaker then when i ran out of juice i put the phone on charger, went back to skype no voice at all on the loudspeakrr. I tried restart factory reset. Tried*#0#* service code no voice came out. But wgen i pluged in and out my earpice . Time to time it makes some noise for 1seccond . Thats it i hope u can give me some advice thanks. U are awsome
  5. Miggs2002

    Miggs2002 Member

    This is one of the app to sd apps I have, as you can see I have numerous apps I am able to send there
    This shows the card is installed and the phone can see it

    But this is all I see when I try to send stuff to the card, I have tried renaming the card but my pc won't read cards for some reason and my laptop is being repaired, if it's going to work I can use a friends to do it, I know what you said above but does that basically mean no matter what I call it the phone will still see it as an sd card? Can I rename the internal sd memory to make it work?
  6. King Kashue

    King Kashue New Member

    Yes, you are missing Android File Transfer, which is available at Transfer

    Just download that, install it, and Robert's your mother's brother.
  7. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Kies can sync multiple items to the phone, like media files and pictures. It's the official Samsung app and can be found here: Transfer, Sync & Manage Music, Movies, Photos, Contacts and Calendars with Kies

    If that doesn't work for you, as that's the US version of Kies (and I can't get google to give me the international link, should you be outside of the US).

    Personally, I prefer AirDroid as it doesn't require any residual software on the machine and will work via any web browser.

    I think your speaker is broken. If you can return the phone, I would recommend you try that. Does the speaker make any sounds, like if you play music?

    Just because an App2SD app says it can be moved doesn't mean the phone will allow it. Android has an App2SD mode built into it (and has since 2.2 Froyo), however, the configuration of the Galaxy S3 doesn't allow for this to work. Apps2SD was for phones that relied on SD cards for storage. Google/Manufacturers are trying to get away from relying on SD cards.
  8. grmuge

    grmuge New Member

    You can't move apps to your SD card on the S3. I have read this on other forums it seem Samsung have stopped it
  9. Farah123

    Farah123 New Member


    so i wanted to copy a video to my pc, i got the cable and connected the phone, then afterwards i did a factory reset.. ever since there has been a folder in the gallery with the computer's name, nothing inside it "it won't open" if selected nothing else ca be pressed, even the delete button doesn't appear :/

    i tried formatting the gallery "through the pc, and through the antivirus" but its still there! everything else got deleted except for that folder :/

    please help!
  10. bjmadison

    bjmadison New Member

    You have to touch the tiny little "round arrow" to refresh and get the current weather. I've purchased a small stylus which helps me with the small, tedious screen touching tasks.
  11. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Your phone has an app called File Explorer. At least mine does. If not, grab ES File Explorer from GPlay. This will allow you to browse your internal memory for this folder and delete it. If you use ES File Explorer (I recommend that you do), you can even search your internal storage for the folder (by folder name) and delete it that way.
  12. Farah123

    Farah123 New Member

    thank you but it didn't work! and i downloaded the app "es explorer" it couldnt find the folder, it's like something that can't be dealt with
  13. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Are you using Kies or Kies Air? Can you try deleting the DCIM directory?
  14. red5ive

    red5ive Well-Known Member

    Has anyone on Verizon noticed a sudden increase in battery drain relative to Cell Standby? I could swear it was in the single digits before, but now I'm seeing Cell Standby around 32% of battery drain by the end of the day. This has been happening for about 3-4 days now on my S3 as well as the wife's S3. I can barely get through the day on a full charge whereas before the battery was regularly in the low 40%, high 30% range by the end of the day.

    I did the basics, checked phone app settings, checked for rogue apps, battery pull (several times), checked that I didn't enable/install anything that'll kill the battery, etc. The kicker is that it suddenly started on both our phones a few days ago. The only thing we did differently earlier this week that I think would impact this is we used wi-fi direct for the first time to transfer files, but I checked repeatedly to be sure that service is off on both phones. Any ideas?
  15. jerofld

    jerofld Fixing stuff is not easy VIP Member

    This is a known issue across all S3 variants. There is a sticky thread with a petition to get Samsung to fix the issue.
  16. alexander323bc

    alexander323bc Well-Known Member

    My understanding was that some phone had this issue due a programming error. It should not be just appearing. Mine cell standby changes daily and I cant figure it out. On Tuesday I got 15 hours out of mine my standby was around 15% today its at 40% and my batter will be lucky to last 10 hours. I don't get it!!!
  17. red5ive

    red5ive Well-Known Member

    Thanks, jerofld. I did see information on the web that it was a known issue, and my bad for not mentioning it. However, I guess what I'm asking is why did this suddenly start happening after 3 weeks? And it started suddenly on both mine and my wife's S3 out of nowhere. My understanding on the issue is if your phone has it, then it has it. My Cell Standby was otherwise less than 10% of battery drain previously, and suddenly the last 3 or 4 days it's at 32%, same as the wife's S3.

    I'll read more on the sticky, though, maybe I don't understand yet the depth of the issue.
  18. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Do you root? I'm under the impression that everyone has it on all variants. I just thought it was a recollection thing, where it just seemed like it was higher than normal today.

    Unless you root and had the cell standby recalculation fix installed and switched to a ROM that didn't.
  19. red5ive

    red5ive Well-Known Member

    No, haven't rooted due to the locked bootloader, but I hear Verizon is going to release a fix that will unlock it. But even then I probably won't bother with it as this is the first Android device I've had that I'm actually very happy and impressed with the stock performance. That is, unless this Cell Standby thing doesn't get fixed and drive me to the point that I root. :D
  20. jerofld

    jerofld Fixing stuff is not easy VIP Member

    I don't know what to tell you, then. Everyone I know of that has a GS3 has this issue (except those who root and install the fix). Honestly, the phone has been good with battery with me that I rarely even check the battery page. I get 16 hours of moderate use. I rarely have to plug it in to recharge during the day. So the problem hasn't really bothered me all that much.

    And there's more reasons to root than just performance tweaks :) I love Titanium Backup and LBE Privacy Guard too much to not root.
  21. red5ive

    red5ive Well-Known Member

    And that's where I'm coming from. The first 3 weeks with the phone after 15+ hours I was almost always above 40%, sometimes in high 30s. It was never an issue until the last few days, that's why it seems odd to me that out of nowhere the last 3 or 4 days the drain started happening.
  22. alexander323bc

    alexander323bc Well-Known Member

    That's I posted summarizing what I read on the XDA site. I know the issue effects all varient's but I did not believe it effect all phones. I thought you either had the issue off that bat or you didn't. I did not realize it was something could magically just appear. Thanks for the info guys
  23. red5ive

    red5ive Well-Known Member

    The thing is, I'm not entirely sure that Cell Standby is the problem. It just seemed to coincide that when I started having the battery drain that I also noticed that Cell Standby % was high. The last time I checked the battery stats was maybe a week before this problem started happening, and up until then I was checking it almost every day. Screen was always the highest % and was always at the top, but now it's 3rd after Cell Standby and Android System.

    It seems better today so far, though, even with Cell Standby at 37% after almost 6 hours. However, I did put it on my dock this morning for a 40 min. call as I was afraid I'd have no battery left after.

  24. yoshx

    yoshx Member

    Thanks for reply.

    It doesnt play anything.
    But when i use my earpiece during skype call. And suddenly i put the phone on speaker while i perform restart then it makes a noise for about 2 sec.
    I really dunno what is going on :)
    I performed factory resets soft resets no use....

  25. bubbler06

    bubbler06 Member

    Pretty cool found this by accident, but the little icon on the bottom of your home screen you can quick choose a home screen you want to go to (don't have to scroll). And if you long press you can quick scroll.
    jerofld likes this.
Thread Status:
Not open for further replies.

Share This Page