1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Samsung Galaxy S3 Not switching on


  1. RisingSun786

    RisingSun786 New Member

    Hey there,

    I'm new to the forum so firstly hi all!

    I've had a S3 for less than 3months on the T-Mobile network.
    I was on the phone to a friend when the phone cut out. I assumed that the network coverage was lost and tried to call back.
    However, was unable to get the phone to work. Blank screen, couldn't switch the phone on at all.
    I know it wasn't the batter as I had over 50% and wasn't talking for very long. To be fair in comparison to some other Android handsets and the iPhone the Galaxy S3 battery lasts me up to 2 days.

    I looked online and saw a couple of YouTube videos to hard reset the phone this didn't' work. Spoke to T-Mobile support (my carrier) who said this is the first time this problem has been reported and also walked through the process of hard resetting my phone and various other support - none worked.

    I was advised to take it to a T-Mobile store to send off for repair, was told it could take up to 7 weeks. Thats sucks but i'll just have to wait.

    Any other experiences like this?
    Gutted really, absolute fan of Android phones had a HTC desire before this and did have the choice of an iPhone but im gutted the phones wrecked and i've not even used it that much.

    Not sure if anyone else has had similar problems, would love to hear...

    Best,

    RisingSun786

    Advertisement
  2. Szadzik

    Szadzik Well-Known Member

    Charge it.
    Take battery out to shut it down.
    Home+Vol down+Power and you will get into download mode.
    Use ODIN to flash firmware for your version.

    Sammobile.com for firmware downloads.
  3. RisingSun786

    RisingSun786 New Member

    Hey there thanks for your message.

    I'm afraid i've done all that you mention.
    The hard reset I was referring to in my original post, which are also instructions you have provided also don't work. They tried it in store too.

    However, once I do get it back, I will try and download the firmware you suggest.

    Many thanks,
  4. Szadzik

    Szadzik Well-Known Member

    Hard reset is not the same as flashing.
  5. RisingSun786

    RisingSun786 New Member

    Hey there,

    In terms of flashing - doesn't the device have to be responsive for me to do this?
    Just checking in case i've misunderstood - checked out a couple youtube vids and the device was responding?

    Thanks for your help so far
  6. Szadzik

    Szadzik Well-Known Member

    If it does not start up at all, then you are done, if you can press Power_Home_Vol down and it starts up, then you can fix it.
  7. keico

    keico New Member

    Hi there,

    i think we got the same problem. my 4month galaxy s3 is not switching on.. i thought i drained my battery but when i charged my phone for a couple of hours and try to switch it on, nothing happen. i tried Hard Reset but my phone don't respond.. its totally dead..
  8. Tripndrag

    Tripndrag Member

    I checked my phone today and it was off, wouldn't turn on. I have had the phone for a couple months.

    The only way I could get it to work is to plug it into a charger, it would show an empty battery with a circle in the middle and then go to a charge screen with a battery that was almost full so I knew it was charged and charging ok. My wife has the same phone so I swapped our batteries and mine worked in hers but her battery did the same thing in mine, wouldn't turn on or do anything unless I connected a charger and then it would start up and turn right off once it got to the lock screen.

    I could hit the power button when it was connected to a charger and charging and turn it off, then hold the power button and it would vibrate and turn on, once it got to my lock screen it would just turn off again. If I unplugged the charger it just wouldn't do anything and it would instantly turn off if it was in the middle of going through the boot up. I left the battery off for an hour or so, nothing, still wouldn't work.

    I read online about getting into program mode by holding up volume, power and home button. It wouldn't go into program mode but, I could get it in to program mode by having a charger connected, waiting for it to start charging, holding the power button to turn it off then doing the up volume, home button, power button thing to get into program mode. I tried everything in there, clearing cache, reload option etc... and it still wouldn't work. Last effort I cleared and wiped the phone from within there. It seemed like it was then working but after I answered a couple questions it just turned off again on its own and still didn't work without a charger connected.

    I went to the Sprint store and they ordered me a new phone. I went home and started looking on the internet and wasn't having any luck. I then though about taking out the battery, holding the power button and then putting the battery back in, it worked! I didn't have the charger connected at this time. The phone booted and works fine again. I wish I would have though of this before I wiped the phone but, I just set it back up with my Gmail account, put the sd card back in it, logged into the play store on my computer and clicked on all the apps I had on the phone and told them to install on my phone again. It was all up and running again in a few minutes. Had to set my ring tones and other tones again, select my calendars, turn on power saving and make my home screen and my other screens but that is about it.

    So if your phone won't turn on, try pulling the battery, hold the power button and put the battery back in the phone while your holding the power button.

    Hope this helps others. Happy New Year!

Share This Page