Samsung Galaxy s3 screen flashing after dialingSupport


  1. mrpancakes

    mrpancakes New Member

    Hey guys,

    I bought a Samsung Galaxy s3 from Verizon two weeks ago and I've noticed that whenever I dial a number which then requires me to pick an option and press additional numbers the screen starts flashing on and off so that I can't even dial.

    Today I called the 800 number for my insurance company and was asked to dial 0 for customer service but the screen was flashing so fast that I couldn't dial the 0. I ended up hanging up and using my husband's Droid to make the call.

    Has anyone had this problem? I don't have notifications, emails, texts. I have only downloaded some basic apps and the phone is fully charged.

    By the way, I should mention this is my 2ND Galaxy s3 in two weeks. The first one died after one day and I had to go get a new one. :mad::confused:

    Advertisement
    :
  2. davidmanvell

    davidmanvell Well-Known Member

    What is happening is the phones sensors are kicking in and turning off the screen. The phone has a feature that blanks the screen when you place it against your cheek to prevent you from accidentally cheek pressing stuff on the active screen.

    When you tap your finger against the screen the phone also thinks it's your cheek and blanks the screen accordingly.

    The fix is how you hold the phone. If you hold the phone exactly like you do when you place it against your ear it will sense you are holding it that way. Change your grip and it will work. Other option is to turn off that sensor in the settings.

    Took me a bit to figure it out as well when it first happened to me. Once i figured it out it was a no brainer.
  3. mrpancakes

    mrpancakes New Member

    Thank you thank you!!! I went to the phone screen and hit call settings and unchecked the "auto screen off during calls" option.

    Much better. This phone has so many features, maybe too many for me.:confused:
  4. Digital Controller

    Digital Controller The Real Bass Creator Guide

    This is exactly the right solution.

    New smart phones can be pretty overwhelming that's why we are here to help :)

    Fortunately enough you can turn this feature off, as i know it has given some people a hassle in the past.

    Glad to see you got your problem solved.
  5. GolfAtTheOaks

    GolfAtTheOaks New Member

    I just wanted to add to the solution. The auto-screen off isn't a bad feature when it's working. Once I turned mine off and backed out to the homescreen, I verified the solution worked. Then I went back in a turned it on again, and it worked as advertised.
Loading...

Share This Page