Samsung Galaxy S3 wifi problemSupport


  1. jiggspk

    jiggspk New Member

    I am facing some frustrating issues with my new S3.

    I bought it last week and wifi was working fine but sicne yesterday I am unable to connect my samsung galaxy s3, though the WIFI connection has very good signal strength. I always get the msg 'To see available connections tern on WiFi' even the wifi is on. There is nothing wrong with the WIFI as i can connect it with my laptop and my iphone 4. My new galaxy s3 can not find any wifi device.
    please help.

    Advertisement
    user1892 likes this.
  2. davoid

    davoid Well-Known Member

    When you say "even the wifi is on" do you mean that the wifi network is on (i.e. the router) or do you mean even when you have wifi turned on in your phone?

    'To see available connections tern on WiFi' (sic) is not referring to your network router being available to devices. It means turn on wifi in your phone. I apologize if this is what you meant.

    by the way, you might have received more replies if you had posted this in the general S3 forum and not the All Things Root subforum.
  3. Shotgun84

    Shotgun84 Well-Known Member

    Moved to main forum
  4. cary328is

    cary328is Well-Known Member

    I believe this is related to the popular issue regarding WIFI on our device. The most common "Fix" right now is something that was learned from XDA developers:

    1. Go to your phone dialer
    2. Dial *#0011#
    3. When you see the "ServiceMode" screen, press the left menu button
    4. Select "WiFi"
    5. See that "Wifi Power Save Mode" button that is "ON" - well turn it "OFF"
    6. Exit this menu, turn off your Wifi and turn it back on. If you already entered all your wifi credentials, forget your network info (remove it) and re-enter it again.

    Let me know if this works
  5. s3user

    s3user Active Member

    I am experiencing the same thing, my wifi does not work at home. Wifi works at my workplace which runs the same 2.4GHz as my home.

    The weird thing is that the phone worked on wifi in my home before I activated the sim card. right after the sim card it just stopped working when I try to connect at home.

    The status is connected, but I can't load any page.

    I tried this but no luck. I even tried resetting the router with default values and nothing :(

    Damn you samsung, I thought my galaxy S had wifi problems, at least it was able to go online!
  6. headbrian

    headbrian New Member

    I have the same problem :(. cary328is' trick did not work for me..
  7. s3user

    s3user Active Member

    yea there's definitely a problem but it only happens with some routers I think...

    what router do you have?

    I have an old b-band linksys
  8. cary328is

    cary328is Well-Known Member

    Just for the record - I take absolutely no credit for that "trick" :) I found that in a thread from XDA developers and thought I could bring it up as a possible fix for you guys. Sorry it didn't work. I have an Apple Time capsule (built in wireless router with backup drive) and I don't have any issues with wi-fi. It would suck if it was your router(s) because other devices around your house are working just fine! Samsung should definitely fix this bug if this was the case.
  9. ouchmaster

    ouchmaster New Member

    hello im new here and also been having problems with wifi of my galaxy s3...it says its connected but no internet. It suddenly stopped working after 2 weeks of use
    I did the *#0011# trick and it didnt work for me
    So i accessed the router settings and found something called DYNAMIC ROUTING which was switched off. So I turned it on et voila...wifi works again
    Hope this helps you
    s3user likes this.
  10. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Sometimes rebooting the router fixes things, too. Or do a DHCP release to let it clear out any oddities with DHCP.
  11. s3user

    s3user Active Member

    wow that worked for me too... thanks for that!!!

    That Dynamic Routing was the problem, don't know if that's a samsung issue or what..
  12. ouchmaster

    ouchmaster New Member

    Glad I could help you
  13. scorpio78

    scorpio78 New Member

    I had this issue after switching to Verizon and buying 2 Galaxy S 3's. Mine would not allow wi-fi to turn on at al. After my girlfriend was able to connect immediately and after countless hours, I did the following:
    1. Downloaded wondershare mobilego for android and backed up my contacts, pics, and apps
    2. Performed a factory reset
    I was able to restore all of my phone settings and immediately connected to my home wireless.

    Hope this helps
  14. rafian

    rafian Active Member

  15. asmasin

    asmasin New Member

    thnk u so much! it worked :D
  16. KP7465

    KP7465 New Member

    :eek: Okay so my phone was not showing me any wifi networks that were in range.....I have wifi at home and it is working....I scrolled down to the bottom of the list of wifi networks out of range and clicked on +Add Network....I put in my Network SSID, Security, and Password...then I clicked Save and I was connected to my home network AND all the other networks that are within range popped up too. I'm sure this isn't the best idea if you are trying to "borrow" wifi...but this worked for me! Hope it helps!:smokingsomb:
  17. kennychaffin

    kennychaffin Well-Known Member

    No wifi or cell signal issues here after almost a week. I've only used wifi on my home system, but it works fine and consistently.
  18. SicilianPanda

    SicilianPanda New Member

    As like many of you, I had the same issue with my new S3... here is the solution that worked for me on my Home Wireless setup using a CISCO Linksys EA4500.

    1) Log Into Your Wireless Router
    2) Select The WIRELESS Tab
    3) In The Wi-Fi Protected Set-up feature (it may called something else on yours)... look for the

    --- "2. If your client device has a Wi-Fi Protected Setup
  19. autechre11

    autechre11 New Member

    One way to fix this problem is to assign the device a static ip on the router, then go into advanced setup on the s3 wifi connection, and specify the ip, gateway and other settings. Make sure you change the ip from auto or whatever, to static. Worked like a charm for me, dlink dir-655
    discipulum90 likes this.
  20. SicilianPanda

    SicilianPanda New Member

  21. arul murugan

    arul murugan New Member

    tell me d procedure to switch on dynamic routing tell me wer s the router settings
  22. jan1262

    jan1262 Member

    DId you solve your problem with connecting to wifi? I bought a Galaxy S3 2 days ago and it still won't connect. I have the wifi turned on on the phone, all other devices in house connect fine.
  23. ZX9RDan

    ZX9RDan New Member


    To that, we would need to know what router you are using.
  24. ZX9RDan

    ZX9RDan New Member

    I had (have) the same issue as the original thread.

    I tried the *#0011# trick to no avail. The version of phone that I have does not allow to switch from 2.4 to 5 MHz.

    I went to settings/Developper options. At the bottom there is a topic called Limit background processes
    When u click on that, you get some radial options. I set mine to No background processes from Standard limit and the signal bars immediately fillled right up.

    I had the issue at home on my Netgear router and here at work where I sue a P.O.S. Mac as access point.

    Im sure I will soon find a bunch of stuff that sued to work and dont work anymore, but WiFi is back!

Share This Page