1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Samsung galaxy s3 WIFI problem?


  1. boom10ful

    boom10ful Member

    Hello. Since I bought my Samsung galaxy s3 I cannot connect to my router. My carrier is sprint. My dad's phone is also from sprint but it is a different phone. Both phones attempt to connect and fail. They keep trying to connect.

    Advertisement
  2. 9to5cynic

    9to5cynic Well-Known Member

    Hi and welcome to the forums!

    First, I'd like to inquire if you've been able to connect other devices to this wireless network? If so, has anything changed besides the new s3?

    If you are using WPA2, make sure you've got the settings correct in the wireless setup...

    These are just some of the more "Slipped my Mind" errors that sometimes happen.

    If that's not the case, I'm sure someone can help you out further... those are just my quick thoughts on the matter.

    Best of luck!
  3. boom10ful

    boom10ful Member

    Yes I have tried. I even changed the router settings from WPA2 to WEP and that still didn't work.
  4. Mr. Ed

    Mr. Ed Well-Known Member

    silly question but what type of router, and have you tried rebooting the router?

    with the fact that two different phones refuse to connect..it is unlikely that it is an issue with the phones
  5. boom10ful

    boom10ful Member

    I have tried rebooting it and that didn't make a difference. It is a 2wire router from att.
  6. ajdroidx

    ajdroidx Well-Known Member

    Have you flashed an updated firmware to the router?
  7. Ktest

    Ktest Active Member

    I too have the new S3 (sprint) and have been experiencing issues with connecting to some routers. Latest one was at a favorite restaurant. Everyone else at table could connect. My device would not. Signal strength was good too.

    Router was a Belkin, dual mode 2.4 and 5 GHZ model. Would not connect to either band.
  8. boom10ful

    boom10ful Member

    No I haven't. I don't know how.
  9. capricious

    capricious New Member

    Hey guys please help, I got S 3 international version on 25th June, my WiFi gave some probs but started working on its on the next day after few failed attempts, so i didnt pay much attention, then i updated phone over OTA few days later via wifi, and the very next day my phone did not start, I submitted my phone to Samsung Service center, they reset the phone, installed the default firmware version and phone is working fine again, but now its not connecting to Wifi, kies is showing me that firmware update is available, please suggest me what to do, in my wifi settings, after i enter the password, it shows "connecting", "authenticating..." and then i get message "stored,saved" then it connects again, this keeps on happening.. please help..
  10. Shotgun84

    Shotgun84 Well-Known Member

    Have you tried changing the channel your router uses? I had all sorts of problems connecting my old gs2 to my wifi and it turned out that my house phone was using the same frequency as the router and was interfering. After changing the channel from 7 to 11i I haven't had any problems either with the s2 or s3
  11. newcomer21

    newcomer21 New Member

    I have had a similar problem. I can make a connection but within 5 minutes, I lose the wi-fi connection. I have an Android tablet that has no issues with the same router connection, providing very stable and consistent Wi-fi to all our wireless devices.
  12. quasti

    quasti New Member

    I have a very similar problem.

    My router
    HW Revision 1.1 VENDOR Thomson
    BOOT Revision 2.3.0 SW Revision STBA.01.50
    MODEL TWG870U Software Version STBA.01.50

    Standard Wifi settings (auto channel select)

    I have constantly problems with the Samsung and I am tempted to believe that it's an issue with the WiFi module because I don't have any other issues with any other WiFi device. I use 2 iPhones 2 Laptops and sometimes a tablet all over the same hotspot and neither of them are showing the behaviour like the SGS3 does.

    I can connect to the AP and have full bar (sitting directly next to the router) and don't have a connection to the internet. SGS3 status shows connected and IP address 192.168.0.18 but the router shows me 10.56.4.79 under the same MAC address. Now you might think that this is router config problems but why is this not happening with any other device?

    I will now try to change the band and play around with the router settings but to be fair, that very much looks like a strange DNS/wifi module problem inside the SGS3.

    In addition to the above, when I am in the next room, the iPhone has lets say 3 bars, the sgs3 has baaaaaaaaaaarely 1 bar. :)

    Does anyone have similar problems? Would be interested whether Samsung acknowledged this problem already or whether I just have a "monday" device...

    Cheers guys
  13. onthehunt

    onthehunt New Member

    I also had a wifi connectivity issue with my G3. My E4GT connects easily to wifi and doesn't drop the connection. The G3 scans and finds the router but won't authenticate. It continues scanning and then displays and authentication error message. I use wifi a lot and this is a deal killer for me, in addition to a couple of other issues, with the G3. Read somewhere that someone changed their router setting and turned on Dynamic Routing which made their wifi work.

    I upgrade my phone every year so I've had several smartphones. This is the first new phone I've had that has so many glitches. I don't expect a new phone to be perfect, but I only had the G3 for a few hours and was disappointed quickly with some features. My E4GT has been a great phone for me. It's a business phone and gets heavy use with email, text, internet, scanning docs, navigation, camera, etc.

    I had Sprint reactivate my E4GT. The G3 is going back to Sprint. I can wait a little longer so the bugs can be worked out on the G3.
  14. hammer00223

    hammer00223 New Member

    heres the fix. Got it from a uk website but worked perfectly on my sprint s3

    1 open phone dialer
    2 dial *#0011#
    3 when u see servicemode screen click on fixed menu button bottom left
    4 select wifi
    5 itll be in wifi power save mode. Click that off
    6 thats it. If u have a router saved choose forget then reconnect so it refreshes
    coleoptera1 and parapluie like this.
  15. onthehunt

    onthehunt New Member

    @hammer...thanks for the tip. I received my G3 on July 2. When the phone wouldn't connect to wifi, I googled G3 wifi and found many others were experiencing the same wifi issue. I called Sprint tech support and the tech hadn't received any calls about it. He really wanted to help so he also googled the issue while I was on the phone with him. He saw there is a problem with G3's wifi. He actually provided me with the tip you provided but it didn't work. I've read other people tried the fix but it didn't work for them either. Sprint said the wifi issue is with Samsung so he connected me with Samsung tech support. The Samsung tech couldn't fix it either. She wanted me to send the phone back for repair, but I told her I was going to return it to Sprint. I got the impression that Samsung knows there is a problem with G3's wifi.
  16. ewingr

    ewingr Well-Known Member

    There's a few posts on this problem over in XDA too. I am having the issue as well (AT&T phone).

    I called Samsung, and they said "Google will have to fix it. It is a software issue. WE do the hardware". uh...like it couldn't be a hardware issue.

    Anyway, someone else in one of the threads there says they have had several conversations with Samsung, and that they are aware of it and working on it. Who knows though...

    I sure hope it gets fixed.
  17. universem2

    universem2 Well-Known Member

    Possible solution from XDA go into your router settings for QoS then enable WMM. Please let me know if this works, as I would love this to be the solution for the wifi issues.
  18. gabquintero09

    gabquintero09 Well-Known Member

    I own a BELKIN router N+ and FYI, if you have a personal firewall on your computers, I would suggest you disable the firewall on the router, as it caused me HUGE amounts of headaches.. I have been using belkin routers for years and never have I had a problem with them besides the firewall..

    I run a 25MB line and have 2 laptops, 1 desktop, 2 Ps3s, 1 Wii, 2 blackberrys and now my Galaxy S3 all connected to the router, no problem at all..

    if disabling the firewall makes you uneasy, just hide the SSID broadcasting, that way if somebody doesn't know the name of your network, they can't connect or wouldn't know it even exists..
  19. traouroud

    traouroud New Member

    We have tried all the SGS3 "solutions", but nothing works.
    The problem is a poor WIFI signal comming out of the SGS3.
    Even if the WIFI router signal is ok, the connection cannot be made, because of
    the poor signal (works about 2 - 4 meters) of the SGS3.
    How to check it:
    - set SGS3 to WLAN-Hotspot
    - install "Wifi Analyzer" (from Play Store) on another android phone
    - now we can check the signal of the rooter, and the SGS3

    Still waiting for a solution. Or is it a hardware problem:confused:
  20. coleoptera1

    coleoptera1 Member

    We received 2 Verizon s3s yesterday. One was fine, the other had WiFi issues,it would site connected to our hone network, but mail and facebook wouldn't load. This fixed the problem. Thanks

    Well, it turns out that it works for a while, but once it loses the wifi connection (leave the house) my husband has to do it all over again when we get back. IT IS NOT the router. We have 2 identical S3's (32GB), and mine has no troubles. We'll be calling Verizon tomorrow.
  21. ewingr

    ewingr Well-Known Member

    Well, seems to me that this is a fairly common problem, but maybe not a high percentage of folks. Not seeing enough complaints. Although I am certain that if it just disconnects, then reconnects, many people won't even know they have the problem.

    At any rate, one person over on XDA exchanged his phone, and he says the new one is fine.

    I'm going to give that a try.
  22. coleoptera1

    coleoptera1 Member

    The problem is that it doesn't reconnect. It disconnects and then you don't have wifi until you follow the *#0011# process. Very frustrating. This is not all the phones, but it is across carries so who knows. Unfortunately we are on Verizon, so they wont be at the stores until Wed, and I don't know if they will even have any 32GB at the stores. So an exchange may not be a quick fix for us.
  23. boom10ful

    boom10ful Member

    Thanks everyone for your help. After hours of trying to get it to connect I ended up buying another router and it works now.
  24. Naquden

    Naquden New Member

    I bought the S3 about three months ago, first it work perfectly, but after som firmware upgrades the wifi starts to bugg.

    And how do i know it's the S3 thats the problem:
    - I noticed i couldnt connect to some routers(tried several) but on the same routers i've mananged to connect with other phone(S), and my laptop.
    - I cant find the networks, dispite my laptop have full strength, however if i get within 1m range to the router i find the network but it's really bad connection-strength, and i loose the connction often.

    I dont know whats causing this problem but it's obviously the S3 device thats the problem, And the problem first occured after the firmware upgrades. Dont know if I should turn it in for repair, or downgrade.
  25. Tagsfordroid

    Tagsfordroid Member

    this is a known bug...but on jelly bean. Weird you are seeing it. In jellybean the wifi icon just turns gray after a few minutes and stops transmitting. You have to disable/enable wifi for it to work again. Worse part is it only happens on some routers so its harder to debug.

    -tagsfordroid.com

Share This Page