Samsung Galaxy SII Problems/QuestionsSupport


  1. GVity17

    GVity17 New Member

    Hi guys, my name's Nick. I've had the Galaxy SII since last December. It never really gave me a problem, until I about 3-4 weeks ago.
    The current problems are as follows:
    • Unfortunately, the process com.google.process.gapps has stopped.
    • The screen randomly flickers and then shuts down, and drops battery to a critical level.
    • It freezes after each action.

    So here's what I think caused the problem, I downloaded some emulator apps from the market and ran some ROMs on the phone. The errors annoyed me, so I uninstalled the apps, they still persisted. I did a factory reset about 2 weeks ago thinking that would remove any problem and make the phone like new... I was wrong. The battery charge percent still randomly dropped to nothing. I decided to do the Android update to my phone to like 4.0.4 or something like that thinking "Hey, it'll overwrite everything and make it all good." I was wrong again. Now it cause the phone to freeze after every action I do, and following the freezing, the google gapps errors occurs and closes whatever I'm doing.

    That about sums it up. If anyone knows how to fix or solve these problems or one of them, please let me know, thank you:)

    And let me know if you need more info.!

    Advertisement
    :
  2. angrybirds365

    angrybirds365 Active Member

    my girlfriend has this phone, and she has similar problems :/ let me know if you find something!
  3. Atma

    Atma Well-Known Member

    Welcome to the forums Nick. :hello:

    I know you say you have done a factory reset before the update, but after an update it is usually necessary to do one to clear up issues. The com.google.process.gapps problem is a good indication of needing a factory reset. I would suggest trying that again.

    What model S2 do you have and which carrier?
  4. GVity17

    GVity17 New Member

    Thank you!

    And I thought that I should do another since I did the update, I just didn't wanna backup everything again, I'm a bit' lazy I guess, hahaha.

    Anyways, yeah, I'll do the factory reset right now and get back to you!

    I have Sprint and as for what model, I do not know! I guess I'm a hardware noob. Where can I find which model it is?
  5. Atma

    Atma Well-Known Member

    If you have the Sprint Galaxy S2 I think it would be the Epic 4G Touch. If you go in settings and go to About Phone, look for Model number. If its the Epic I think it will say SPH-D710. If you can tell me what it is I'll move this thread in that forum where you might find more members with the same problem and maybe a solution.



    Do you know which carrier? Tell her to sign up. We'll help her out. :)
  6. GVity17

    GVity17 New Member

    Well thank you for all the help and stuff guys. Today when I got out of class, I tried to turn my phone on and it got stuck on the boot screen. So I had enough and I called Sprint! I did a factory reset and did some more stuff and it fixed that problem and the google.gapps problem! So you were right on that! Lol. However, now, the Home button is muffing up! Any solutions? It still does a light vibrate when I touch it, but it has no effect.
    Also, it is the Epic 4G Touch thing:p Thank you!
  7. Atma

    Atma Well-Known Member

    Okay, let's try it in the Epic forum. :)

    What's wrong with the home button? What did Sprint say? Can you get a warranty replacement?
  8. Netcat

    Netcat Well-Known Member

    I read this on XDA developers...someone else had the same problem.

    It may be that the setting for the home key has been accidentally changed. You could try this - on any of the home screens, pinch to reduce size. All the home screens will now be visible with a home emblem on the bottom of one of them. Tap menu, tap set as home, tap on the screen you want as home, tap done, then press home and see it that worked.


    Atma likes this.
  9. GVity17

    GVity17 New Member

    I just tried that and it failed to work. It was saddening. Lol.

    And thank you for moving it to the appropriate Forum! Sprint said to take it into the store, but I really don't want to do that, they also said I could get a replacement, but eh, that's too much work for my liking, Lol. I read some places online that if I reboot it a few times, I don't know how true that is though!

    *Edit: Randomly, it started working again... Weird. Anyways, thanks for the help guys! I probably just need to get a new battery to fix it from randomly dying out.
    Atma likes this.
Loading...

Share This Page