Samsung GS4 Bricked. Odin Firmware flash says "invalid ext4 image"

Last Updated:

  1. nathan968

    nathan968 Member

    My new Samsung GS4 google edition no longer works.

    I have no idea how I got here but the point is, this is my situation:

    My GS4 boots straight into the recovery. I have installed different recoveries, including CWM and TWRP. Both flash from odin with no problem. I can install a ROM via either recovery but when I reboot it still goes straight into recovery. I have tried all types of data wipes and cahe wips, none of those work either. I have also tried using a PIT file and a kernal file instead and with the system firmware md5 file. I have also tried all these in Odin v3.07 and Odin v1.85 with the same results.

    I have downloaded a number of stock images specifially for my phone (only differece in them is that they have different country codes). I read that they all should work and when I try to flash it via Odin I get the error "FAIL! (Ext. 4)" in the odin messsage window and my phone says "ODIN: invalid ext4 img"

    Does anyone know how to get this to work? or another alternative to fix my phone.

    Any help is appriciated.

  2. jhawkkw

    jhawkkw Chinchillin' Moderator

    Since this looks like it will be more of a help thread, I've moved it to the S4 GE root forum.

    Since the S4 GE is only available in the US, I'm curious as to why you're seeing different country codes. The model number you should be looking for is I9505G. I'll take a quick look at sammobile and see. Also, when you flashed the pit file, did you flash it with the factory image or by itself. You should always flash a pit with the image or else that can really cause big problems.
    nathan968 likes this.
  3. nathan968

    nathan968 Member

    I did download an image from sammobile and it was for the I9505 model number. I was just confused on the wording for that.

    As for the PIT file, I know I have tried flashing the PIT file with the stock firmware and it did not work. Honestly, I might have flashed the PIT file by itself at one point.

    Does that mean that I have permanatly bricked my phone?
  4. jhawkkw

    jhawkkw Chinchillin' Moderator

    If it turns on, it should be fixable. The 9505 file you downloaded isn't technically for your device, you need to find one for the 9505G. Though I have had much luck finding a 4.2.2 image, just an incomplete 4.3 leak. :(

    I'm still looking though.
    nathan968 likes this.
  5. jhawkkw

    jhawkkw Chinchillin' Moderator

    nathan968 likes this.
  6. nathan968

    nathan968 Member

    That's a great find! I appriciate you helping me out!

    Turns out they have taken that specific file off of the site for some reason!

    So if I could find the factory image for GT-I9505G and NOT the one for GT-I9505 you think it will fix my phone?
  7. jhawkkw

    jhawkkw Chinchillin' Moderator

    Yeah, that's what we need to find. That was the only possible complete image that I've found so far though. :(
  8. nathan968

    nathan968 Member

    jhawkkw likes this.
  9. jhawkkw

    jhawkkw Chinchillin' Moderator

    Yes, because the pit files are different, you will want to flash the pit in the pit section for the 9505G, along with the full image in pda. If a modem flash is required and isn't part of the pda image, then that goes in the phone section. Also, you'll probably need to extract the rar because odin usually flashes .tar files, not rars
  10. nathan968

    nathan968 Member

    Okay so in the file there is a pit file, one that says CSC, one that says MODEM, and one that says PLATFORM. Where do I put the PLATFORM file?

    Exact File Names:
  11. nathan968

    nathan968 Member

    Nevermind, I guess Platform has to be PDA.

    Thanks for your help! I will try to flash these right away!!
  12. jhawkkw

    jhawkkw Chinchillin' Moderator

    I would flash the whole thing, putting each part in the necessary spots. Also have auto-reboot, f. reset time, and re-partition checked.
    nathan968 likes this.
  13. nathan968

    nathan968 Member

    Alright, that worked! phone works perfect now!

    Thank you so much for your help!
    jhawkkw likes this.
  14. jhawkkw

    jhawkkw Chinchillin' Moderator

    Glad I could help. :)
    When I get back to a desktop, I'm going to add that mega link to the ATR sticky.

Share This Page