Samsung gs4 can't receive text messagesSupport


  1. makane716

    makane716 Member

    Got the Samsung Galaxy S4 5 days ago. Everything seemed fine, except I can send texts but do not receive them. I can receive the pictures in a picture text, but not the text body. 4 days ago Sprint said perhaps it was a software problem. The 'yellow tag store' guys tried some stuff and concurred. Did the factory reset, removed the battery, got a replacement phone 2 days ago. The replacement phone received texts while at the 'yellow tag store' where the phone was purchased and replaced. Thought all was well. Today then, again with the not receiving text messages. Tomorrow this *EDIT for vulgarity* phone may come into direct contact with the wall at an accelerated rate of travel. Seriously though, any help would be greatly appreciated.

    Advertisement
    :
  2. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hello and welcome to the forums. I see your having a problem with android device . Can i ask are these new phones you are getting cause it seems that these maybe used phones . And what is the yellow store .
  3. makane716

    makane716 Member

    These are brand new phones. "yellow tag store" refers to Best Buy. Wasn't sure if I am supposed to call out specific retailers.
  4. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hey its better to say which one sold u the device cause someone else may post the same thing . But over here on the east that yellow tag store will have me thinking about the famous walmart . . Now that u said best buy i know someone that lives inside my building that had brought a device and guess what the dang thing wasn't never activated . And they tried to cover it up .
    makane716 likes this.
  5. makane716

    makane716 Member

    All of my incoming texts were going to my gmail account. On my previous phone, Samsung Nexus S (Google edition), I had been using google voice. When they transferred all of my accounts/info/contacts to the S4, somewhere along the line the google voice settings caused the problem. I could send texts using the messaging app, but incoming texts were going to gmail. I logged in to my gmail account (on my pc) unchecked google voice and BOOM! Sweet success!
Loading...

Share This Page