Samsung I5700 (Galaxy SPICA) Android 2.1 Flashing Guide - ENGLISHTips

Last Updated:

  1. Orfeas91

    Orfeas91 Active Member

    Yeah, noticed that as well :D
    See you around mate

  2. FuriousAngel

    FuriousAngel New Member

    Yeah it's 2.1 right now. It's been like 4 hours by now. Generally it seems OK. As I said, I had some problem with APN configuration at the beginning, but it is ok for now. One problem I've encountered so far is with contact list. I added like 5 contacts but it only shows the first one i entered. But if I search it manually it shows the other contacts and shows their info when they call me. Maybe it's my inability:D. Another thing, I can't still use multi-touch. Maybe i5700 doesn't support it, I'm not sure.

    I don't know that if all i5700 are the same but, on my i5700 (bought from Dubai) there was no Android Market with 1.5. With 2.1, I can use it. Tried some apps already.

    By the way, with 2.1 firmware, it's like I'm using whole different phone.

    I'll let you know if I encounter other problems.

  3. Orfeas91

    Orfeas91 Active Member

    Yeah, I've read to another site that it doesn't support multi-touch.
    Well, what to do we can't have everything :D

    Yeah I can't wait to try that.
    I am considering trying the way you did it -removing the CSC from Odin-, but I am not sure. Maybe I'll wait for something more official, I don't know.
  4. greaky

    greaky Member

    This rom does not have support for multitouch.. heres hoping when they finally release the official version it will have multitouch :)

    I have noticed some APN issues too but they kinda get alright on their on. Installed this application called APN BACKUP AND RESTORE.. pretty cool that one.
  5. FuriousAngel

    FuriousAngel New Member

    This one is proven to be my inability.:) After entering Contacts, pressed the menu button. Then selected the Display options. Selected my gmail account name then checked all boxes. Especially the blank one and this problem is solved too.
  6. bluechill

    bluechill Member

    Does this mean the phone isn't bricked yet?

    and that there isn't any risk in trying to update the 2.1 firmware, since if we're stuck we could simply remove the phone battery and reboot?
  7. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member

    Most probably :D
    Since there is no communication, so no brick i mean.

    I'll suggest, don't take risk n wait for the official release rather :)
  8. rusty4ever

    rusty4ever Member

    hey i have read on some russian forum that i5700 has multitouch support....
  9. mahipal007

    mahipal007 New Member

    when is the official upgrade coming ??????????????????????
  10. acoole

    acoole Well-Known Member

    How did you avoid the brick, just take the battery out?
  11. Orfeas91

    Orfeas91 Active Member

    Just remove battery, unplug, insert battery again and then plug in again on the computer. You should see the charging battery image. Then power on and done
  12. iKelvinn

    iKelvinn Member

    Flashed for the first time, I downloaded a corrupted firmware and thought it was bricked, but flashed again and now the cool 2.1 Eclair :D
  13. andy-roid

    andy-roid Well-Known Member

    how do we no that this is recently leaked Android 2.1
  14. aproka

    aproka Member

    hi, thanks for the guide which worked like a charm except that i had not to flash csc as it wasn't working with that.

    although i experience a couple of minor/not so minor issues:

    apn settings cannot be saved (they can be but it's not appearing on the list and are not functional) so hsdpa/3g is not working

    live wallpapers only appearing at the lock screen, on the home screen i see the static wallpaper set.

    google earth, ustream broadcaster apps won't start
  15. greaky

    greaky Member

    APN thingy is erratic, you can try restarting the phone when that happens, it works for me after a restart. Also i have installed an application called APN Backup and Restore..just in case.

    I face the same issue with the livewallpapers.. apparently it needs a modified Launcher.apk which is available on the forum.. but i did not like I am sticking with my Herohome Free :) I can live without livewallpapers for now..

    notsure about google earth and upstream broadcaster though.. dont use them.

  16. greaky

    greaky Member

    see the screenshots...

  17. aproka

    aproka Member


    have anyone experienced random reboots of the phone with the 2.1 firmware or is it just me?
  18. greaky

    greaky Member

    Yes it does randomly reboot at times.. but I am not complaining lol ..

  19. aproka

    aproka Member

    me neither :) the whole thing feels much more polished than the 1.5 was, and without my apn settings it can keep up with battery more than a day lol
  20. bennychen

    bennychen New Member

    Hi..i been enjoying this 2.1 but i had problems..i cant download any apps from market..its giving me the message 'download unsucessful'
  21. nx1977

    nx1977 Well-Known Member

    Check your time and date are correct, and do not use automatic updating.
  22. sriharsha_m

    sriharsha_m Member

    Uffff Finally got it done.
    That modem driver was the issue, For me the modem was installed as "Samsung CDMA Modem" no matter what I did, fiddled around for 3hrs and then I tried updating the device drivers and updated it with the drivers from that guide and Viola everything is over within 5 mins and I'm on 2.1 :D

    For those who are getting some image error in ODIN, run the application as administrator.
  23. viohazardz

    viohazardz New Member

    can anybody help me. i think i bricked my spica while updating to 2.1.
    i tried to reflash it again but im stuck at setup connection. can i unbrick my phone. thnx
  24. Beerkan

    Beerkan Well-Known Member

    Possibly. I've flashed and upated my phone many times, and only once had an issue. I had to flash way back to an earlier firmware, using as All-In-One firmware, before bringing my phone back to life.

    Follow these instructions (to the letter).

    You must follow Flash Guide I ie. The ALL-In-One Flash update using ONLY TWO files.

    The spica_jc3.ops file and All-in-One I570EXXJCE.tar

    Use Flash 1 All-In-One Guide

    Once I had this firmware installed, my phone booted ok, and I was able to re-flash up to my latest firmware.
  25. nailz

    nailz Active Member

    I tried to do this before, but got stuck on the "mapping com ports" stage.

    using Win7 64bit....

Share This Page