Samsung I897 Captivate Froyo 2.2 Rooting


  1. bryancandle

    bryancandle New Member

    I have tried to root the Samsung Captivate I897 using Froyo 2.2 OS and there seems to be no way to do it without having the "certificate verification" error during installation.

    I have tried to use one-click rooting systems, various different update.zip files from many different sources and none of them have worked.

    It appears that the 2.2 version of android for this phone has been secured so that rooting is not possible. I realize one way to root the phone from this point would be to flash back to 2.1, but that is a pain.

    Has anyone experienced the same problems and successfully rooted the phone without reverting back to 2.1?

    Advertisement
    :
  2. kaepos

    kaepos Active Member

    vilamonster likes this.
  3. reichberger

    reichberger Member

    I have the same sad story to share.
    1. Official upgrade Captivate to 2.2 Froyo
    2. Tried every conceivable method to root.
    3. Get "e signature verification failed" error everytime.
    I just feel that there is a special update.zip file that needs to be had to root the 2.2. Can anyone shed some ligt on this?

    If not, could you direct me to the process to downgrade from 2.2 to 2.1 and I'll try to root from there?

    Thanks in advance,

    reichberger
  4. jetpuck73

    jetpuck73 Well-Known Member

  5. Big Pope Daddy

    Big Pope Daddy Well-Known Member

  6. 2manyPHONES

    2manyPHONES Well-Known Member

    same here superoneclick worked great for me and took less than 5 minutes.

    when you use the superoneclick are you using the captivate tab? i tried that and got the error. from what i read that tab is for 2.1 captivates. try using the universal tab. thats what worked for me as it is for android OS 2.2 and higher
  7. automagrt

    automagrt Well-Known Member

    Ok, so I'm about to root my Captivate running 2.2 using superoneclick which I haven't used before. I take it based on this thread that I don't use the Captivate tab. What options do I choose on the Universal tab - Root or Shell Root? What exploit - psneuter or rageagainsthecage? Is "Allow Non-Market Apps" something I need to do after rooting if I want to install the Amazon App Store?

    Thanks a bunch!
  8. xThaNaturalx

    xThaNaturalx Well-Known Member

    You should be using "root". As for the exploit, start with "psneuter". If it doesn't work, try rage. If you read through the threads, it talks about getting past the "waiting for device" part. The way that it worked for me was starting with USB debugging off, then clicking root, then when it says "waiting for device", unplug the phone and turn on USB debugging. Then plug it back it back in. If you read on, it says that a lot of the time it will switch from psneuter to rage if you have to do one of those fixes to get past the looping.
Loading...

Share This Page