1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

Samsung Infuse Straight Talk APN help please?Support

Last Updated:

  1. Dreamfire

    Dreamfire New Member

    I'm at my wits end :(

    I have a Samsung Infuse that I activated on Straight Talk. The phone was factory reset on Sunday. I activated ST last night. I have tried every combination of APN's I can find. NOTHING is working. I still have no internet or MMS.

    One thing that I am finding is that in the APN type, I don't have the option to type anything. I can only choose one of the presets which are" internet+mms+supl, Internet, MMS or SUPL. I have tried not entering anything but the information ST provided and it automatically fills that field to internet+mms+supl. None of the options are working.

    I spent 45 minutes on the phone with ST today and they assured me everything is set up correctly on their end although who knows if that is truly the case.

    I also tried another suggestion posted in another thread which was to use H2O. I tried that and it still didn't work. It did however give me the ability to delete the AT&T APN settings which I hadn't been able to do previously.

    Can anyone help me with this? I am really new to this (obviously) and really need help.


  2. tbzj7

    tbzj7 Well-Known Member

    Old thread but thought I'd try and help with anybody looking to use their infuse on straight talk, just activated mine and everything's working fine.

    Name - Straight Talk
    Apn - att.mvno
    Proxy - proxy.mvno.tracfone.com
    Port - 80
    Mmsc - http://mmsc.cingular.com
    Mms proxy -
    Mms port - 80

    Leave all other fields blank and delete other apn's if possible.

    Select the apn you just created

    Restart your device
    Justinsaneok likes this.
  3. rogerwright

    rogerwright New Member

    I just used your settings for straight talk, and I now have an Straight talk APN selected, but I still have no internet connection. Is there a way to delete the T-Mobile APN that is still there unselected, or is there another solution to this with the MMS settings? You said to leave everything blank after MMS port 80, but the MCC already had 310, and the MNC had 260 is that correct to just leave them like I did? Any help on this would be appreciated, thanks.
  4. rogerwright

    rogerwright New Member

    thank you do you know why it wont go online after putting those setting in?
  5. tbzj7

    tbzj7 Well-Known Member

    If you already had settings in your fields, you need to delete that APN and create a new one, with the fields above, except lately I've found that if you leave the proxy field blank, internet works much better. And I do not believe you can delete factory apn's
  6. sweetsuzannah

    sweetsuzannah New Member

    This worked perfectly for me. Thank you so much as it was very different than what I was getting from other sites INCLUDING wrong on Straight Talk's site

Share This Page