Samsung mobile MTP Device cannot be installedSupport


Last Updated:

  1. YoussefWahby

    YoussefWahby Member

    I really tried everything i posted on the internet, and i still get that error for only this component. I had it working for a while, then it stopped, i have no idea why.

    I removed drivers, and kies, then reinstalled them, then put my mobile on debug mode, and everything was recognized. The i ticked off debug mode and i still got this error. I am really going crazy.

    Advertisement
  2. naith_kk

    naith_kk Well-Known Member

    Have you tried changing USB ports? Try to use ports directly connected to your PC instead of a USB hub... see if that works.
  3. YoussefWahby

    YoussefWahby Member

    I don't use a usb hub, and it is the same port that worked before. But I will try a new port anyway.
  4. YoussefWahby

    YoussefWahby Member


    No it didn't work :/
  5. naith_kk

    naith_kk Well-Known Member

    What I can suggest you do is to read a post made by Hawker regarding about phone connectivity... try these tips and see if your phone re-establishes its MTP drivers.

    The tips you should be focusing on are after the section: "If you can NEVER get your PC to see your GS2" part... all the way down to the link for manuals.

    If somehow your phone still can't get those MTP drivers initialized for any wierd reason, you'd want to try force resetting your USB interfaces.

    If all else fails (for Windows specific instructions):

    1. Ensure phone is not connected to PC.
    2. Uninstall KIES from PC. Reboot your PC and Reinstall KIES after that. Just for great measure... open KIES, go to Tools | Troubleshoot connection error. Follow instructions and wait for it to finish the troubleshooting procedure.
    3. Reboot your phone (or turn off and then on your phone again). Do not connect it to your PC just yet.
    4. Once rebooted, go to your phone's dialer, type *#7284# - A configuration window will appear. In that window's USB section, if it's default to PDA, tap MODEM, then back to PDA, (if it is MODEM in the beginning, change it to PDA) then press the back key to exit. Most importantly, it must set as PDA when you exit.
    5. Turn off USB debugging in your phone.
    6. (Optional) Set your phone's screen timeout to a lengthy time. (minimum 1-2 minutes - recommended 5mins to 30mins) its found in Settings | Display. You can change this back later on.
    7. Connect the phone to your PC with USB cable and let windows load your drivers... and wait for the drivers to get reinstalled.
    8. Once reinstalled, disconnect the phone off USB. Switch USB debugging back on in your phone settings, and reconnect the phone back - you'll see windows load another set of drivers for your phone. Wait until it is completed. (This step is a precautionative measure to ensure your phone is identified with all the necessary drivers)
    9. Once complete, unplug your phone, and turn off USB debugging... This is to ensure MTP will initialize. Also, press the phone's home key until your homescreen is displayed. Only after doing all that, reconnect your phone back to PC.
    10. Test and see if MTP works using Windows Explorer. You'll see your phone's USB storage and SDCard contents if it does.
  6. sg3geek

    sg3geek New Member

    I found a solution that worked. It's for a Samsung Galaxy S3, but should still apply to this issue. Below was the method I used, followed by further explanation. You may not need to follow these steps exactly, but they're the steps I used.

    1) Plug Samsung Galaxy S3 phone into computer's USB port. You will get the MTP driver failed to installed message.

    2) Backup SMS / MMS using a backup app (like MyBackup Pro).

    3) Factory reset phone (while still plugged into computer).

    4) Do NOT sign in to your Google Account when phone resets - This is CRITICAL. You can do it later.

    5) Basically, just get the phone started up again without signing into any accounts (like Dropbox, Samsung account, etc.)

    6) MTP driver should have automatically installed on computer - if not, then unplug phone from computer and reconnect.

    7) Sign into your Google Account, and feel free to re-customize your phone at this point.


    Explanation and Notes:

    1) I factory reset my phone 2x in a row. The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install. I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings. This interferes with the initial MTP driver installation. The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed. Only AFTER I was able to connect to the computer did I sign in to Google Account.

    2) Previous to this solution, I had tried every solution I had found online including:

    a) checking / unchecking USB debugging mode
    b) toggling between MTP mode and Camera mode
    c) changing some hidden Android settings
    d) using different USB cables (the one that came with the phone along with others I had)
    e) uninstalling and reinstalling the Samsung drivers
    f) uninstalling and reinstalling Samsung Kies
    g) Device Manager in Microsoft Windows - deleting everything under Universal Serial Bus Controllers so it would reinstall upon Windows restart
    h) cleaning registry
    i) trying to connect to different computers (it didn't work)


    I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera). The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.


    For those of you who have tried everything suggested online to connect to the computer, I hope this solution helps!
  7. martskii

    martskii New Member

    I trolled the forums with mixed information.

    What worked for me was this:

    Go to connected as media device - take it off the Media device (MTP) and put it on Camera (PTP) and then back on Media device (MTP) again.

    Must have reset some setting or something.

    Good luck peeps

    :):):)
  8. fbuehner

    fbuehner New Member

    It appears there are several issues with the MTP driver not loading. I spent two days including a dismal session with Verizon tech support. For my phone the problem was the SD card. I upgraded from a Samsung Omnia and simply removed the SD card and placed it in the galaxy S3. I'll bet many do this without thinking it could be a problem.

    Removing the SD card finally solved the driver MTP driver install problem. The drivers load properly and all functions except the SD added memory are working. Nice phone now that I can sync and add content.
  9. yorkie d

    yorkie d New Member

    After I too got the error message I used windows update. The first time it again failed to install the MTP but the second time I clicked check for updates it installed correctly.
  10. stevopativo

    stevopativo New Member

    I had to upgrade to Windows Media Player 10 before it would install that driver correctly.
    stabesh likes this.
  11. rogermass

    rogermass Member

    These are some really awful suggestions. Factory reset is particularly crazy. Just remove your SD card, install the drivers then reinsert. This is caused by the new awful Kitcat SD card write restriction. After connection you can read the SD card but not write it from the PC and the internal SD is still read/write.
  12. ironass

    ironass Well-Known Member

    Duh! :stupid:

    Not as daft as your comment rogermass.

    KitKat, Android 4.4.2, has never been officially released for the Samsung Galaxy S2. Therefore, it cannot be causing the problem.

    ironass motto... "A little knowledge is a dangerous thing!"

Share This Page