1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Samsung Moment TetheringSupport


  1. TheEsupremacy

    TheEsupremacy Member

    I have Windows 7 64 bit and for the life of me I cannot get this up and running. I have tried everything. Did anybody actually get PDANet up and working on this OS? If so, how the hec did you do it? I have tried all suggestions listed so far. Nothing works. :(
  2. NOMster

    NOMster Well-Known Member

    I'm running xp and it won't load the drivers. keeps going into error and stopping. oh well.
  3. cheesemoo

    cheesemoo Active Member

    TheEsupremacy, are the drivers not installing properly? Or is the problem with PdaNet? I haven't gotten PdaNet working on my Win7 x64 machine, and probably won't bother because I got azilink working (and it's free).

    NOMster, can you post some more info about the problem you're having? I'm going to try getting the drivers installed on XP 32 bit right now. I'll post back with my results.
  4. cheesemoo

    cheesemoo Active Member

    Okay, I got Azilink working under both WinXP-32 and Win7-64. All I needed was the zip file with the drivers (posted earlier in the thread), OpenVPN and the Azilink OpenVPN config file, the Azilink app, and the latest version of adb from the Android SDK.

    usbdview can come in handy if you want to look at your USB devices, but keep in mind that although it will uninstall the drivers for a device, Windows will just reinstall the same drivers when you plug it back in. To stop that, you have to uninstall the device from device manager, and check the box that asks if you want to delete the drivers from your hard drive. If you have drivers installed that aren't working, you should give that a try to get rid of them. Then install using the ones in the zip file.
  5. cheesemoo

    cheesemoo Active Member

    I put together a package with everything that I used to get tethering working with my Moment in XP-32 and Win7-64. I assume it'll work with other versions of Windows, including Vista. There's a readme inside with the basic steps I took to get things working. Let me know if you have problems!

    I uploaded it all over since I'm not sure which sites have time limits on free account uploads or whatever.

    Download links:
    Sendspace.com
    Mediafire.com
    RapidShare.com
    GigaSize.com
    MEGAUPLOAD.com
  6. NOMster

    NOMster Well-Known Member


    sure. it loads fine the whole package installs but then when it gets to the driver install, it hangs and throws out a "failed to install, do you want to report this problem to microsoft"
  7. aboutDbuzz

    aboutDbuzz Member

    Thanks for binging it all together. Your instructions are great! But I was still not able to connect to the internet.
    After following your instructions in the 'read me' file, I went to internet option and added the Samsung modem (I have windows XP) as a dial-up option, #777, left the username and password blank. Did I miss anything?

    I am getting the error code: 698
  8. cheesemoo

    cheesemoo Active Member

    So let me make sure I have this right - you ran through all the instructions and everything seemed to go well, is that right? You shouldn't need to set up a modem connection in Windows networking. OpenVPN makes a tunnel over the ADB interface to your phone, which acts as a router for you.

    What sort of output do you get when you run the "Start Azilink" batch file? Once you run that file and it sets up communication with your phone, you should be able to connect to the internet. Post back with what it says, and I'll see if I can figure out what's up.

    Also, just wondering, you say you're on Windows XP. Are you running 64 bit or 32 bit? On your start menu, press Run, and type %PROGRAMFILES%. Tell me what folder that takes you to. For example, on my XP-32 machine it takes me to "C:\Program Files". If your program files directory is on another drive, this could break the batch file.
  9. cheesemoo

    cheesemoo Active Member

    NOMster, it sounds like you are installing PdaNet or the Samsung Studio program. Both of those failed to install drivers for me too.

    What happens when you plug in your phone (when your phone has USB debugging enabled)? Does Windows ask you about installing drivers, or does it do nothing?

    If it asks you about installing drivers, then use the drivers in that zip file (linked above by LincKraker: http://randomtechinfo.com/Moment/Samsung Moment USB Drivers Windows.zip) or use the drivers in my zip package (they are the same).

    If Windows does not ask you to install drivers, then it sounds like you have some drivers installed already, and they might not be the right ones. If that is the case, please download usbdeview and post a copy of the "HTML Report - All Items" that you can access from the View menu. You can find usbdeview at USBDeview - View all installed/connected USB devices on your system or in the zip package I mentioned in my earlier post.
  10. The8thst

    The8thst Member

    Thanks for putting this together. I am posting this via my Moment using the Azilink connection.

    The one trip up I ran into is that I have to manually start the Azilink service on the moment (programs -> azilink -> check "Service Active"). Once I did that openVPN connected and everything is working great.

    This will help me out at work quite a bit.

    Thank you.

    PS. I'm new to android so pardon a dumb question. Is there any reason to turn off USB Debugging on the phone when you are not tethering?
  11. NOMster

    NOMster Well-Known Member

    link won't work and neither will image. so copy and paste time.i just did the ones relative to the phone drivers.

    file:///C:/DOCUME~1/Eric/LOCALS~1/Temp/Temporary%20Directory%202%20for%20driverview.zip/report.html
  12. cheesemoo

    cheesemoo Active Member

    NOMster, it doesn't look like that worked. Can you try uploading the text from the report to somewhere like pastebin?
  13. cheesemoo

    cheesemoo Active Member

    Sorry I forgot that step. Glad you got it working! I am relatively new to Android myself, but I don't know of any reason to turn off USB debugging. I assume it only affects how your phone presents itself to the computer when you plug it in via USB. I don't have a definite answer though.
  14. NOMster

    NOMster Well-Known Member

    okay, i uninstalled the existing drivers and tried to install the ones from the zip pack but it's not working. when i hook the phone up it tells me the old "there was a problem, blah blah." and pdanet gives me a error 103 and 104.
  15. cheesemoo

    cheesemoo Active Member

    What exactly does it say when you plug in the phone?

    Is there a reason you want to use PdaNet? I have not tried it out, so I can't help you get it working. Please try installing azilink from the package I put together (links in this post). I should be able to help you better with that, or you could email the maker of PdaNet.
  16. aboutDbuzz

    aboutDbuzz Member

    The Azilink file was not installed on my phone when I clicked on the 'Install Azilink to Phone' batch file. I started over and manually copied the 'azilink-2.0.2.apk' to the SD card and installed it manually on the phone. I checked the Service Active, but the 'Status' says 'waiting for connection'. On the computer, the Open VPN is on (not sure what it is supposed to do). But still not able to connect when I open a browser page.

    To answer your questions:
    1. When I click on 'Start Azilink(32-bit)' - I believe that is the right one. (I have a Lenovo Ideapad running Windows XP), it flashed a DOS-like window on the screen for a few seconds and nothing else happens.
    2. When I type '%PROGRAMFILES%' it takes me to 'C:/Program files'.

    Thanks for your anticipated help.
  17. cheesemoo

    cheesemoo Active Member

    Well that's interesting. That batch file isn't running properly - it is supposed to start OpenVPN for you, and should remain open as long as you want to be tethered to your phone. If it is just popping up for a second, then it is probably not starting OpenVPN properly.

    Let's try something to find out what the problem is. Add a new line to the batch file, "pause". This will keep the console open so you can read what it says before it exits. So the whole thing should look like this:

    Code (Text):
    %~dp0\adb\adb kill-server
    %~dp0\adb\adb forward tcp:41927 tcp:41927
    "C:\Program Files\OpenVPN\bin\openvpn.exe" %~dp0\OpenVPN\azilink.ovpn
    pause
    Please post back with the text in the console window, and I should be able to figure out what's wrong.
  18. aboutDbuzz

    aboutDbuzz Member

    Just figured out the problem by trial. You many want to add that on your 'readme' instructions. I had to copy the downloaded 'Azilink' folder to the hard drive. I previously had it on 'My Documents'. It is working now, THANKS!! (Although, it disconnects sometimes for some reason I am yet to figure out).
  19. edp

    edp Well-Known Member

    first off, thanks for all the great info on this thread. tethering is working great with my phone.

    sorry for the newb question, but if you tether too much and you use a lot of data, does sprint figure it out, and call you out on it? has this happened to anyone before? i thought sprint really didn't allow phone tethering so i was just curious.
  20. aboutDbuzz

    aboutDbuzz Member

    As long as you average monthly data usage remains below 5GB, there will be no red flags raised. At the time you are tethering, the network does not discriminate. But use it judiciously. Most users do not exceed this limit in a month. I barely make it to the 3GB mark with heavy use.
  21. TheEsupremacy

    TheEsupremacy Member

    I wish I could get mine to work. I've tried everything. Something to do with Windows 7 64 bit and even the 2.11a update, still no go. I've never been able to NOT install or get something like this working. I fail. :(
  22. RADTECHTX

    RADTECHTX New Member

    new to this and tried following these instructions to the letter except for using pdanet 2.12 special from junefabrics. I've tried I can't tell you how many times to get this to work and it always comes up with pdanetpc.exe encountered a problem. Do you have any ideas about fixing this? I need some type of internet acces at work since they are now blocking most everything w barracuda firewall. I know the work around for that but don't feel like risking my job just to use their internet.
  23. Silverexpress

    Silverexpress Well-Known Member

    Hello, the newer versions of pdanet do not require pc studio. They are standalone executables that contain everything you need - from what I was told by junefabrics. Try uninstalling pc studio, and pdanet. Restart your pc afterwards and try the install again.

    If it doesn't work, it means that something got corrupt. You'll need to find it and remove it.
  24. lgmayka

    lgmayka Active Member

    My nephew got a Samsung Moment this week, and we tried to get his tethering to work.

    1) He installed PdaNet from the Android Marketplace (or whatever it's called).
    2) He started up that program, but it told him he needed to install drivers on his XP laptop computer first. It gave him a hyperlink.
    3) On his laptop, he went to that hyperlink, which was simply a PdaNet installation page. He downloaded the installer and started it.
    4) The installer told him to put his phone into USB Debugging mode and connect it to the computer so that the computer would install drivers.
    5) He indeed set the phone into USB Debugging, and connected it to the computer.
    6) Nothing at all happened. No drivers, no device in the Device Manager, nothing. I ran USBDeview to see if a preexisting driver had grabbed the phone, but saw nothing out of the ordinary.

    7) A Google search suggested to us that we install the Samsung PC Studio (or whatever it's called) on the laptop. We did so.
    8) We then retried installing the PdaNet client on the laptop. Again, nothing.

    What do we do now?

    Are there any other settings on the phone that we need to check?

    Is it possible that everything is now installed correctly, and we should simply try to use PdaNet? I see no instructions--what all do we need to do? Turn on PdaNet, connect the phone to the computer, and then do what?

    Some sites mention a "Mobile Internet Sharing" option, but others say that there is no such option on the Sprint Samsung Moment. Is there one there? Should we turn it on?

    I'm sorry that this sounds so amateurish, but I'm used to my own Windows Mobile, which has no difficulty with multiple kinds of tethering. But I would like to help my nephew.
  25. zefie

    zefie Well-Known Member

    Did you try rebooting the phone (Power it down, remove batt for 5 seconds, power it back up)? This is a known issue that occasionally occurs with the Moment... it won't appear on the computer. Try rebooting the phone and let us know :)
Loading...

Share This Page