Samsung Moment TetheringSupport


  1. jr_mfn_p

    jr_mfn_p Well-Known Member

    hey yall.

    i've installed azilink and i thought i did everything correctly but i guess not i have an error that reads

    windows route add command failed: returned error code 1

    it looks like everything is good except for that and it'll transfer some bytes between phone and computer. any help is greatly appreciated
  2. cheesemoo

    cheesemoo Active Member

    Are you running Vista or 7? Are you using the package I put together? I remember I had to add an extra line to the .ovpn file to get that to work on Vista & 7.

    Try adding "route-method exe" to the top of your .ovpn file if you aren't using my package, see if that helps. Or if you are using mine, maybe remove it :)
  3. jr_mfn_p

    jr_mfn_p Well-Known Member

    yeah i'm usin your package (very well thought out by the way). i've seen somethin about the adb application but everytime i hit it it pops open then closes real quick. do i need to do somethin with that? i'll try your suggestion and see if that works. it seems like i'm close but probably missin some simple step. i often time have "if it was a snake it would have bit you" syndrome.
  4. cheesemoo

    cheesemoo Active Member

    What OS are you running? Can you post the exact output you're getting when you run the Azilink batch script?
  5. jr_mfn_p

    jr_mfn_p Well-Known Member

    i'm runnin vista. i've tried to highlight the text in the azilink box but it won't let me and it won't let me copy it
  6. cheesemoo

    cheesemoo Active Member

    Oh, you'll have to right click on it and click Mark. Then select the text, then hit enter. That puts the text on your clipboard.
  7. jr_mfn_p

    jr_mfn_p Well-Known Member

    well hit mark then enter where is the clipboard?
  8. cheesemoo

    cheesemoo Active Member

    Sorry I didn't explain well - your clipboard isn't something you look at generally, it's just where stuff is when you have copied it. Like if you are going to copy & paste some text, copying it puts it in your clipboard. When you go to paste, it comes out of your clipboard.

    Anyway all you have to do is hit Ctrl+V to paste, or right click in a text box and hit paste (as long as there is text on your clipboard).

    If you really want to see what's on your clipboard I think there are programs that let you see, but I don't really know much about that, I've never used one.
  9. jr_mfn_p

    jr_mfn_p Well-Known Member

    C:\Users\Owner\Desktop\Azilink>C:\Users\Owner\Desktop\Azilink\\adb\adb kill-serv
    er

    C:\Users\Owner\Desktop\Azilink>C:\Users\Owner\Desktop\Azilink\\adb\adb forward t
    cp:41927 tcp:41927
    * daemon not running. starting it now *
    * daemon started successfully *

    C:\Users\Owner\Desktop\Azilink>"C:\Program Files\OpenVPN\bin\openvpn.exe" C:\Use
    rs\Owner\Desktop\Azilink\\OpenVPN\azilink.ovpn
    Wed Dec 16 18:18:07 2009 OpenVPN 2.1_rc22 i686-pc-mingw32 [SSL] [LZO2] [PKCS11]
    built on Nov 20 2009
    Wed Dec 16 18:18:07 2009 WARNING: --ping should normally be used with --ping-res
    tart or --ping-exit
    Wed Dec 16 18:18:07 2009 NOTE: OpenVPN 2.1 requires '--script-security 2' or hig
    her to call user-defined scripts or executables
    Wed Dec 16 18:18:07 2009 ******* WARNING *******: all encryption and authenticat
    ion features disabled -- all data will be tunnelled as cleartext
    Wed Dec 16 18:18:07 2009 TAP-WIN32 device [Local Area Connection 2] opened: \\.\
    Global\{C251ADC4-19D1-4343-A683-D414E3C919E5}.tap
    Wed Dec 16 18:18:07 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 1
    92.168.56.2/255.255.255.252 on interface {C251ADC4-19D1-4343-A683-D414E3C919E5}
    [DHCP-serv: 192.168.56.1, lease-time: 31536000]
    Wed Dec 16 18:18:07 2009 Attempting to establish TCP connection with 127.0.0.1:4
    1927
    Wed Dec 16 18:18:07 2009 TCP connection established with 127.0.0.1:41927
    Wed Dec 16 18:18:07 2009 TCPv4_CLIENT link local: [undef]
    Wed Dec 16 18:18:07 2009 TCPv4_CLIENT link remote: 127.0.0.1:41927
    Wed Dec 16 18:18:10 2009 Peer Connection Initiated with 127.0.0.1:41927
    Wed Dec 16 18:18:16 2009 WARNING: potential route subnet conflict between local
    LAN [10.0.0.0/255.255.255.0] and remote VPN [0.0.0.0/128.0.0.0]
    The requested operation requires elevation.
    Wed Dec 16 18:18:16 2009 ERROR: Windows route add command failed: returned error
    code 1
    The requested operation requires elevation.
    Wed Dec 16 18:18:16 2009 ERROR: Windows route add command failed: returned error
    code 1
    Wed Dec 16 18:18:16 2009 Initialization Sequence Completed

    lol wow i feel like a shmuck. but here's what i got
  10. cheesemoo

    cheesemoo Active Member

    Ohhh! I think I know what's going on. It looks like a permissions problem. You need to right click on the batch file and tell it to run as an administrator.
  11. jr_mfn_p

    jr_mfn_p Well-Known Member

    worked like a champ preciate it man
  12. cheesemoo

    cheesemoo Active Member

    No problem, hope it does the job for ya!
  13. jr_mfn_p

    jr_mfn_p Well-Known Member

    yeah it should i just wanna be able to listen to some tunes while i'm at work and my girl doesn't have the net at her place so that'll come in handy also. thanks again for the help
  14. NOMster

    NOMster Well-Known Member

    so, the best speeds i can get are around .6-.9 megs down. anybody getting better?
  15. gadget

    gadget Active Member

    i am also trying to tether my Samsung moment...I have the PdaNet loaded in my phone and i have the pdaNet icon on my laptop....I cannot get them together so i can tether....if you find out how....please let me know...thank you Gadget
  16. gadget

    gadget Active Member

    yes...please let me know too.....i am in the same boat....looks like there is a full boat.....hope it doesn't sink....I need my tether....thank you
  17. jason81

    jason81 Well-Known Member


    I get about 1.5
  18. mywhip

    mywhip Well-Known Member

    Installed pdanet on my laptop and cell phone. Connected at home to make sure everything was fine, and it was. Went to a pizza place and dined in. Tried to connect but it wouldn't let me? Anyone know whats up with that?

    Also, if i wanted to use samsung studios could i? When i try to connect my phone, it says fail trying to connect.
  19. gadget

    gadget Active Member

    I have been going in circles with junefabrics...they give me a link and i still cannot get it to work...I had pdanet on my Treo at one time and it was fast and simple and worked perfectly.....I guess they do not have the Android software perfected.
  20. kahale

    kahale Well-Known Member

    it works. tho it takes some fine tuning to get it to work. once u get it working its all set. its well worth the effort.
  21. AlkiDweller

    AlkiDweller Well-Known Member

    Me to. I think JuneFabrics sent me links to three different installation packages and none of them worked. I ended up installing Azilink which works great, but it initially took a little fiddling with to get it to work.
  22. gadget

    gadget Active Member

    I wish there was step by step instructions .....to install pdanet...I did follow what june fabrics has...and they sent me links..etc etc...and still not good. I do want to stick with PdaNet because i was very satisfied with it when i had my palm treo. I have it downloaded to my Samsung Moment...and i have the desktop part on my laptop....but i cannot get them together to work...this has been going on too long...and it is frustrating....not to have step by step instructions..
    I am going to keep trying...but cannot forever. thank you
  23. drumindroid

    drumindroid New Member

    There is a MacOS X update for PDANet (2.16)... and it works great...through a USB umbilical connection. You will have to wait for 2.1 to use PDANet via Bluetooth (coming soon). From Firefox, I'm getting anywhere from 580kb to 830kb/sec download speeds (tested through DSLReports.com).

    CHEERS!
  24. gadget

    gadget Active Member

    If you are replying to me...Thank you.. However i do not have a mac. I have windows xp. I do not care about the bluetooth tethering. I am ok with using the cable. It is supposed to work on the Samsung Moment. JuneFabrics/PdaNet says so.
  25. IOWA

    IOWA Mr. Logic Pants Moderator

    You need to download the samsung drivers. Download the Samsung New PC studio.

    Also you need to enable usb debugging on your moment.

    That should do the trick
Loading...

Share This Page