Samsung Prevail acting possessedSupport


  1. sarahschober

    sarahschober New Member

    Ok so I have a Samsung Prevail and it just died and I have it on the charger now it is @ 43% now but usually I can use it while it charges... Well after i get it off the unlock screen it just jumps between the google search and settings and voice search. Any ideas of what is really going on and how to fix it?

    Advertisement
    :
  2. cwhatever

    cwhatever Life Goes On Guide

    no clue on that one, maybe try power off and then back on?
    sarahschober likes this.
  3. adaaaam

    adaaaam Well-Known Member

    My Galaxy S II used to do this because the provided charger was charging at such a high rate that the screen wouldn't work properly. If you unplug the Prevail, is it still wacky?
    sarahschober likes this.
  4. sarahschober

    sarahschober New Member

    Tried both, I unplugged it after it got a charge going again. then Did multiple shut downs as well as removing the battery for a minute. still acting ******ed :( hoping I don't just need a new phone.
  5. cwhatever

    cwhatever Life Goes On Guide

    save everything to pc if can and try a delete cache and or dalvick, if that doesn't work then a factory reset, which will wipe everything and have to redo everything. but use that as last resort. power and vol up will get you int recovery to delete cache and dalvick, try that first.
  6. Rarewolf

    Rarewolf Well-Known Member

    He may not have root, he never said he was rooted.
  7. kevincott

    kevincott Well-Known Member Contributor

    Holy water and scripture ... after that Rosary beads
  8. kristopher5823

    kristopher5823 Well-Known Member

    Lmao to funny
  9. wetbiker7

    wetbiker7 Well-Known Member Contributor

  10. cwhatever

    cwhatever Life Goes On Guide

    They still have a recovery without being rooted. Lv showed me that 1. I don't remember what's in it it's been a long time. they might still be able to wipe the cache and dalvik. They can definitely do a factory wipe.
  11. adaaaam

    adaaaam Well-Known Member

    Give the screen a good ol' wipe down, maybe the search key has some dirt on it (if long-pressed it opens voice search..hmmmm)
  12. kevincott

    kevincott Well-Known Member Contributor

    1. Did the Prevail get wet? Moisture can have unpredictable effects

    2. You may just have a bad unit. Doesn't happen often but every item manufactured eventually lets a bad one slip through.
  13. NightThorn

    NightThorn Well-Known Member

    My first prevail did that. I just odined back to stock rooted, then installed cm7. Worked fine after that.
Loading...

Share This Page