Samsung S2 4.04 update Bugs/glitchesSupport

Last Updated:

  1. fdd8787

    fdd8787 New Member

    Help! Received update OTA for 4.04 and my phone is now glitching. It crashes, screen freezes-I have to remove battery to reboot because I can't even power off after freeze. Phone quality is bad, no smooth scrolling, lags, battery icon error, 'not connected to network' error... On and on. This was a beautiful phone and now it's horrible. I don't have it rooted, it's a UK version and I'm using an ATT sim card. Can anyone help me get it working as well as it did prior to Jul 25? Thanks

  2. jaliy

    jaliy Well-Known Member

    4.0.4 is bad in general i regret upgrading to it
    Do a factory reset first and see if problems go away
  3. evohicks

    evohicks Well-Known Member

    I did a factory reset(including internal storage) when I updated to 4.0.3.
    After my update to 4.0.4 my phone runs smoother and my Bluetooth streaming problem has been sorted, I still get an error message but it's working fine.
    It's running better than it ever has to be honest and when the 4.1 update comes along I might hold back for a while :)

    Back everything up including the stuff NOT on your SD card and then do an internal wipe also to clear all traces of previous software, this is because a usual factory reset does not do this.
    Please note I am not going to be held responsible for anything lost during a reset.
  4. fiatfan

    fiatfan New Member

    Hi, my first proper post on here, so please be gentle

    Im using an S2 on the virgin network, the signal quality had been so bad, since moving to a virgin sim, that i could only make calls from the bottom of the garden (no exageration), after upgrading to 4.04, the phone now actualy works as it should, ie no more droped calls in the house etc, i havent really noticed an improvement in speed, but certainly havent experianced any glitches or bugs yet
  5. fdd8787

    fdd8787 New Member

    So, I tried to download Kies to backup everything so I could do a factory reset. But Kies not working on my PC. I've installed/uninstalled 3 times. Keep getting a 'connection error' message. When I try to trouble shoot, it doesn't fix problem or explain what the problem is. I am trying to back up via USB. Not sure what an internal reset is? This is the first time I'm doing this so any step by step help would be appreciated. Would any of these things effect install/connection?
    1. SD card or SIM card in or out of phone
    2. PC wi-fi connected
    3. S2 'tethered'

Share This Page