Samsung S3 won't charge on mains chargerSupport


Last Updated:

  1. richardsamsung

    richardsamsung New Member

    I have had a Samsung S3 for just over a week. It has been working fine but this morning after being plugged into the mains charger overnight, I noticed that the battery had not charged.

    For some reason the phone will no longer charge from the mains charger. I have also tried my old S2 mains charger which also used to charge the phone but that doesn't work either so it's not the charger.

    The phone will charge from a USB cable whilst plugged into my laptop.

    Does anyone have any ideas? I bought the phone unlocked from Amazon.co.uk but Samsung Mobile UK said they do not provide technical support to people who have bought phones from Amazon. Can you believe that!?

    On another issue, I have my S3 paired to the bluetooth handsfree built into my Range Rover but every time I get into the car it asks me to enter the PIN associated with the pairing. My S2 always used to automatically remember this. I can't find a similar option on the S3 that will pair it automatically each time without me having to enter the PIN.

    Any ideas on that one?

    Thanks for your help Guys and Girls.

    Richard

    Advertisement
  2. jerofld

    jerofld Fixing stuff is not easy VIP Member

    I would try a factory reset. If it doesn't charge off of your wall socket, still, then I'd talk to Amazon to get a replacement.
  3. breezex

    breezex Well-Known Member

    Are you using the same USB cable with both chargers? If so try a different one. And make sure your mains outlet has power.
  4. richardsamsung

    richardsamsung New Member

    Yes I am using the same USB cable with the charger as the one on the laptop.

    The mains socket has power. It is really odd.

    I would warn against anyone buying a Samsung product from Amazon.co.uk because Samsung UK won't provide any technical support if you do as apparently Amazon do not source their products sold in the UK from Europe!
  5. XplosiV

    XplosiV Master X is Watching You VIP Member

    Apparently the phone detects different ampages from different chargers so it can tell you if you're charging off the car, mains, usb etc, maybe you have a fault within your handset that's not detecting them right. I'd contact either amazon or samsung support.
  6. dracozny

    dracozny Well-Known Member

    I had this issue with my eris, I know diff phone but same exact issue. it turned out to be the USB cable. I used another cable for a while and then eventually that one crapped out too. I stole the USB cable from my PS3 controller and haven't had an issue with charging ever since. I think the PS3 USB cables are a little more stout around the connector ends
  7. XplosiV

    XplosiV Master X is Watching You VIP Member

    Not sure about your ps3 but mine doesn't use micro usb connectors, sure they are small, but not the same as micro usb.
  8. simon14

    simon14 New Member

    Hi guys,

    I have the same problem.

    My Samsung Galaxy s3 won't charge when connected into the mains power. I have tested with two different charges. It also wont charge with the car charger but always charges when connected with a USB cable to a PC.

    Something else to add, sometimes when i connect my phone to a mains charger it will start to charge for a few seconds then stop but most of the time it won't do anything.

    As i won this phone, i'm now trying to find out how to send it back in for repair but will follow this up next week.
  9. adroidnoob

    adroidnoob New Member

    any luck with that ? I'm in the same boat as you
  10. adroidnoob

    adroidnoob New Member

    Ok ... I freaked out yesterday morning because that happened to me too ! So i thought it was my brand new Samsung galaxy S3 that was already defective. Worse feeling ever right !? Anyways ... I bought a new charger from AT&T to test it out and it worked. Its not the usb , its the actual charger that goes to the wall that was defective . So I called AT&T ( 800-801-1101) warranty number that way you don't get transfer 20 times before they assist you, and got my charger replace at no cost with one day shipping since our phones are still under warranty.
  11. Tinto

    Tinto New Member

    Hi all, I had the same issue. I found it was my mini USB cord, it was defective. That was the main problem. When I looked at how it went inside the device, it was on a slight slant. Fortunately I have a different device that uses the same size mini USB, used that one and voila!

    Now I need to solve the power issue, seems to be draining a lot quicker. But atleast it's charging now.
  12. CMNDR

    CMNDR Well-Known Member

    I'd be really interested to see why the chargers are going bad. I noticed last night that my SGS3 wasn't charging as fast as it should and then looked down at the cube Sammy gave me, and noticed its a 1.0A charger. All other chargers for phones have always been in the .5 - .7 range (USB port provides .5A). I swapped out the old brick for the new one and sure enough charging sped up. Seeing as there was no size increase but a double in power output, I wonder if we'll see a trend of failed power bricks. (As an electrical engineering major this subject interests me vastly.)

    If your charger seems to be getting hot, see if there's anyway to ventilate its surroundings a bit more, as high heat can often wreck power circuits.
  13. antoeknee

    antoeknee Well-Known Member

    I also had issue with the charger/USB cable supplied with the handset. Whn pluged in initaially the phone would start charging and then after 15-20 seconds it would stop.

    Tried different USB cable still the same.

    So tried the charger from my Galaxy S this worked no problem and I've continued to use this.
  14. MMMMMMMM

    MMMMMMMM New Member

    Yesterday I used my MHL(samsung official) adapter (+ charger) to watch a movie. Since then I can't charge the phone with any adapter or on the computer. Only way to charge it is to use the MHL adapter?!!?!?!?!?

    It also takes much longer time to charge than it should and I need to restart the phone several times to make it start charging...

    WTF?!?!?

    I've tried factory reset without any success..

    :mad::mad::mad::mad::mad::mad::mad:
  15. aleem77

    aleem77 New Member

    I am having the same problem with s3 just 8 days old bought from vodafone.
    It wud charge with s2 old charger n also with the usb of main charger when plugged into my laptop.
    I called Vodafone n asked for charger to be replaced. Guy told me that we will just change the handset.
    Exchange without even asking n i am also out of their 7 days return policy hmmm this problem must be known n their might be a known fault users have not been told.
    Anyway i am getting a new one even without asking.
    So i am not bothered
    Hope it solves for u guys soon
    Good luck:)


  16. rupertlovibond

    rupertlovibond New Member

    You're not going to believe this as it's ludicrous but i got a tip off youtube after a week with a phone that would only charge via laptop.
    Let the phone run down until completely empty. Then charge it back to 100% on laptop/pc, whatever, after that it has worked fine.
    Good luck.
  17. skramblr

    skramblr Well-Known Member

    I'm not saying I don't believe everyone, but this whole thread seems odd. Here in the US, the mains charger is nothing more than a 5v charge block with a USB cable plugged in. So 5v coming from the charger is identical to 5v coming from a PC/Laptop (note 1).

    General trouble shooting:
    1) Swap out the USB cable with the one you know is working.
    2) If phone is now charging, you had a bad cable.
    3) If phone still not charging, the 5v converter is bad and needs replacing.

    Note 1: Actually, USB connections can have different current ratings. Standard is 0.5A current output, but powered connections can be over 1A current. This is why some power sources can charge faster than others. But they are all the same 5v rating and electrically there is the same 5v and a Gnd connection providing power regardless of what you plug your cable into..
  18. Pbc70196

    Pbc70196 New Member

    I have exactly the same issue, my phone wouldn't charge after the first day, had a replacement dispatched, but before it arrived got a firmware update which resolved the problem for about a month when a second firmware update caused the issue to return!!!! My phone will now only charge from a pc or an external battery, even though I charge the external battery from the same plug, cable and power supply that won't charge the phone! It sounds like a software issue to me, so please no suggestions of replacement power supplies as this has been tried.
    Ther was mention of the phone recognising different amp inputs as it knows if it is plugged into an ac adapter or USB charger, I have also read about an issue with a setting to indicate its power usage, that could be set wrong, any suggestions on how to fix these or step back to the previous version of firmware until they get it fixed would be welcome. I am currently running 4.1.1 baseband version i9300NEDL17. :)
  19. mbrossar

    mbrossar New Member

    I'm wondering if everyone on this thread is having troubles with the original Samsung charger or a third party charger. What I found was that my S3 would always charge on a charger rated 1a or less but only on some chargers rated 2a or more. Frustrated, I ended up talking a brainiac nuclear physicist friend of mine, and he explained that it was likely the power supply. Not that it's broken, just that it's cheap. First, keep in mind that volts are pushed (i.e. the charger will deliver the stated voltage) and amps are pulled (i.e. the device [the phone in this case] will pull whatever amps it needs up to what the charger is capable of delivering). Second, notice that the vast majority of USB devices are expecting 5v. This may even be according to spec, I'm not sure. Now, you might expect a power supply rated at 5v to deliver 5v regardless of the amperage drawn. This is the case for good power supplies, but it turns out you can make power supplies cheaper if you bend the rules a.bit. If a power supply uses cheap components, it will actually deliver more than 5v at low amperage draws and fewer than 5v at higher amperage draws. To get away with this design, the manufacturer just needs the voltage delivery to be roughly 5v at the target amperage draw. You're almost always within a margin of error on power supplies rated at 1a or lower. But when your only drawing 1a or less off a cheap power supply capable of delivering 2a or more, the power supply is likely to deliver much more than 5v. This will likely either fry your phone or your phone will detect the excess voltage and in an act of self preservation will refuse the charge altogether. This is probably why your chargers aren't working.
  20. Yowser

    Yowser New Member

    I have a similar problem with my SGS3, with a little twist.

    I have 2 USB cables I use on the phone: the original which came with it (call that Cable 1) plugged into the charger in the wall, and another cheap one plugged into my PC (call that Cable 2). Both were charging fine up until a few days ago. I also have an in-car charger.

    This is the little twist. My phone was low on power, and I had to go to a client's so I took Cable 1 with me to charge from my laptop whilst I was there. On the way there I also charged from the in-car charger, but only for about 15 minutes. I then charged from the USB later on, no problems so far.

    At the end of the day I went to put the phone on charge using the mains charger, only to find I'd left my original USB cable at the client's place. No problem, I just used Cable 2 from my PC and plugged that into the charger. The phone began to charge and I went to bed.

    Next morning I looked at the phone and it was FULLY CHARGED. I left the house for the day, and when I got into my car the phone did the beep beep warning telling me the battery was low!

    Now my phone will charge from my PC with either cable, and from my in-car charger, but it won't charge from the mains charger with the Cable 2 but WILL charge from the mains charger using Cable 1.

    So what I'm wondering is whether having a low quality cable (Cable 2), combined with a low quality charger (as suggested by mbrossar) pushes the operating window of the charger just outside optimal for the phone??

    Still don't know why it reported it was fully charged!
  21. spyvsspy

    spyvsspy New Member

    I had a similar problem this morning. The S3 wouldnt charge : not on the mains, not on the desktop USB & not on a portable battery charger that I had.

    The portable battery uses the same cable as the S3 & that worked both with the USD port on the desktop & also on the Adapter. So the Adapter was fine and the cable was fine.

    I tried some of the suggestions on this tread. Booted & rebooted, swapped the battery but nothing. I called the Samsung helpline and they told me that it was a problem with the jack & to bring it in to the service center.

    I tried one last option that was on this thread. I blew into the S3 micro USD port & plugged it in. & That worked.

    Go figure.
    Gazd2002 likes this.
  22. Gazd2002

    Gazd2002 New Member

    Got my s3 brand new out of box. No joy charging or getting the USB to work with laptop. Called the mobile company and was going to get a replacement sent out. Read this post, thought what the hell........it worked! Saved me a week of waiting for a new phone, simplest fix ever!
  23. rexusjg

    rexusjg New Member

    New to the forum and to S3, Bberry refugee - Brand new, S3 - first time charged it at the office, worked fine. Brought it home and used the same wall charger, starts off charging, but next morning, I saw it did not charge. I thought - user error - I must not have plugged it all the way in. Next night, same thing, and same thing in the morning, I investigated to find that the phone starts off charging and then after a short time it cuts the charger off. I tried powering the phone down and turning back on, it charged from my car 12 volt DC charger. Now I am investigating whether it will accept a charge from the wall charger.......

    So after 5 mins on the wall charger, it went from 90% to 92%. Seems to be charging fine.

    To sum it up so far - wouldn't accepted charge from wall charger when battery was critically low; after a couple failed attempts, user powered down the phone and turned it back on, car charger brought it up to 90%, user disconnected charger; now the phone is accepting charge from wall charger.

    Power down the phone and turn it back on seems to reset it? I wonder if this is a firmware/software problem.

Share This Page