Samsung Stratosphere 2 SCH-i415 (4.1.2/Jelly Bean/MA3) rooting guide

Last Updated:

  1. vermillion1

    vermillion1 New Member

    With some pointers and instructions from some people in xda-developers forum, I've been able to create a rooted system image for the Samsung Stratosphere 2 phone.

    The link to the rooted system image to apply to a Samsung Stratosphere 2 phone running 4.1.2 (jelly bean / MA3) is here:!wZpSURaZ!E3EpjBAbw7KNCiKet2oYvzPmnH1jC0o_39HQyqwlWSs

    - Just make sure you're already running 4.1.2, because this only replaces the /system partition and I don't know if it would work otherwise.
    - Setup the usb drivers (same drivers adb uses)
    - Unzip the downloaded file (it will give you a tar file)
    - Put your phone in download mode (volume down+power to turn on, volume up to confirm)
    - Run Odin (I used Odin 3.07). It should detect your phone and say it is ready
    - Check PDA and supply the tar file for the PDA box.
    - Flash. It's a bit large and will take around 10 minutes to complete.

    This uses the SuperSU version of su. I don't think you need to install SuperSU from the market (it is included in /system/app already) but it couldn't hurt and the market will let you get updates for it.

    If you'd like more information the genesis of this work is an xda-developers thread here:
    While I created this image for the 4.1.2 firmware version, most of the credit should go to Nardholio with the original idea and kado01 who implemented it on the 4.0.4 firmware.

  2. tinmankxk

    tinmankxk Member

    it doesn't give a tar file...
  3. SoulSingin

    SoulSingin New Member

    This method worked for me. Thanks!
  4. Snakebite096

    Snakebite096 New Member

    The Directions
    "- Just make sure you're already running 4.1.2, because this only replaces the /system partition and I don't know if it would work otherwise.
    - Setup the usb drivers (same drivers adb uses)
    - Unzip the downloaded file (it will give you a tar file)
    - Put your phone in download mode (volume down+power to turn on, volume up to confirm)
    - Run Odin (I used Odin 3.07). It should detect your phone and say it is ready (<How far I get)
    - Check PDA and supply the tar file for the PDA box.
    - Flash. It's a bit large and will take around 10 minutes to complete."

    I have all the files, have USB Debugging enabled; but when I put my Stratosphere 2 (4.1.2) in download mode, Odin 3.07 doesn't detect my phone like the directions say it should. Can anyone please help? Im also running windows 7.
  5. paradoxical

    paradoxical New Member

    I am trying very hard to install this ROM, but my phone doesn't seem to let me. Do I need to be already rooted or have ClockWorkMod recovery to install this rom?

    I've tried using odin, it recognizes my phone, but it takes a long time for it to say "pass!" When it says pass! and I disconnect my phone and boot into recovery mode, (I only have TWRP and Android Stock recovery. I do not have CWM installed and cannot find a compatible version for my stratosphere II) it cannot find the tar file on the SD card.

    I've tried copying the whole zip file and putting it on my SD card, and it does show up in recovery but it doesn't install successfully. I get errors, such as E:Error in cache/recovery/log (No space left on device), and a bunch of other errors, such as, verification not signed, or something like that. I've use TWRP to try to install this and nothing works. I am stumped. Can someone give me a hand in figuring this out? :confused:

    Another thing with this phone, is the dialer codes do not seem to work on this phone, how am I suppose to get it into Diag mode? I cannot connect to QSPT, QXDM, etc. :confused:
  6. janeric2

    janeric2 New Member

    The steps above worked like a charm for me. The only problem I have now is that Verizon is trying to send an update to my phone. I have tried to install it repeatedly, and the update keeps failing. I'm guessing rooting the phone may be the reason. I tried a temporary unroot using OTA Rootkeeper, but that didn't help. Is there a way to go back to the stock ROM, or is it possible to turn off the constant prompts I get over and over to install this update that won't work?
  7. puppybutt

    puppybutt New Member

    Try putting your phone into debugging mode, and then plugging it into your PC via the USB. Verizon should automatically prompt you to install some software to "help your device communicate with your PC"

    After that, you'll be prompted to install the software to bring your device up-to-date.

    I'm not a developer and I'm not SUPER tech-savvy, but my thinking is that the root process interferes with OTA (over the air) updates going through, but I haven't had any trouble updating manually using the method I described above.

    Good luck! Hope this helps!
  8. speedy2123

    speedy2123 New Member

    i keep getting a message saying has stopped responding and then phone resets
  9. janeric2

    janeric2 New Member

    I tried what you said. Verizon's Update Assistant says that the software is up to date, but my phone still keeps downloading and prompting me to install this update over and over again. When I run it, I briefly get the android graphic that shows when software is updating. After a moment, it switches to the picture of the android with a yellow exclamation point indicating the update failed.

    I have done some reading elsewhere, and it appears that loss of ability to install updates after rooting can happen if you remove some of the pre-installed apps on the phone, which I have. Anybody have an idea how to get those back? From what I've read, it's not as simple as reinstalling them from the Market - you apparently need the original apps. Anybody have the original android Jellybean install?
  10. puppybutt

    puppybutt New Member

    Interesting, Which pre-installed apps are required to process the update successfully? Because I uninstalled a lot of bloatware after rooting as well but I haven't run into the same problem.

    Could you post links with regards to the research you've done? Maybe we can get this figured out!
  11. death1223

    death1223 New Member

    I keep getting this as well. I followed the guide, but I forgot to enable USB Debugging(that's all I forgot to do) and it kept giving me this error. I did it again but I was able to enable USB Debugging this time(the phone annoyingly restarts every 10 seconds so it's a race to do anything on the phone.)
    It still gives me this error, and even worse.. I can't get in fast enough to factory reset my phone. While it says "Shutting Down" it resets, not doing any factory reset. I've tried several times, and yet nothing. None of the guides for Hard Resets, or recovery modes that I find online work for stratosphere 2. I'm stuck here, guys. Please help!
  12. puppybutt

    puppybutt New Member

    Nevermind - I'm having the same issue you are. The OTA Verizon Jellybean update won't take for me either. Stay tuned...

  13. janeric2

    janeric2 New Member

    It looks like I may be going about this the wrong way. According to one site ([HOW TO] Block the latest Verizon OTA for rooted phones (IMM76D)), you shouldn't be doing OTA updates once you have rooted the phone - there is risk of unrooting or even bricking the phone. This makes sense, since we seem to be downloading some sort of custom update to the OS. According to the article, it would be better to wait for somebody to put out updates made for rooted phones. To disable the OTA update prompts, you need to freeze the SDM 1.0 app. The article mentions using Titanium Backup, but only the paid version seems to be able to freeze apps. I did it using the free version of System Tuner. I got a message right after I froze it saying the app that controls the desktop (can't think of the name) had stopped, but everything was fine after rebooting the phone. Since then, I am no longer being prompted to update the phone's software.
  14. death1223

    death1223 New Member

    Gosh darn it! Did I brick my phone? I just got this phone :c
    Is there anyway to unbrick it? I can't find any official firmware for the phone anywhere.
  15. death1223

    death1223 New Member

    Alright, I fixed it through these steps:
    1. Install the samsung mobile usb driver.
    2. Download the latest Android SDK package.
    3. Extract it, then connect your phone.
    4. Open up CMD, type in "cd (Directory to your sdk folder inside the bundle)"
    5. Once it shows you are in the right directory, type in "platform-tools\adb reboot recovery" DO NOT PRESS ENTER YET.
    6. Wait for your phone to come online to the point where it will show up on your computer as a storage device, then press enter and it should restart the phone in recovery mode.
    7. Scroll with your volume up and volume down buttons. Scroll to Factory Data Reset and press it with the power button. Then scroll down to "Yes" and press the power button again.
    8. Enjoy your non-messed up phone!
  16. markdavidson109

    markdavidson109 New Member

    guys i need help and help right now. i did the aboved mentioned process and my phone is reseting and my process keeps failing. i need help with fixing my phone. im not tech savy at all. i need help fixing this and restoring my phone back to orignial rom and kernals or whatever the heck their called. i need my phone fixed and i need it fixed like now. please help me!!!! :'(
  17. Phelpsj87

    Phelpsj87 New Member

    SO I was having the same issue as DEATH 1223. The issue I found was I was following more than one set of directions.

    First, every root manual I found said the same thing. Enable installed apps from unknown sources, and enable debugging.

    So I did this, then opened Odin, and followed this manuals EXACT DIRECTIONS....... ALMOST.

    Most manuals I found that utilized odin requested you uncheck the boxes "F. Time Reset" and "Auto Reboot." Being a DUMB ASS, this is what I did, and I started getting this same error " has stopped responding." Here is what I did to get my phone rooted and clear the message.

    1) I did a factory reset
    2) Enabled USB debugging in app development, and Installations from unknown sources in the security tab. (Settings>Security)
    4) Set Stratosphere 2 sch i415 to download mode, and plug into USB.
    5) Hit start on ODIN, wait for completed flash and reboot.

    6) When phone is rebooted, eject phone from usb, and use su command to access temp root in terminal.

    This worked for me as Temp root is all I really needed. Just enough to pick up more. Hope this helps.

    BTW thanks for the awesome TAR guys......great work, keep it UP !!!
  18. mag1guru

    mag1guru New Member

    Followed through this thread and decided to attempt root access on Strat 2 I picked up for 40 bucks. Everything appeared to be going as expected until after the phone rebooted. The Samsung logo displayed the screen went black I heard what sounded like the Samsung startup melody then the Verizon shutdown melody and then nothing but darkness. Let the phone set for several minutes but nothing. Removed battery, replaced powered up with same scenario. Got phone in recovery mode and reset to factory but was not help still same startup scenario as above. The phone will go into both recovery mode and download mode but that's it. Tried to flash the phone again with same outcome. Any help would be very appreciated.:confused: Thanks

    The phone was @ 4.1.2 os
  19. Tepafray

    Tepafray New Member

    So I followed the instructions and everything is working for me except wifi. I try to turn it on and it just turns off a second later. Help?

    Edit: Bluetooth seems to not be working either
  20. bangdosa

    bangdosa New Member

    I have also rooted using the method on this post, but forgot to chekc if the phone was in MA3 or the Mj2 update.. Wifi and Bluetooth no longer works for me too. could someone send me a pure Mj3 tar to see if that fixes it?
  21. mgoldie11

    mgoldie11 New Member

    Hi, I was wondering if there was a way to unroot. I rooted with system.img.ext4, but now lost ability for wifi and bluetooth.

    Is there a way to get it back to original image/rom? Please let me know. Thanks.
  22. denacioustea

    denacioustea New Member

    BEFORE you do anything else with this file, go to settings, about phone, that little ma3 thing in his title is really important, most of the issues with rooting 4.1.2 strat 2 has to do with ma3 v. mj2, it's at the end of your baseband code, if it says ma3 go ahead and download, if it says mj2 this will give issues and stop wifi/bluetooth from working killing most if not all wireless communication. if you have mj2 go to the link below, this kado01 guy bricked his phone to give you this file, be grateful (download with odin 3.07, check pda box and use unzipped .tar file, be sure you have adb drivers which you can get from sdk manager in sdk 2.0 (from google) which requires java, flash of rom will take about 10 minutes 46 seconds) I just did this over the last 36 hours, what is typed above worked for me.

    mj2: forum xda-developers com/showthread php?t=2078615&page=17
    (put periods where I have spaces, it is the top link in #165)

    ps: I now know more than I needed, I may be able to help with additional problems, I'll probably check this thread about once a month for the next year, sorry if I don't
  23. mgoldie11

    mgoldie11 New Member

    Unfortunately when I tried this, I got the "Complete(write) operation failed error in odin. Any suggestions?

    Also, you say "unzipped" file, but when you try to load it, it looks for the .tar file, which is not unzipped.

Share This Page