1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

San Francisco 2 / ZTE Crescent bricked - HELP!!Support


Last Updated:

  1. alanbeber

    alanbeber New Member This Topic's Starter

    Joined:
    Jul 10, 2012
    Messages:
    2
    Likes Received:
    0
    I had to do a reset from Settings/Privacy to clear the Google account, and it went wrong somehow. Now my SF2 (ZTE Crescent) only boots to the green android man, then the word ANDROID, and it just stays like this and won't go any further.

    I've tried VOL-UP/POWER ON and get the same thing.
    When I try VOL-DOWN/POWER ON, I get a screen with FTM on it, but I don't know what this is, or what to do with it.

    I have tried to get info from the forums, but there are so many acronyms, I'm completely bewildered.

    How do I get my phone back, please someone?
     

    Advertisement
  2. fr0d0

    fr0d0 Well-Known Member

    Joined:
    Aug 21, 2011
    Messages:
    101
    Likes Received:
    21
    Read the last posts in the other most recent threads. From FTM mode you can use the official ZTE update tool that will fix your problem.
     
  3. alanbeber

    alanbeber New Member This Topic's Starter

    Joined:
    Jul 10, 2012
    Messages:
    2
    Likes Received:
    0
    Tried that and it gets to the unlock screen, but the touch screen doesn't respond, so I can't unlock it.
     
  4. fr0d0

    fr0d0 Well-Known Member

    Joined:
    Aug 21, 2011
    Messages:
    101
    Likes Received:
    21
    Have you rebooted a few times? You could send the phone commands using adb over usb, or take back to a shop.
     

Share This Page

Loading...