San Fransisco II- unlock to all networksSupport


Last Updated: 2012-06-14 06:44:18
  1. Arbu

    Arbu Well-Known Member

    OK, if I do exactly as you say, double clicking on the Stock ROMs folder in Windows Explorer I get the following errors:

    "! C:\Documents and Settings\Administrator\Desktop\Test\orange-roms.zip: The archive is corrupt
    ! C:\Documents and Settings\Administrator\Desktop\Test\orange-roms.zip: The archive is corrupt
    ! C:\Documents and Settings\Administrator\Desktop\Test\orange-roms.zip: CRC failed in Stock ROMs\rom-stock.zip. The file is corrupt
    "

    The Stock ROMS folder does appear but the only files that appear in it are ii, ii.md5 and kernel-stock. md5.exe is not shown.

    What I was doing before was double-clicking on the orange-roms.zip. Then you get a list of files in the WinRAR application window. This lists two extra files - rom-stock.zip and md5.exe. When I double click on md5.exe from within the WinRAR window I get the errors I described in my last post.

    Advertisement
  2. momist

    momist Member

    I think the clue is in the order you are doing it. If you double click a .zip file, the zip utility shows you what's in there. Don't do that. Instead, _rightclick_ the file, and choose "extract here" or similar. this takes them out of the zip file, rather than just opening it enough to show them to you.

    Afterwards, open the folder with explorer, or whatever file manager you use, and run the .exe from that, not the zip software.

    HTH
  3. Arbu

    Arbu Well-Known Member

    No, this is what I did. There's plainly a problem with the file as it downloads onto my computer or I wouldn't be getting all these error messages. It's not to do with small details of how I unzip it. I have unzipped lots of files previously without problems like this. Can you not post the unzipped files?
  4. Reider

    Reider Well-Known Member

    I suggest, and please don`t take offence because none is intended, that you allow someone else to do the work on your phone. Use someone who has a bit more experience in using a computer and files of this nature, ie zip files.

    The reason is if you trip up on this easy part of the process then you`re most likely to trip up even more and brick the phone later. Just an opinion and at the end of the day its up to you to proceed or not.
  5. Arbu

    Arbu Well-Known Member

    I have more experience of using computers than almost everyone I know. If I get someone else to do it they will have exactly the same problems. You seem to be refusing to accept that when the files are downloaded onto my computer they are somehow corrupted. Unzipping files is not complicated and as I say I have done it many times before - there is clearly some problem with your zipped file. If you're not going to make the unzipped version directly available then there's nothing I can do.
  6. Reider

    Reider Well-Known Member

    They are not "my" files. I WAS simply trying to help you. Many people have downloaded the files, extracted them and had no problems.

    I cannot make them available unzipped because they do not belong to me. If they are coming down the pipe for everyone else and not corrupted then the problem is at your end.

    EDIT:

    I just downloaded it again no problem
    Used "Extract Here" and the MD5 EXE worked when I doublicked on it, after closing WinRar.

    I then deleted the extracted contents
    Next I opened the contents inside WinRar itself
    Doubleclicked on MD5.exe and it still worked

    So something is corrupting it at your end on download. Because it works for almost everyone else. Even if the contents were unzipped you`d have problems because the kernel-stock and the rom-stock have to stay zipped, that's how they are used. So you`d possibly still get errors. All you could do is try downloading from a friends machine and then put it on a memory stick/card.
  7. Arbu

    Arbu Well-Known Member

    OK, well thanks for your help. I just downloaded the file again with IE instead of Firefox and have had exactly the same problem. It's just a mystery.
  8. Reider

    Reider Well-Known Member

  9. Reider

    Reider Well-Known Member

    Can you use FTP like maybe FileZilla?

    Edit: Scratch that. If all other efforts failed try this;

    (1) Go to;

    download now done, link removed.....

    (2) One at a time download each of the 5 files I embedded on that page.

    (3) If a download page or something pops up make sure you fully download all files in their entirety. Mine shows a dial around the background of each of the two big files and this dial is split into 8 quadrants, when all 8 have gone green the file is fully downloaded. The ROM-stock.zip will take the longest.

    Hoping this alternative works, I just made the download page up and hosted the files. Then I tested it and the last file is still downloading, took ages to upload and download. But all 5 are downloading and all 5 are from that Orange-Roms file. All I did was add a download link for each individual file instead of all 5 in the one zipped file. If this works NOTHING needs unzipping after download. The two big files stay zipped.
  10. fr0d0

    fr0d0 Well-Known Member

    @ Arbu: You don't unzip anything inside the first zip... That's all meant to stay zipped up. The rom is a zip file. You're supposed to check the size of that zip with the md5 utility.

    Sent from my Blade2 using Tapatalk 2 Beta-6
  11. Arbu

    Arbu Well-Known Member

    Thanks, but I can't access this page. I get "
    Error 404 Not found".



  12. Arbu

    Arbu Well-Known Member

    Yes, but the point is I can't get hold of the md5 utility.
  13. Reider

    Reider Well-Known Member

    I closed it down because my internet went crazy last night (my time). Had a power out on the ISP connection for some reason. So I cut all third party links afterward while I investigated it a little more. I`ll rebuild it and edit this post when its up again.

    EDIT: Probably won`t work, as frodo suggests their do seem to be problems at your end. But try;

    download done, link now removed.....

    4 of the required files download for me and 1 opens to show the MD5 details inside. Let me know when you`ve finished with it so I can delete it and the link again please. I`ve also started an alternative links page here for the SFII and the Vivacity;

    http://android.modaco.com/topic/353218-alternative-download-sites-sfii-and-vivacity/
    Arbu and fr0d0 like this.
  14. fr0d0

    fr0d0 Well-Known Member

    You can get md5 checking utilities all over the place, including versions to run on your phone.

    Sounds like you have serious PC issues.

    Sent from my Blade2 using Tapatalk 2 Beta-6
    Arbu likes this.
  15. dannymur

    dannymur Well-Known Member

    Arbu likes this.
  16. Arbu

    Arbu Well-Known Member

    OK, thanks I've managed to download both kernel-stock and rom-stock and I've checked their MD5 numbers against the numbers in the link that I get to when I click "ii md5" on your page. I've now copied them to my phone. On to the next stage...
  17. Arbu

    Arbu Well-Known Member

    OK, got a problem. Not sure how it happened and it may be my fault. At stage 13 of reinstalling the stock-rom I don't see rom-stock.zip as an option. I've got kernel-stock and orange-roms.zip. I could have sworn that I copied rom-stock to my phone but it looks as if I may have copied orange-roms instead. Is there anything I can do? I'll leave my phone as it is and attached to my computer for now.
  18. Reider

    Reider Well-Known Member

    Just quickly as going out on a trip to the Anderton Boat lift (and its persisting it down). Theirs a setting in CWM to turn off the SD Card. Use that, take it out and swap the zip file for the correct one. Put it back and it will either auto turn on the SD Card again or their will be a setting. Then continue from there at a guess.

    I never used this method but turned it off after the phone booted, I guess it does the same sort of thing loosely. Don`t feel bad about the slip up, we all do it from time to time. It's not letting panic mode set in and how you get around it that counts.....

    EDIT: Can you take out my download links in two of your posts above please? Not needed now and I need to secure it again. Thanks.....
    Arbu likes this.
  19. Arbu

    Arbu Well-Known Member

    Thanks, that has worked fine and my Tesco SIM is now in the phone and working. "Unmount" is the term used in CWM for turning off the SD card.
  20. Arbu

    Arbu Well-Known Member

    Now trying to install a custom ROM but not having much luck with reinstalling Clockwork Mod Recovery. The first time I tried it Windows did indeed try to install new drivers as you mention. I said yes to it doing so, it said to insert a disc if you have one, I don't have a disc so didn't insert one, it looked for drivers, couldn't find them, and then said nothing more. The MS-DOS window just sat on <waiting for device> for 15 minutes. I gave up and closed it down. Now trying again and the MS-DOS window has been sitting on <waiting for device> for a further 15 minutes. No request to install drivers from Windows this time.
  21. fr0d0

    fr0d0 Well-Known Member

  22. Arbu

    Arbu Well-Known Member

    Yes, I've done that. But now I want to get rid of the Orange software and so I'm following what it says in point 22 of the last page of your link:

    "If you wish to install a custom ROM, follow our guide here."

    And that's where I'm stuck now. I've tried it on two computers now and they both say "error: device not found <waiting for device>"

    If I enable USB connection on my phone I can see the phone under "My Computer". But USB enabled or not, I still can't get the current step to work.
  23. fr0d0

    fr0d0 Well-Known Member

    Ah right. Personally I'd go with this method. WAY easier and without pain IMO: Alternative way to flash recovery - Android @ MoDaCo

    I used 5.0.2.7 because I have a Vivacity. (Flibblesan's rom was built from a Vivacity)
    For an SF2 I'd use 4.0.1.5 as sebs rom was built from an SF2.

    This is what I did:

    Check the m5sums.

    Unzip to the root of your sdcard, you should have a folder called image with an image.bin and nandroid.md5 file inside it.

    Check the md5sum of the image.bin matches the one listed in the nandroid.md5 file.

    1. Go to settings, about phone, system updates and start from there.

    ------------

    I did it a different way 1st time around. 2nd time I needed it I'd wrecked the phone with a dodgy rom, managed to get the latest source using the ZTE upgrade tool, then used the above method to get back to CWM.

    HTH
    momist likes this.
  24. Arbu

    Arbu Well-Known Member

    OK, thanks. I've downloaded 5.0.2.7 to my computer and unzipped it to my sd card. There are two files as you describe. In order to check the md5 number I've downloaded AVF as dannymur suggested onto my phone. I've run this on image.bin and it comes up with a checksum - 6d27e...... Then presumably I have to select the nandroid.md5 file in AVF to check that it contains the same number. So I select the file, and then "verify Nandroid backup" and get the message:

    "nandroid.md5: 1 lines read, 0 existing files, 1 non-existent files

    Could not verify any files in the 'mnt/sdcard/image' directory.

    The selected file does not appear to be formatted like an nandroid.md5 file.

    Additionally, these files do not exist and could not be verified;

    *image.bin"

    It all seems very complicated. Surely all I need is the checksum for the image.bin file which could be posted online rather than needing to be extracted from an md5 file?
  25. Arbu

    Arbu Well-Known Member

    I remembered seeing somewhere that I could just rename the Nandroid file to have the txt extension so I did that. It opened and I could see that the MD5 code matched. So I went ahead and the phone is working fine.

    The only thing is I'm not quite sure what I've achieved in installing the new rom! The icons on the homepage are still kind of orange coloured and I can't delete apps that I don't want from the program list (such as Tetris). I can drag them to the bin but they're still on the program list when I go back to it. What have I achieved?

    Also is it OK now to delete the three zip files that I have on my sd card?

Share This Page