saving pictures to SD card.General


  1. buckhead

    buckhead Well-Known Member

    Hey everyone, I had been saving all my pictures to my SD card that isn't even half full. Then somewhere along the line I must have changed something and now the camera wants to save everything to the camera itself.

    If I take a picture it tells me "Unable to save to SD card. Default storage has been changed to default setting". But I get into the cameras settings and change the storage from device to memory card and take a picture again and it tells me it's been changed to device. I will go back into settings and it shows it back on device.....again.

    What's going on that's not letting my memory card choice stick?

    Advertisement
    :
  2. speedlever

    speedlever Well-Known Member

    My suggestion is to make sure your card actually has the advertised capacity. I don't know, but if the card is actually full, Android may not allow the SD card to be selected as the destination for your new pics.

    What SD card do you have and where did you obtain it? There have been a number of cases where people have bought a xxGb card, only to find out it is bogus and only has a fraction of the advertised capacity.
  3. lotus49

    lotus49 Well-Known Member

    Google h2testw and test your SD card with it.

    Did you buy this card cheaply on eBay by any chance?
  4. itsallgood

    itsallgood Well-Known Member

    All good advice above. Its possible the SD card is bad too. (You would know if you get a notification of it being unmounted, if you didn't unmount it.) It sounds like the SD card is full though. You can check the space of the SD card from settings> more> storage.
  5. buckhead

    buckhead Well-Known Member

    It is a PNY brand 16GB mini SD card. Available space right now is 8.89 GB's. I believe I ordered the card the same time I ordered the phone.

    When I unmounted and took the card out, it didn't show anything under SD card in the storage page, which should be right. I put it back in and it shows total space on card as 14.91 GB, available space 8.89 GB.

    I have never had a notification about it being unmounted. I will try and delete about half of my pictures and see if that makes a difference.


    EDIT ----- I downloaded h2testw and it told me I had 46Kbyte corrupted.

    It said it had 15263Kbytes, which equals 14.9GB. Size looks right, must be the corrupted files causing the problem.

    I let windows fix problems with the card and after fixing the corrupted files it does look as though the card is almost full. For some reason the corrupted 46Kbytes of files were making the card look only a little over half full.

    Thanks for a the help guys, and thanks lotus49 for suggesting I run the h2testw program.
Loading...

Share This Page