Screen dims for no reasonSupport


  1. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    Given the extra beefy battery on the Maxx I always keep my screen at 100% brightness, but over the past few weeks I've noticed an odd thing. At random times (and for no reason I can identify), my screen remains dim when I turn it on. It's the same level of dimness that is the default when it's about to go back to sleep after inactivity, but it happens immediately after turning on the screen, and persists while I use the phone. No settings have been changed, and I don't have any apps set to automatically adjust the screen brightness in any way. It's not a functional issue, because when I go into the brightness settings and re-adjust it, the screen comes on at full brightness again without a problem. As long as I keep using it, it remains at full brightness, but when I finish using the phone and turn it off again (or if it goes to sleep again normally), the next time I turn it on it will remain dim again. It used to go away after a reboot, but that hasn't worked lately. I set a toggle widget on my home screen to adjust the brightness with a single tap, but it's still annoying and I'd like to identify and get rid of the problem.

    It happened on rare occasions a few months ago, and I initially thought it was related to my Otterbox case possibly interfering with the light sensor, but recently it's been happening even without the case. Thus, my assumption is that it's something on the phone itself, but not related to any particular app that I've installed recently.

    Has anyone else seen this persistent dimming, and is there a way to address it?

    I'm running 4.0.4, rooted but with only some limited cosmetic customizations, a few bloatware freezes, and some backup utilities (i.e. TiBu/ROM Toolbox) in place. No major mods or ROM changes.

    Advertisement
  2. narayanan9190

    narayanan9190 Well-Known Member

    weird ! have you set any smart settings ? and does the same occur while charging your device ?
  3. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    No kidding!

    I tinkered with the Smart Settings when I first got the phone, but was unimpressed and shut them all off immediately. So, as of now, I have nothing set to modify the screen brightness automatically. I suppose it is possible that something is doing it in the background that I don't know about, but if that's the case then something has changed recently to trigger it more frequently. I'm not sure how to troubleshoot that sort of thing, though, so I'd be very open to any suggestions you have on that.

    I have it set to never turn off the screen when plugged in/charging, so it will go to the dim setting after 1 minute of inactivity (while plugged in). With this new strangeness happening, then, when I unplug it and start using it, it just stays dim.

    This dimness doesn't happen 100% of the time. It used to be once every few weeks, but it's much more frequent for the past couple of weeks. Probably 60-70% of the time.
  4. steveo42

    steveo42 Well-Known Member

    Same problem only mine goes full brightness at times. No Smart Actions set. No rhyme or reason but it seems to get confused. Started after ICS.
  5. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    I thought I had it kicked by removing a few apps...but then it started happening again. Anyone have any ideas or suggestions?
  6. carracerz14

    carracerz14 Well-Known Member

    Is it on auto brightness? It may just be adjusting quickly. I've seen mine go full brightness sometimes when the light changes suddenly
  7. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    Nope, not on auto-brightness.
  8. razrclive

    razrclive Well-Known Member

    did you reset the phone to factory settings after update to ICS?
  9. narayanan9190

    narayanan9190 Well-Known Member

    The universal cure for all problems right now :D
  10. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    I did back when I first upgraded to it, but not since then. I was afraid that would be the eventual solution. What a pain...
  11. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    I contacted Verizon for help, just for fun. I wondered if perhaps the light sensor was malfunctioning somehow. The one useful thing they told me was that the Razr has kind of a 'safe mode' where you can diagnose whether problems are related to the hardware, or to apps. Reboot the phone normally, and then when the red eye comes up, hold both volume buttons (up and down together) until it boots into safe mode. Seems like I held them for at least 10-12 seconds before it kicked in. Anyway, It's kind of a stripped-down stock version of ICS, but only the basic functionality worked (including, apparently, only the basic and/or stock apps). Testing there, it seems that my brightness worked correctly 100% of the time, so they told me that meant the problem in normal mode was being caused by an app that was somehow modifying the screen brightness automatically behind the scenes. That's not what I wanted to hear, but I suppose it at least narrows things down. I'll probably test uninstall a few apps and see if I get lucky, but I suspect I'll end up doing a factory reset. Ugh
  12. thecarlsoncrew

    thecarlsoncrew Well-Known Member

    Ah-HAH!!! It looks like the culprit is Light Flow Lite. I've been using it forever, but maybe a recent update broke something. I've sent a message to the developer to see if they are aware of the problem and/or have a fix. I'll post again whenever I hear back from them.

    ***UPDATE***
    I have uninstalled and reinstalled the app, and all seemed to be working correctly this time. I received a contact from one of the developers (I think), and he said this:

    I don't recall whether or not these settings were checked previously, but if the mysterious dimming starts up again this will be the first thing I check.

    It appears I'm solid now, but if anyone else has other issues, I'd encourage you sending an email to the app developer.

Share This Page