Screen flickerSupport


  1. Dudditz

    Dudditz Well-Known Member

    Hey guys,

    Rooted and installed ARHD last night, all went well enough, got my phone set up the way I like it then went to bed.

    Woke this morning, had a play around it and then noticed the screen start to flicker ever so slightly.

    It most notable on lightish grey backgrounds.

    Anyway, fully charged it and it seems to have gone, the battery was around 70% when I noticed it.

    Not blaming the ROM as I'm not really sure if that's is the cause, but do we know if it is a hardware or software issue?

    Figure I have screwed my warranty by unlocking and the flicker may well get blamed on that.

    Any advice from anyone who has suffered this?

    Advertisement
  2. cupraman

    cupraman Active Member

    I too had the screen flicker on light grey background. Plenty of threads around if you google about the screen flicker. Mine ran the stock rom but was still within my 28 days so phoned mobiles.co.uk who supplied the phone. They have organised a pick up and replacement so alls well. But no one seems to know if its a hardware or software problem or if future updates will sort the problem.
    Dudditz likes this.
  3. Dudditz

    Dudditz Well-Known Member

    I wonder if I flash my back up, remove CMW and lock the phone T-Mob will take it back for an exchange....

    Just spoke to my parents, got the phone the same day from the same T-Mob shop, they too have the issue but ain't exchanging as it isn't bothering them too much (they are stock, no rooting for them :D)

    Putting it down to the phone and not the ROM in that case (not that I thought it was the ROM tbh).
  4. jemlang

    jemlang Member

    My first one was flickering as well. Did not root the phone. Took it back to Optus and they swapped it over for a new one. Now flicker-free!
  5. shedboy79

    shedboy79 Well-Known Member

    well this is a strange one, my phone as been flicker free, just had the 1.28 update and now have the flicker!! so i mesed about with the screen brightness, turned it up and down, put auto on etc etc. and now it has gone again :confused::confused:
  6. Dudditz

    Dudditz Well-Known Member

    Shedboy :cool:

    Nice to see another Arab around here :D

    Edit to add - Mines appears to be gone now. Happened for a couple of days then disappeared. Did wonder if it was the heat of the phone causing it but even when I play GTA for a bit an it heats up it ain't happening.

    Not sure what it is....
  7. shedboy79

    shedboy79 Well-Known Member


    FTD83 :cool:
  8. Dudditz

    Dudditz Well-Known Member

    WASC :cool:
  9. cupraman

    cupraman Active Member

    Sent mine back and got it replaced, flicker free now.

Share This Page