Screen keeps flashing up for no reasonSupport

Last Updated:

  1. kierons316

    kierons316 Member

    Hey guys, had my galaxy ace (black) since November and had no real problems, but my girlfriend got the ace (White) in January, but for the last week or so her screen has been lighting up for no reason, as though the button has been pressed.

    I've checked through the settings - turned proximity sensor off, turned auto rotate off, just to see if these are to blame... they're not.

    There are no notifications when this happens either. The phone could be sat on the desk minding it's own business when it will suddenly flash up. Sometimes it goes off and then flashes again almost straight away.

    She's had it a little over 28 days, so other than sending off for repair I don't have a clue.

    I do also know someone else who has the ace in white, and she has the same problem.

    I've tried googling but not been able to find anything.

    Any ideas would be great thanks guys :)

  2. Omeniser

    Omeniser Member

    Weird! Same thing is happening to my S2 and I have started a thread.. Hoping if someone comes up with a solution.
  3. Morgster

    Morgster New Member

    OMG. Mine has been doing that alot lately, it'll be sitting on the table or anywhere and suddenly light up without being touched, and I don't have any notifications... I too am confused aye!
  4. Tombi

    Tombi New Member

    I get the same thing with my Ace, more so when it is around my laptop.
    Anyone know why?
  5. jdgreat4

    jdgreat4 Well-Known Member

    Static electricity maybe.. :confused:
  6. Highenemy

    Highenemy New Member

    i have a Samsung galaxy s2 and my screen also lights up randomly.i think i figured it definitely has to do with the red light next to the front facing camera,i dont know about the rest of you but my phone has one,after putting the phone on stand by from the power button by just pressing it once to shut screen,not hold to fully shutdown.
    put your thumb over the small red light and you will see that the screen lights up and do it again and it will close.i did it like that and it hasnt lit up alone again.try it,it might work for you..its the Proximity sensor and once you run many apps later,it will do it again and you must cover the red light with your thumb hasnt lit up with me from the time i did this.even after i ran other doesn't light up anymore (on its own) to the point that its making me worry :D
    i hope this has been helpful to any of you.
  7. volkspas

    volkspas New Member

    i have a samsung galaxy ace and sometimes when recievin a calls it shows that someone is calling but doesnt make no sound,it was not silent and when i tired to call on it again from my mum cellphone it was ok..any ideas pls+
  8. Shabbychic24

    Shabbychic24 New Member

    Hi i want to try that, but I can't find the red light next to the front camera. Mine is samsung galaxy note.. but in the front cam, there are two circles and 1 oblong shape hole. Definitely the bigger circle is the front camera.. I don't know which one is the sensor from the rest.. pls help, coz i think it make sense...
  9. Marcha

    Marcha Well-Known Member

    Though I understand some people with other phones have problems, I'd like to ask to stay with the original topic and the actual forum, meant for the Samsung Galaxy Ace.
  10. ayush29k

    ayush29k Well-Known Member

    This issue seems to be in a lot of samsung phones, although i guess its due to the software bugs rather because i never faced this problem in my ACE, the only similar bug i got was that at times the softkeys light up and at times they won't turn off even when i locked the phone, but a reboot always solved that.

    I haven't experienced any of this since i switched to custom roms.
  11. warwing

    warwing Member

    I'm using a custom Rom
    And have the same issue.

    But not very often.

    Sometimes it will not go off
    Especially during charging.

    I use lock button widget.
    No need to use button.
  12. ayush29k

    ayush29k Well-Known Member

    The lock widget doesn't solve the issue, its as same as using the power button, if the lights come on when using lock button, they will certainly come on using the widget, its just a substitute for the button.
    I use the inbuilt CM power widget, saves using the power button, might even prolong the button's life. :p
  13. Crimsonhawk

    Crimsonhawk New Member

  14. zZzACEzZz

    zZzACEzZz Well-Known Member

    my ace did that like 2 weeks and suddenly it stopped and it hasn't done that anymore
  15. shankar7

    shankar7 New Member

    I had the same problem with my Galaxy S. I uninstalled a couple of themes (non-default) and that solved the issue!
    I guess some of the themes had the ability to wake up the phone even when in sleep mode.
  16. subport

    subport New Member

    hey guys

    I also had the same problem on my galaxy s3. I uninstalled few games and a navigator app and never got it again... I almost sure (though not 100%) that the navigator app (mapfactor navigator) caused the problem... Kinda bad cuz there is no google nav workin' need to find another one... or just let it go hehe
  17. zarrac

    zarrac New Member

    I developed this problem after Google maps asked my to change the way it locates me. that wireless optimize your location thingy.
  18. eliaselkhoury

    eliaselkhoury New Member

    Install ad detector to show the apps which contain risky ad plugins !
    This app solved my screen flash problem :)
  19. diksonktr

    diksonktr New Member

    Dear All, there are one or more answers for this issue of screen blinking automatically.
    1. In settings-Under wireless and networks-under wifi settings disable the network notification.
    2. Download and install AIRPUSH from playstore. Run it and scan the mobile for the applications that cause problems because of the adds in it. Uninstall those application.
    3. If you have installed any live wallpapers, do uninstall them.

    Method 1 & 2 worked for most, n method 3 was the solution for few.. Try it..

Share This Page