Screen keeps turning on by itself?Support


  1. hasbrobot

    hasbrobot Well-Known Member

    Any one have any suggestions for tracking down a rogue app possibly causing my screen to turn on by itself? Is just lying on the table in front of me and sometimes it lights up without me touching it. Its getting annoying and I can't figure out what is causing it. Thank you for help in advance.

    Advertisement
  2. Dieben

    Dieben Well-Known Member

    Try downloading the GSam Battery Monitor, select the right arrow on "App Usage" to get to the "App Sucker", and on the dropdown list at the upper right select "View Num Times Waking Device".
  3. hasbrobot

    hasbrobot Well-Known Member

    Thank you. After a reboot this is what I got. Location is turned off but why is maps so high?

    Attached Files:

  4. hasbrobot

    hasbrobot Well-Known Member

    Oops, Was still charging ignore that. That will affect the results :eek:
  5. hasbrobot

    hasbrobot Well-Known Member

    I'm going to give this app a shot it looks promising. Thanks for sharing it. I'll post later with results.
  6. Dieben

    Dieben Well-Known Member

    To look at the problem a different way try downloading the "System Tuner" application and look at the "Used CPU%" in the Task Manager with "System" and "Kernel" turned on in the bottom toolbar. In addition to usage by apps, System Tuner displays the usage of the individual processes within the Android OS.

    Even if you aren't using them Maps and Google Services may be stuck in endless loops trying to establish your location. Try turning GPS off or on and go into Settings/Location Services and temporarily disable everything and go into Settings/Apps and temporarily disable Maps and everything else that uses location services.
  7. hasbrobot

    hasbrobot Well-Known Member

    Can't seem to track it down, strange? In going to do a factory reset.
  8. sparksd

    sparksd Well-Known Member

    I had this problem and it seems to have been fixed with a Dropsynch (Dropbox Synchronizer app) update. The developer said it was to fix a new issue under 4.2 where the screen came on whenever a synch was run. So it was an app issue related to the 4.2 update.
  9. hasbrobot

    hasbrobot Well-Known Member

    This is why we have forums. Thank you guys very much. It looks like so far the new update squished this bug. It was driving me crazy I could not track this down. Thank you again.
  10. hasbrobot

    hasbrobot Well-Known Member

    Bad news, it's still continuing after the recent update. It's getting irritating to track this down.
  11. drabidea

    drabidea Well-Known Member

    OP, did you have any luck fixing the problem? I am having the same issues, I did a factory reset and it went away for a while and then came back.
  12. hasbrobot

    hasbrobot Well-Known Member

    I did a factory reset and only restored maybe half the apps i originally had via TB. It since stopped and hasn't resurfaced. Evidently it was one of my apps causing it but I'm not sure which one.
    drabidea likes this.
  13. drabidea

    drabidea Well-Known Member

    Well if you don't mind, I am going to list the apps i have installed. If there are any that you had before and don't now could you let me know? Hopefully it will bee helpful to others too.

    8 tracks, adobe reader, aldiko, kindle, astro, audio manager pro, beautiful widgets, calwidget, dog catcher, drive, drop box, earth, evernote, evernote widget, Facebook, espn fantasy football, flixter, foozle, imdb, kobo, lux, mint.com, netflix, osmos hd, Pandora, pewpew, Reddit, skitch, songza, sound hound, stumbleupon tablified market, tasker, tweet deck, wattpad, zedge, and zombie evil

    Thanks for taking a look, the drain in battery life is driving me crazy.
  14. RyanB

    RyanB Distributor of Awesome VIP Member

    If it helps, I don't have this problem, so you can rule out what we have in common:
    Dropbox
    Earth
    Evernote (widget is part of the app)
    Facebook
    Tablified Market
    Tweakdeck (notice the spelling, there is one for each spelling, double check if you're using exactly what you spelled out, or not)
    Zedge
  15. hasbrobot

    hasbrobot Well-Known Member

    I didn't reinstall the following. audio manager pro, beautiful widgets, Facebook, tablified market, calwidget is sticking out for some reason i had a hunch for a while that it had something to do with syncing with my Calender that was waking it.
    drabidea likes this.
  16. hasbrobot

    hasbrobot Well-Known Member

    You might want to think about factory resetting first and then not reinstalling the ones i listed off. I know its a pain trust me i understand.
  17. drabidea

    drabidea Well-Known Member

    Thanks again. Yeah i will back up my stuff and do another factory install. Then i will try not installing those. I was wondering about calwidget too.
  18. hasbrobot

    hasbrobot Well-Known Member

    I hope it stops for you. That was quite irritating for me. Good luck
  19. drabidea

    drabidea Well-Known Member

    Update: i deleted the calwidget app and just turned the nexus 7 on and off. It seems to have eliminated the problem. If it comes back i will post updates.
  20. hasbrobot

    hasbrobot Well-Known Member

    Awesome!
  21. brave_beaker

    brave_beaker Active Member

    call the exorcist ;)
  22. OBGYNE

    OBGYNE New Member

    I had the same problem of the screen of my Samsung note 2 turning on for 3-6 seconds every 1 minute and it was draining my battery. I read so many posts on numerous forums. I tried the suggested remedies to no avail for 2 weeks. What solved the problem for me was when I did a hard reset (volume up, power button and home button) then I installed my apps in groups of 5 apps at a time to pinpoint if the problem would recur. After so much effort I was able to localize the culprit. The problem recurred after I installed a pedometer application (message me if you want the specific app name). After I uninstalled it, the recurring "waking up" of the screen was resolved and I have re installed all my other epps without any screen problems. I hope that helps...
    funkylogik likes this.
  23. ninjanobro

    ninjanobro New Member

    Go to Settings>Security>Automatically Lock> Set To 0

Share This Page