Screen lock during the call?Support


Last Updated:

  1. Skang

    Skang Well-Known Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    114
    Likes Received:
    4
    Hello, i am new here.:)

    So, i was trying to make a payment over the #pmt.

    but, whenever i try to press key button, screen will just black out every 2 sec, i had to press volume button everything. really pissed me off. :mad:

    how do you guys punch Credit Card number like that?:confused:
     

    Advertisement
  2. dopepope

    dopepope Well-Known Member

    Joined:
    Sep 23, 2010
    Messages:
    47
    Likes Received:
    21
    go to settings> sound and display> screen timeout.
    default i think is 1 minute, so check to see that its not on something low like 15 seconds.
    next, do you happen to have "Fast Reboot" installed on your phone?
     
  3. Halcyon

    Halcyon Well-Known Member

    Joined:
    Oct 15, 2010
    Messages:
    236
    Likes Received:
    38
    I had Fast reboot installed and had the same issues. Removed it and they went away.
     
  4. bezerk19

    bezerk19 Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    369
    Likes Received:
    46
    Yup same problem when I used fast reboot, restarted the phone now it works fine.
     
  5. Skang

    Skang Well-Known Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    114
    Likes Received:
    4
    i dont have any of those. pretty much stock.

    maybe i was in the room? room light was on at dark night.
     
  6. dopepope

    dopepope Well-Known Member

    Joined:
    Sep 23, 2010
    Messages:
    47
    Likes Received:
    21
    also make sure your fingers arent covering up the proximity sensor on the phone (just to the left of the ear piece).
     
    AZgl1500 likes this.
  7. jiyyah26

    jiyyah26 New Member

    Joined:
    Nov 12, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same problem, although it happens every time i try to hang the phone up as well. I will take the phone away from my ear and it locks up, so i unlock it and then the screen will shut off. so then i have to turn the screen back on, and then i am able to press "end call". I pretty much have factory apps for the most part, so unless the Fast Reboot comes installed on the phone, i don't have it. i know that my finger is not covering the sensor and it happens everytime, no matter what lighting i am in...

    Can use all the help i can get!!!! it is driving me crazy!!!!!!:mad:
     
  8. chrisexv6

    chrisexv6 Well-Known Member

    Joined:
    Nov 9, 2010
    Messages:
    83
    Likes Received:
    14
    I recently noticed this as well....attributed it to being root-ed with a 3rd party ROM/kernel but it looks like thats not the cause of the issue.

    I noticed that turning the phone off and back on again fixes it, at least for some random amount of time.

    I did have fast reboot installed at one point but Ive since wiped the phone and started with a different ROM and kernel, without reinstalling fast reboot and the problem still occurred again.

    Im wondering if its a bug with the stock set, which the 3rd party ROM/kernel Im using is based on
     
  9. jiyyah26

    jiyyah26 New Member

    Joined:
    Nov 12, 2010
    Messages:
    2
    Likes Received:
    0
    i found this in a different thread posted by namelee78
    it worked for me!!!!!:D

    Hello Galaxy Lovers!

    I solved the problem that screen goes black even if your phone is away from your chin and I'm sure it will also help you to get rid of unlock during calls.

    In my case, one of my apps called System Pannel was killing important service. It is called com.samsung.phoneinfo

    This was causing the problems. Of course, I tested more than 50 times by killing this service and make phone calls. In this situation, my solution was put this service on exclude mode and it works.

    [​IMG]

    I know there's thousands apps for managing active apps and services .(Task killers, Advanced task killers...etc).
    Please make sure your utility apps doesn't kill com.samsung.phoneinfo.

    Here's how you do.

    1. You have to battery pull. Turn off your phone, Take your battery out, Put it back and turn your phone on.
    2. Go to your apps that kills inactive apps and find com.samsung.phoneinfo. make it this in your exclude lists.
    3. Turn off your phone and turn it on
    4. Test it. (I called 611 because i don't get charged:))

    **** I know it works because, my 4 Friends who has Fascinate tried and got their Fascinate working and they are happy. Please if this solution helps you, reply on this thread so that we can help other people*******

    Good Luck guys.

    P.S.
    Personally, I do not recommend using ATK. Sometimes, it will kill so much apps that phone needs it. You can managed this with system panel apps that I'm using. It is better, because you can manually kills your app when you feel like your phone is slowing down. Also, Smart phone is different than iphone. you have to manage this phone continuously.

    I use System Pannel lite to kill apps like Active apps, Background Apps and Inactive Apps with one touch key. Of course, few apps or service, you have to move it to your exclude list so it won't get killed.

    I also use apps called Memory booster once a day and quick app clean cache once a day. Then finish with HistoryEraser once a day.

    If you would like to feel little bit faster, download Spar Parts and Change your Window animations and Transition Animations Normal to FAST. It will help too.

    Thank you for reading and I look forward to hearing from you guys.
    Thanks!!!
     
  10. AZgl1500

    AZgl1500 Well-Known Member

    Joined:
    Feb 3, 2011
    Messages:
    6,100
    Likes Received:
    2,897

    Thanks, removed Fast Reboot and my problem just got resolved.

    This forum rocks!
     

Share This Page

Loading...