screen rotation speedSupport


Last Updated:

  1. lochaos

    lochaos Active Member This Topic's Starter

    Joined:
    Jun 4, 2011
    Messages:
    26
    Likes Received:
    19
    Got my S4 two days ago and im loving it, only thing I don't like is the screen rotation is very slow, can it be made faster ???
     

    Advertisement
  2. 84guy

    84guy Well-Known Member

    Joined:
    Feb 25, 2010
    Messages:
    126
    Likes Received:
    46
    Settings-more-about device keep tapping build number till you unlock developer options, press back and go into dev options and set transition animation to .5
     
    Kie and zig8100 like this.
  3. zig8100

    zig8100 Member

    Joined:
    Jun 30, 2010
    Messages:
    11
    Likes Received:
    2
    Worked on my S3 also. Changed everything to 0.5 n now its super fast. I checked force GPU rendering also n scrolling in fast now too. I don't know if that's the reason though.
     
  4. lochaos

    lochaos Active Member This Topic's Starter

    Joined:
    Jun 4, 2011
    Messages:
    26
    Likes Received:
    19
    This has not improved the rotation speed at all
     
  5. oleb84

    oleb84 Well-Known Member

    Joined:
    Jul 15, 2011
    Messages:
    243
    Likes Received:
    21
    The answer has helped the speed of the rotation but not the lag between rotating the phone and the screen rotation starting.
     
  6. 84guy

    84guy Well-Known Member

    Joined:
    Feb 25, 2010
    Messages:
    126
    Likes Received:
    46
    Turn off smart rotation. Just realized that is your problem, bring down the notification panel with 2 fingers, press and hold Smart Stay and un check smart rotation
     
    BABAB, funkylogik, tcoz2000 and 4 others like this.
  7. lochaos

    lochaos Active Member This Topic's Starter

    Joined:
    Jun 4, 2011
    Messages:
    26
    Likes Received:
    19
    Your a star, worked like a charm, thanks mate ;)
     
  8. Kie

    Kie Well-Known Member

    Joined:
    Oct 7, 2011
    Messages:
    822
    Likes Received:
    223
    Did not know this. Awesome.

    Similar issue I'm having, well not really 'issue' per se: When viewing photos, my GS2 used to auto rotate when I turned the screen around but now you have to press a rotate button. Is there a way to disable this button so it auto-rotates images?
     
  9. 84guy

    84guy Well-Known Member

    Joined:
    Feb 25, 2010
    Messages:
    126
    Likes Received:
    46
    Not sure i completely understand, when the screen rotation is enabled it'll auto rotate. If its not that its probably the smart rotation i mentioned in my last post, and if its not that im not sure what it is, but I'll keep an eye out for other settings
     
  10. Kie

    Kie Well-Known Member

    Joined:
    Oct 7, 2011
    Messages:
    822
    Likes Received:
    223
    An image will help:

    [​IMG]

    See the Rotate button top right? It's the only way to rotate photos when you turn the screen around. It's greyed out in the image, but if I turn the phone portrait, the photo stays as is but the rotate button becomes available, rather than just auto-rotating as you'd expect. Like I said not an issue per se, but it's an extra button to do something that used to be automatic.
     
  11. NacsMXer

    NacsMXer Member

    Joined:
    Jul 26, 2010
    Messages:
    16
    Likes Received:
    5
    This worked perfect, thanks! No more screen lag when I rotate my phone from portrait to landscape and vice versa.
     
  12. 84guy

    84guy Well-Known Member

    Joined:
    Feb 25, 2010
    Messages:
    126
    Likes Received:
    46
    Im on the Sprint Galaxy S4 and i dont even have that option when in a photo, so im not sure whats up with that, sorry

    [​IMG]
     
  13. Kie

    Kie Well-Known Member

    Joined:
    Oct 7, 2011
    Messages:
    822
    Likes Received:
    223
    And I'm not even on a custom rom yet! Intriguing how the i9500 and the i9505 differ.
     
  14. aksgx4

    aksgx4 New Member

    Joined:
    Jun 1, 2013
    Messages:
    1
    Likes Received:
    0
    -------------------------------
    U really solved my problem.....
     
  15. Ice

    Ice Active Member

    Joined:
    Sep 3, 2010
    Messages:
    27
    Likes Received:
    0
    Thankyou, Was doing my nut in!!!
     
  16. fubu05

    fubu05 New Member

    Joined:
    Sep 5, 2013
    Messages:
    1
    Likes Received:
    0
    Rock! I registered here to thank you for this solution. You solved my problem ;)

    Thanks again.
     
  17. mihaelb

    mihaelb Well-Known Member

    Joined:
    May 4, 2011
    Messages:
    141
    Likes Received:
    8
    Just expand on that: you don't have to completely turn off smart stay. You can press and hold the smart stay option, and just turn off the smart rotation.

    Cheers
     
  18. m3incorp

    m3incorp Well-Known Member

    Joined:
    Nov 15, 2011
    Messages:
    118
    Likes Received:
    9
    I learned something today :)
     
  19. WonderFull

    WonderFull Active Member

    Joined:
    Apr 4, 2012
    Messages:
    39
    Likes Received:
    1
    I've 9500 with 4.2.2 and when viewing photos it auto rotates. Do not have the rotate option.
     
  20. oldmick

    oldmick Member

    Joined:
    Jul 7, 2014
    Messages:
    7
    Likes Received:
    2
    I wondered how to speed up up my note 2 s rotation as well, turning off smart rotation did the trick, Thanks 84guy if your still about.
     

Share This Page

Loading...