screen turns off when away from head while phone call is onSupport


  1. starmandell

    starmandell Member

    hello for the s3, do any of you guys have the issue where...when you're on the phone, the screen turns off to save battery. however, once you pull the phone away from your head, the screen should turn back on so you can see the numberpad etc.

    however, when i pull mines off my head, the screen turns on and then immediately off again so i can't hit the keypad on my phone

    Advertisement
    :
  2. Hogan773

    Hogan773 Well-Known Member

    Sometimes the proximity sensor is dirty or it is sensing something else like a finger if you're trying to approach the keypad to type in a password or something. Don't approach the keypad from the top with your hand, and wipe off the glass at the top of the screen in case your face grime is blocking the prox sensor.
  3. SUroot

    SUroot Well-Known Member Developer

    Another all time favourite is screen protectors obscuring the sensor
  4. starmandell

    starmandell Member

    could you clarify what you meant by 'Don't approach the keypad from the top with your hand'

    thanks = )
  5. sherlock5545

    sherlock5545 Well-Known Member

    It means that if are typing on the keypad while calling, make sure your hand isn't on top of the proximity sensors, or the phone might think it is facing your ears/head and turn off the screen.

    Anyway, the screen goes off to avoid you "touching" anything with your ears, as being a capacitive screen it's very sensitive.
  6. Hogan773

    Hogan773 Well-Known Member

    hold the phone flat in front of you. Stick out your finger and press forward straight ahead. This would be approaching from the middle.

    Now angle the top of the phone a little toward you, and/or move your hand up so that when your finger is approaching the middle of the screen, your knuckles are straight in front of the top edge of the screen. This is what I mean my approaching from the top.
  7. Haris

    Haris Well-Known Member

    Can you please provide a diagram?



    LOL jk
  8. matttye

    matttye Well-Known Member

    Slightly off topic but I think the question has been answered so I'll chip in with this anyway; the proximity sensor is also to stop you accidentally pressing buttons with your face while you're on the phone.
  9. 4tunesmiles

    4tunesmiles Member

    This is crazy. The phone is way too sensitive. I called to cancel a doctor appointment today, and of course got a voice mail system... "if you are calling to cancel, push "1""... and I couldn't do it! Everytime my hand approached the screen, index finger extended, the screen went black. I finally had to sneak up on it from behind with my left hand, and reach my left index finger over the top of the phone and push "1".
    I have a perfectly clean screen and no screen protector.
    Where is the proximity sensor?
    There must be some way to disable this feature?
  10. matttye

    matttye Well-Known Member

    There's no way to disable it that I know of; mainly because as I said above, it's a feature intended to stop you from pressing buttons with your face while you're on the phone.

    I can use the entire keypad without the proximity sensor kicking in though. It's up by the ear speaker.
  11. moonlitday

    moonlitday Active Member

    I just hit the home button when I want to see the keypad while on a call.......
  12. heymargo

    heymargo New Member

    Click your phone icon, go to its settings and unclick Auto screen off during calls.
    neilfries and Johnnybee like this.
  13. eyecon82

    eyecon82 Well-Known Member

    This also happens and goes wonky at times and most of the time i have no issue

    what I do when it goes wonky is press the home button, then go into the call app from the dropdown notification bar
  14. maxell2143

    maxell2143 New Member

    my galaxy s3's screen has a problem. sometime i can not turn on the screen even though i hit home button. the only way of turning on the screen is to remove battery and put it again. what's wrong with that? what should i do?
  15. Pandasauce

    Pandasauce New Member

    I was having this same issue for because of my broken screen. Normally this issue is caused because of a dirty(face grease) proximity sensor and wiping down the top part of your screen would solve the issue.

    I dropped the phone on asphalt and a rock dented the edge, pushed up from underneath the glass and shattered it. I kept the tempered glass screen protector on to hold the shattered glass together. But dust is now able to get under the screen and my proximity meter is too dirty to sense my face.

    For weeks I was pulling the battery out when I needed to hang up a call because I couldn't get my screen to turn on. Until i found if you go to the settings from your phone app you can turn the sensor off so that the screen doesn't even turn off when you make a call.

    Its not perfect, but much better than having to pull your battery out. I hope this helps.
  16. marshcat

    marshcat New Member

    :pThanks to all the other messages above, I recently bought my S3 of Ebay and the screen kept switching off during call, now i have disabled it as detailed above.

    Point to note once connected you can still switch on off the screen by using the quick press of on/off button on the side of the phone, thought this may aid people with similar issues when disabling the screen switch off but are nervous of activating something with their ear lol.
  17. n4zty

    n4zty Well-Known Member

    no no no you guys are doing it all wrong every1 knows u have to lay flat on a surface then creep up on it from the side slowly and when the screen turns back on u have to quickly press the number.

    just joking :D
  18. giraldjm

    giraldjm New Member

    thanks for the info!!! other option I have seen is to enter phone settings and selecting "answering/ending calls" and the clicking on "the power key ends calls"...that is a way to end the call if desired (i.e. answering machine answers but dont want to leave a message)...without having to turn proximity sensor off.
    regards, giraldjm
    nuttynat84 likes this.
Loading...

Share This Page