SD card blank or unsupported filesystem


  1. shrpshtr325

    shrpshtr325 Well-Known Member

    This seems to be an error which has come up since rooting, if i go through the rooting process again the problem goes away for a while, at first i thought it was SU, but now im not so sure, i turned off auto updating to see if that took care of it and the problem resurfaced today, i went through the rooting process again and its gone, we will see how long it stays gone.

    before reflashing the kernel i tried just pushing the origional SU, busybox and SuperUser.apk files to the unit again with no results. had to redo everything in order, i feel like it has to be software related, but this is not my specialty so im asking the experts.

    Advertisement
    :
  2. Scur

    Scur Well-Known Member

    I've had this pop up. I just rebooted and my sdcard came back. I don't know what's causing it either.
  3. shrpshtr325

    shrpshtr325 Well-Known Member

    i even tried my old 2gb sd card in the phone and it gave me the same error, the fact that a reflash of the kernel fixes it makes me think software, but i have no way to confirm this.
  4. shrpshtr325

    shrpshtr325 Well-Known Member

    sorry to double post here, but i have an update

    the issue showed itself again today, this time rebooting took care of it,(took a couple of reboots to get it right tho) im still convinced its software related for a hardware problem would be much simpler to recreate.
  5. Jodabro

    Jodabro New Member

    I have had the same issue, several times. OK I have had this problem with both CM7 and now MIUI. Ever since I rooted really, at random. Best I can guess during usb dismount or app crash my SD card becomes corrupt with a bad writen file. Have search high and low, found many others experianceing the same issue.

    Android OS tells me blank card or uncompatable file system. Phone will just go into a loop if you ask it to reformat the card. Ways I have got it back suggest its a software issue.

    I have tried several cards when this happen and same error comes up. I have to put the card into a pc and reformat, then reload all the folders and files previously saved before corruption happened. That usually helps, sometimes though I have to reflash the ROM, when I can get a card to read.
  6. shrpshtr325

    shrpshtr325 Well-Known Member

    the problem on my phone was Titanium backup, i have uninstalled it and the problem has not come back since i deleted it (its been about 2.5 weeks)

    it took about 3 days to come back before.
  7. koodawg

    koodawg New Member

    I'm new to android, just spent some time searching for answers, found solution and wanted to share my findings;

    I have a new Samsung Skyrocket. First time I plugged it into Windows and Mac the drives appeared and I was able to begin copying music. Days later I couldn't get this to work and it took me numerous hours to resolve.

    I saw posts referring to a procedure like this; connect phone to usb port, option to use usb storage appears on phone, hit ok, and you're good to go.

    This doesn't happen on my version of gingerbread. I have to go into the the usb utilities, choose to use usb mass storage, then it tells me to connect to usb port on computer, I do so then phone says to click ok to continue and if it's successful then phone screen says USB storage in use. That's how it goes when it works. I had this work on Windows and Mac. Drives appeared in file browsers of both OSs.

    Now what happened for the past 2 days is that I'd connect phone usb cable computer (and get a notification chirp) but I wouldn't get that succeeding screen on the phone saying ok to continue. Instead it went back to the original usb utility. I jacked around with this on and off for two days, trying, searching for clues.

    I also tried connected to a linux box since that's where I really wanted to connect anyway - directly to my music host. Same thing occurred on the phone which connecting to linux (FC14). Odd thing was that I was at first not getting any output in dmesg at all. No indication of any usb device being connected. Weird. Much searching. Nothing.

    I ran across some posts about Kies. Looked at that app - it's for copying over wifi. Don't want that. Then I read something about how a guys phone was set with the usb attached to Kies and he had to unattach it. I couldn't find a way to do that exactly so I just rebooted and things started to get good.

    Now when I connected to linux I was getting the appropriate usb device messages in dmesg. But I still could not mount the devs. fdisk even failed to display any info at all. Weird. Then I realized I need to go into the usb utils and enable usb mass storage use. Did that and all is well.

    Now when I connect phone usb to computer (win, mac, linux) it's mounting and the world is right again.
Loading...

Share This Page