SD card Damaged


Last Updated: 2013-11-10 16:47:44
  1. Carbonangel

    Carbonangel Member

    Hi Guys

    So im getting a problem with my new desire.

    I have my SD card full of music, well not full, around 3gbs worth synced with Silling media sync (itunes playlist syncer)

    i plug it into my car stereo via USB the stereo is the Alpine X305 which plays mp3 etc from USB drive.

    The phone works at first, plays the music etc all day long, but when i come to get out of the car and disconnect the USB from the phone, the desire comes up with:

    Preparing SD card then SD card damaged, you will need to format the SD card

    I tried this again with a freshly formatted SD card and it does the same every time the phone is unplugged

    This is a major pain for me, any ideas?

    Cheers

    Advertisement
  2. lekky

    lekky Lover VIP Member

    Don't suppose you could try a different SD card?
  3. Carbonangel

    Carbonangel Member

    No, i only have the standard one which come with the handset at the moment
  4. lekky

    lekky Lover VIP Member

    You know I've had major issues with the one that came with the phone. I have my own 8gb so I gave my gf the 4gb that came with the phone to use with her new hero.

    But I get the same as you, keeps saying the sdcard has been damaged and even that there is no sdcard in the phone. This is on the Hero with the Desire sdcard. I have even reformatted it and still get the same errors.

    I wonder if the sdcards they provided with the phone are below par quality wise.. My old 2GB sdcard that came with the Hero still works fine.

    Maybe go back to the place you bought it from and explain about the sdcard, this is what i'm planning to do anyway.
  5. antipesto93

    antipesto93 Well-Known Member

    i had a similar problem, the sd cards they provide are...well...crap...all in the name of cutting the production costs!
  6. Carbonangel

    Carbonangel Member

    I understand what you are saying, however i didnt want to spend out like 40quid on a 16gb card only for it not to work and do exactly the same! :D

    Maybe ill pop out on dinner hour and get one
  7. serenity

    serenity Member

    Well my supplied SD card became damaged yesterday and I hadnt even been doing anything with the phone! My PC cannot even see the card and although my laptop can see it it only reports the capacity of 30mb and will not reformat it.
    Never known an sd card to get damaged that quickly befoer they truely must be rubbish which is a shame for such an awsome phone. I hope they havent used any other cheap bits in the actual build of the phone :confused:
  8. antipesto93

    antipesto93 Well-Known Member

    BRAND NEW 16GB MICRO SD CARD MEMORY CARD MICROSD frm UK on eBay (end time 14-Apr-10 06:51:09 BST)
    :) ebay do memory cards for cheap!! :) as do amazon


    i have purchased from this seller many times
    16GB SANDISK MICRO SD HC SDHC MEMORY CARD FOR NOKIA N96 on eBay (end time 02-May-10 08:03:07 BST)
  9. Carbonangel

    Carbonangel Member

    A little update, i think i may have sorted this.

    My SD card is a Sandisk 4gb SDHC card so you would have thought that the quality of this card should be ok??

    I removed my battery and took out the card using the ridge and my finger nail and it just come out, like the sim card.

    However when i put the SD card back in it seems to Click in with a full push.

    I plugged it into my car stereo and when i removed it it prepaired the SD card without Failure.

    Im just syncing some music to the phone now, then ill test again fully and report back
  10. Carbonangel

    Carbonangel Member

    Update, it didnt work, still SD card Damaged when i remove the usb from my stereo
  11. Yorik

    Yorik Member

    Is it possible that your car stereo is not cleanly unmounting the SD Card? I know my car stereo and a few other devices do it on another phone of mine. If you plug the SD Card into a non windows computer (Linux, Mac etc) does it do the same? Have youi searched the model of your car stereo to see if anyone else is having any issues. I am not saying that it is not Android or the Phone, but to me it sounds like the OS is protecting the card (and potentially you) from an uncleanly mounted Filesystem.
  12. Carbonangel

    Carbonangel Member

    I thought that at first, but i cant seem to see anywhere on the desire an option for unmount? there isnt anything for it on the stereo either
  13. Carbonangel

    Carbonangel Member

    Ok i tried another SD card and i've got the same problem, so its pointing towards a unclean unmount.

    Can anybody advise of any way to unmount from the desire end, or an application to give the same effect
  14. lekky

    lekky Lover VIP Member

    settings > sd and phone storage > unmount sd card
  15. Carbonangel

    Carbonangel Member

    I found this option exactly 10 seconds after posting my last, i should have edited! :(

    Is there anyway to put this into a shortcut? what i could put on the homescreen for example?

    Edit:

    That option is not availible while my stereo is plugged in, its greyed out, i think im just going to accept that this phone doesent work with my stereo, which is a shame as the sound quality is great while it works (the first time)

    Even when i turned the stereo off, it swapped the mode to Charge only then 2 beeps and the Damaged SD card msg again :(
  16. mcapozzi

    mcapozzi Well-Known Member

  17. lekky

    lekky Lover VIP Member

  18. Carbonangel

    Carbonangel Member

    thanks for the suggestion, this still causes the same problem, as soon as i click to unmount the card, i get the

    Preparing SD card, then SD card damaged pretty much straight after, i don't think its going to work either way
  19. stepheny

    stepheny New Member

    Im getting exactly the same.

    I keep getting the SD card removed error or occasionally the SD card is damaged and needs reformatting - I try to reformat if this appears on the phone but it doesnt work.

    The problems started when the phone would be active (alarm would go off, or it would ring) but the display wouldnt switch on from standby when i pressed the power button.

    I reboot and get the SD card error after the blank disply issue. A full reset has not solved the problem and now with every boot im getting SD card removed.

    I had a class 2 sandisk 4gb supplied with it - I have another class 4 8gb that came with my nokia 5800 - both now give the same problems and work fine in a PC.

    Any ideas? The phone has been working for 4 days OK previously.
  20. sajon44

    sajon44 Member

    totally new to this so go easy.
    exactly the same happened to me when i tried to connect my phone(htc desire) to my alpine head unit.
    not wanting to keep copy data back onto card i only tried this once but it worked,bit of a pain mind.
    i noticed that the sd card said damaged, when i would turn the keys off to the car,so just unplugged the phone direct from the usb without turning the ignition off and the sd card did not say damaged.
    only tried this once mind.
    what is the app called auto mount would that help????
  21. jimmyb79

    jimmyb79 Active Member

    I'm having this issue with a 16gb Kingston card. Trying to sync my music from my mac to my Desire via various methods - Drag and drop through the finder (explorer), Missing Sync and Doubletwist. All end up the same, and as said before points to the SD card not unmounting properly. Starting to get a bit concerned that its possibly an issue with the phone?
  22. nx1977

    nx1977 Well-Known Member

    No issues here with the supplied card.

    Have you tried selecting the "runs as mass storage" option under settings with your stereo carbon angel?
  23. stepheny

    stepheny New Member

    Just an update to my issue if this helps anyone - phone swapped out next day today and now works fine.

    The same SD card was put in the new phone and worked fine whereas it wouldn't accept it at all on the old phone.

    Looks as if it was a faulty phone/SD card slot.
  24. Carbonangel

    Carbonangel Member

    I cant see this option anywhere under my stereo
  25. jimmyb79

    jimmyb79 Active Member

    I've swapped my 16gb out to the supplied 4gb card and it seems to work fine. My 16gb was a class 2 and the 4gb is a class 4 so I don't know if thats got anything to do with it.
    I suspect that the card I was using is to blame rather than the phone though...

Share This Page