SD Card DissappearedSupport


Last Updated:

  1. RPM_WG

    RPM_WG Member

    Last night, I went to bed and plugged my phone in (Samsung Infuse). When I woke up this morning, I saw one of my apps on my home screen had the generic Android icon, and when I clicked on it, it said "app not installed". Upon further investigation, all of my pictures were gone.

    I went to settings/SD Card and Phone Storage, and under Total Space and Available Space for SD card, it says unavailable. The 'Mount SD card' button is subdued (as in I cannot click on it). It appears that my phone is not reading my SD card, and it is installed. I tried rebooting my phone twice, and even pulling out the SD card with the phone off and reinstalling it to no avail.

    I have not rooted my phone or modified it in any other way. Does anyone know what went wrong with my phone? It has not been dropped or been splashed on since I got it (about 2 weeks ago), and this just came on suddenly this morning.

    -Robert in Tx.

    Advertisement
  2. dan330

    dan330 Well-Known Member

    i sometimes have this issue.. soft reboot does not help.

    you need to do a battery pull while the phone is on.
    it should then re-initialize everything including the sdcard.

    the final problem .. in my case... the card was bad..
    yours might be too.
  3. RPM_WG

    RPM_WG Member

    Well, now all of a sudden, everything seems to be working fine. I did nothing, but now all of my pictures and Alps are back on my phone. I don't know what happened to it.

    -Robert in Tx.
  4. lunatic59

    lunatic59 Moderati ergo sum Moderator

    *moved to Samsung Infuse Forum*
  5. pendragon1998

    pendragon1998 Member

    I had what I think is the same issue. I ended up resolving it by tethering my phone to the PC and accessing the external SD card. Everything was still there (in my case, apps stored in the .android_secure directory). I copied them all over to my PC. Then I unmounted and formatted the external SD card from inside the phone. After remounting the card, I transfered back all of the files from my PC. Once I did that, all of those generic icons were back to normal and my apps were working again.

    I don't know if I trust the 2 GB SD card that came with the phone. I'd been having sporatic error messages having to do with it. I think I'll go ahead and upgrade to a 16 or 32 GB card from a name brand, copy my original external SD to it, and hopefully not have to deal with this any more.

    Anyone know whether it's worth buying a class 10 micro SDHC card?
  6. Mr. Ed

    Mr. Ed Well-Known Member

    I have had no issues with my 32gb class 4 i purchased at best buy.. But by all means if you find the faster card at a good price...buy it!

    If we didnt have the 16 gb internal I would say it were pretty important...but everything phone related goes through that...not the external. I use the external for music movies and random storage
  7. pendragon1998

    pendragon1998 Member

    From what I'm reading, it sounds like the higher class cards will mainly be of benefit in quickly reading/writing to the PC, and then, only if your card reader is fast enough to take advantage.
  8. pendragon1998

    pendragon1998 Member

    Correction: The 'solution' I posted above did not permanently fix my problem. This morning, after the phone slept overnight, I had a red error triangle again saying "SD card unexpectedly removed".

    If you search for that phrase, you see a ton of posts going back a year or two for people having the same problem. Some folks think it's a bad card, or the wrong class card, or a formatting problem, or an android problem. I haven't found anyone who's definitely solved it (so far). Can anyone point me in the right direction before I spend money on a new card?
  9. Mr. Ed

    Mr. Ed Well-Known Member

    have you tried remove it and put it back in?

    it really does sound like a bad card tho
  10. pendragon1998

    pendragon1998 Member

    Repeatedly. I've run check disk on it in Windows, for all the good that did - no errors. Reformatted it again (FAT32) and it went all wonky before the end of the day. I ended up transferring the apps from the card onto internal storage and ordered a SanDisk 16 GB Class 4 card from newegg. See if $20 fixes the problem...
  11. nachomommi

    nachomommi Member

    please let us know
  12. pendragon1998

    pendragon1998 Member

    Hey dudes,

    I got my new SanDisk 16 GB class 4 card last week, formatted it in the phone, and so far I haven't seen the SD card error I'd been getting. I haven't been using the card much yet, but I'm going to load it with my tunes soon and will post back if the error pops up again. So far, so good.
  13. KCP884

    KCP884 New Member

    I have a LG Thrill and it is brand new. All of the sudden my 'camera' and 'media gallery' and all 'music' would not load with a prompt saying "Media Scanner Running." So after about 5 1/2 hours of working on it this is a fix.... Simple as it may be, yes it really took me that long... LOL...

    1. Turn off
    2. Take out SD card
    3. Take out battery (this may be optional but a hard re-boot maybe necessary anyway)
    4. Put battery back in
    5. Power On ( it will finally scan media)
    6. Re-insert SD card...

    At first just taking out my battery worked, but then it stopped working.... So this is a temporary fix... Although I think I came across a permanent fix for the android system... But I can not remember where it was... Also the SD card has to be mounted and working for that fix to work... So if anyone can link that permanent fix... That would be great :)
  14. Stauchwall

    Stauchwall New Member

    I have had exactly this problem as described above and got it to resolve in the past by resetting to factory condition. After spending an hour online with Samsung with the same reset prospect looming, I thought of setting the phone to mass storage when connected to my XP desktop. The screen flashed a couple of times and then eventually I was able to mount and unmount the SD card several times. All of the icons look normal now. I am beginning to suspect that the USB driver somehow is not found by the phone, and tethering to the computer resolved the issue. Am sure that the problem will return and when it does I will try this process again or simply reinstall the USB driver.

    -Mark in OR

Share This Page