SD Card Formatting ErrorSupport


Last Updated:

  1. ndh777

    ndh777 Well-Known Member

    I know that this is a common problem, although I haven't found any real solutions to the problem.

    My friend had a problem like this on his Epic 4G and I heard about it on another Android phone, I believe the Samsung Moment.

    So I've been using my memory card for a while and haven't taken it out in about a month and a half. I've been adding stuff to it, taking stuff off, etc. and have been being very careful when disconnecting it as in disconnecting it from the computer via the My Computer "eject" button, or right clicking the icon in the right corner (on Windows 7 Home Premium) and safely disconnecting it.

    Today I download two different updates from two Glu Mobile apps, the BT Gangsta and Gun Bros. Where it asks you to download the updates to your SD card or your internal memory. I downloaded the update to my SD card on both of them and when they were done, it went to a black screen then force closed. I assumed that it was a problem with the apps, so I restarted the phone and turned it back on. When I did that, an icon appeared telling me that "Blank SD card SD card blank or has unsupported filesystem"

    I tried opening music and it wouldn't load neither would anything else off of my SD card and nothing will open. I tried taking out the SD card and putting it back in but it still gives me the error.

    My friend with the Epic simply formatted his SD card as the phone requested. I can't do that as I am rooted and need backups stored there and also have other important things on there. So I was wondering if anyone could help me.

    My computer doesn't have enough space to keep the files on the SD card so I can't back them up on the computer. The SD card is a 16GB and is FAT32 I believe.

    Advertisement
  2. ndh777

    ndh777 Well-Known Member

    Oh wow...apparently, it deleted EVERYTHING from my card!!!

    When I tried connecting it to my PC using a USB converter, there was NOTHING on the card. Wow...this sucks so much. :///
  3. ndh777

    ndh777 Well-Known Member

    I tried formatting the SD card through the phone's formatter and it still says that the card is blank with the same message...this sucks....:(
  4. ndh777

    ndh777 Well-Known Member

    And now Windows can't format the SD card...
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    on your phone what does the message say when you tried to format the card?
  6. ndh777

    ndh777 Well-Known Member

    Once I formatted using the phone, it said that it was checking the SD card for errors. Then it gave me the "blank card" error. Both of these were seen in the notification window that drops down in Android.

    I'm now trying to format it using Command Prompt. It is at 6% right now so we'll see how it goes.
  7. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    that is odd. i never heard of this happening before. have you tried your card on another computer?
    ndh777 likes this.
  8. ndh777

    ndh777 Well-Known Member

    Yes, three different computers and two different operating systems as follows:
    1st-Android OS running CM7 ROM on my HTC Evo 4G
    2nd-Windows 7 Home Premium PC
    3rd-Windows Vista Home Premium PC
    4th-(another) Windows Vista Home Premium PC
    and now I am trying to format using Command Prompt back on my Windows 7 PC.

    I actually made a mistake, or I think I may have...when I said that my friend had an Epic and was able to format it, I believe he had to get a new SD card. I'd rather not get one as I like this one and don't want to buy another unless it's 32GB or higher and...yeah, I'd rather just be able to find a solution to this problem if possible.

    Googling/Bing search has found results with similar problems across the Android device line. Some are saying that the problem is so bad that it happens on a daily basis sometimes and they are saying that it is a problem with the device and not the SD card which is odd that it wouldn't work after being used with other OSes.
  9. ndh777

    ndh777 Well-Known Member

    WOW! So the format finally finished via Command Prompt and it appears to work as I can view the card in My Computer on the Windows 7 PC. I'm going to insert the card into my phone and see what happens.

    The SD card is now formatted and working in the phone. My phone reads the card well. To anyone wondering how to format a card in Windows Command Prompt, follow these steps:
    In Windows 7, open Command Prompt by searching for it in the Start menu. Once found and opened, type in the name of the drive that you wish to format like so "format H:" or "format :H" (whatever letter corresponds to the drive, insert for "H"). Follow instructions. Click enter and wait. Percentage will be shown as progress occurs then it will finish and you will see the driver open up as before and your drive will now be formatted using Command Prompt.
    ocnbrze likes this.
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    well glad you got that figured out. weird. i gues no glu games for me.lol
    ndh777 likes this.
  11. ndh777

    ndh777 Well-Known Member

    Thanks for the time in asking though ocnbrze! Really appreciated the help you tried to offer lol

    I'm not sure if it was Glu that caused it though...stupidly, I went ahead and downloaded the files again for both games and both games downloaded them and are working fine now.

    I don't want to put the blame on them if they're not at fault but I threw that out there more so if someone also did that then we could have a reason that might be right. It is weird that the SD card became corrupted after I installed their file though so they're not entirely off the hook :p
    ocnbrze likes this.

Share This Page