sd card gallery issue


Last Updated:

  1. CraigSr83

    CraigSr83 New Member This Topic's Starter

    Joined:
    Oct 7, 2010
    Messages:
    2
    Likes Received:
    0
    Ok so my sd card had corrupt data on it. I fixed the files:p:mad: with my PC, now when I go to my gallery it say loading new albums and when its finished just an empty gallery. However, when I go into astro in the dcim folder I can view my pictures just fine. I've reset my phone, unmounted and remounted the SD card and still nothing.
     

    Advertisement
  2. ndoren

    ndoren Well-Known Member Contributor

    Joined:
    Nov 29, 2009
    Messages:
    168
    Likes Received:
    46
    When you reboot your phone, there is a separate, background process that scans your SD card for media. I think it's called "Media Storage." It then builds a database that is read by the gallery.

    Keep in mind that this background media scanning process sometimes takes a LONG time to run. It blindly looks through all your SD card files and directories looking for suitable media... mp3s, video files, etc. Depending on what's been modified on your card, it's a long process.

    Give your phone a few hours... without rebooting or remounting your media (which will restart the process). Then see if they appear in the gallery. If not, make sure your SD file system is not corrupt, and that you have no bad media files that could hang up the scanning process.
     
    CraigSr83 likes this.
  3. CraigSr83

    CraigSr83 New Member This Topic's Starter

    Joined:
    Oct 7, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks. That had to of been it, everything is back to normal. Real quick though my SD card was "damaged" and during that time my phone better than ever. No home screen icon delay no lag, but once I scan and fixed my SD card now its back to doing exactly that.
     

Share This Page

Loading...