1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

SD card issue


  1. matttye

    matttye Well-Known Member

    My fianc

    Advertisement
  2. InfernalByte

    InfernalByte Well-Known Member

    It just that the reader isn't updating the values in real time. Power off, then on again, I'm guessing its as simple as that.
  3. matttye

    matttye Well-Known Member

    Already done that.

    I also suggested she unmount the SD card and then remount it, but the phone still won't let her take pictures. She's deleted gigabytes worth of apps and pictures but only about 4MB of space has been returned.
  4. SUroot

    SUroot Well-Known Member Developer

    If it mounts on a pc, backup files and format.

    Win 7 may even request to scan and repair. If it does, let it
  5. matttye

    matttye Well-Known Member

    Anything you know of that might help from the Market? The difficulty is she's on holiday until Friday and wants to use the phone to take pictures, but doesn't have access to a PC until she gets back.

    Cheers mate
  6. SUroot

    SUroot Well-Known Member Developer

    Not really.

    What is the error? Sometimes there is a mount read/only issue but it doesnt sound like its this.

    I take it she has tried a battery pull rather than a turn off and on?
  7. matttye

    matttye Well-Known Member

    She tried an unmount/remount. Then she tried an unmount, switch off phone, remove battery, remove SD card, put SD card back in, switch on phone. Also just tried a regular reboot with the card in.

    There's no error, it acts like it takes the picture but just doesn't appear in her gallery.
  8. SUroot

    SUroot Well-Known Member Developer

    i think still get astro and browse to the location. Could be a gallery issue. Check that astro can locate images in DCIM. if it can, try a clear data on gallery, follwed by deleteing the following folder on SD card:

    sdcard/android/data/com.cooliris.media

    That should build the database and thumbnails from scratch
  9. matttye

    matttye Well-Known Member

    Thanks I'll get her to try that.

    The thing that makes me think it's something more is that Menu > settings > storage doesn't show the data being freed up, although apps and pictures are no longer present on the phone after being deleted!
  10. SUroot

    SUroot Well-Known Member Developer

    Yes to me it sounds like its possible a file system issue.

    When you delete a file, it is not deleted. Simply its reference in the File Allocation Table (FAT) is removed. Its a database which provides the OS reading the FAT a link to the file and relevant size information for the file.

    Once this is link is removed, it should show more space, even though there is not. Next time a new entry to a new file is added, the old file WILL THEN be overwritten.

    What may be happening is that the File System (FAT) is not reflecting these changes due to a corruption.

    My first instinct would be to copy out all the files elsewhere and reformat the card.
  11. sookster54

    sookster54 Well-Known Member

    These kinds of symptoms are common among those using an ext4 partition on the sdcard. Also improperly dismounting the sdcard while plugged into your Windows PC can wreck it as well.

Share This Page