SD Card issues that appear to be contagious!Support

Last Updated:

  1. Sorraia3

    Sorraia3 Member

    Earlier today I tried to go into my Dolphin Browser and it wouldn't launch. Then I tried AppsFire and ES File Explorer... none would launch. I went into Settings>Applications>Manager and it just hung on computing. I tried to plug in the phone to the pc and it no longer recognized it. I tried to unmount the SD card from in the phone and it just froze then force closed the SD card app. I have tried reboots and shut downs and removing, replacing the card... nothing... NO apps that are on the SD card will work, but the phone mounts the SD card every time. So it knows it is there, it just won't read it. I can't install/uninstall anything. I can pop the card in the pc and see everything on it. I can open the files and view it all. I have copied all of it the pc and was going to format it in the phone but it won't unmount it to let me.

    Sounds like the SD card is shot right? Here's the weird bit...

    Put the sd card into another MT4G... it found and mounted it fine. It let me unmount it and format lit up. So now I'm thinking it is the phone so I pop it out and put it back in my phone... same issues. Put the other phones card back in it and now that phone is doing the same thing!!! Whatever was wrong transfered from the SD card to that phone! Now I have 2 MT4Gs that won't launch apps that are on the SD card. all apps on the phone themselves still work... for now anyway. Could this be some kind of virus or malware? How can I backup the stuff that is on the phone itself to try a factory reset?

    Has anyone encountered anything like this before? It really seems like whatever is wrong is contagious and passed to the other phone! Please Please help! We have so much stuff on these phones! The SD cards are backed up but I can't figure out how to backup all the stuff on the phones.

    Thank you for any and all help!


  2. ilpochino21

    ilpochino21 New Member

    I have had the same issue, but it has been an issue with both the Nexus One when I had it, and the Mytouch 4G. The only bad part is I have yet to find a way to fix it other than wiping the phone and memory card and starting over. I have found that what usually triggers it is disconnecting the phone from the PC without properly dismounting it or turning off the phone while it is trying to access the memory card. i.e. Restarting the phone before it has properly loaded all of the apps on your SD card. The only good thing is that you backup your phone to your Google account, after you wipe all your apps will automatically restore themselves. You will however lose all progress you had in games. But its the only fix I know off.

    Hope it helped.
    Sorraia3 likes this.
  3. Sorraia3

    Sorraia3 Member

    After popping the battery this morning the SD card apps were back. Then tonight I plugged it into the computer ok, copied 2 files to put on the other phone, plugged that one in and copied them fine. And I did use the remove device thing to disconnect them, but again no sd apps on both phones! However on the other phone they came back again after a battery removal but not on mine. :-/ This is seriously frustrating!

    Funny thing is... it is just the apps... I can go into Astro, open a movie on the SD card and watch it! But still can't launch any apps on it.
  4. bshafer

    bshafer New Member

    Hi, I have the exact same problem. Did you ever find a solution?
  5. Sorraia3

    Sorraia3 Member

    I have not found a permanent solution yet, no. It will work again if I pop the battery, wait a minute or two, then put it back in and turn the phone on then wait not doing anything for like an hour.

    But if I restart, shut down, or connect to the pc, it's gone again.

    It seems to be that if there is anything major done with the status of the SD card it happens. Just installing or uninstalling apps or moving or using files, etc does not affect it.

    It's almost like the phone needs to be reminded that the card is there (by popping the battery) and then it just takes a very long time to load it all up.

    I am using an 8GB card with about half of it filled, mostly music and vids though, less than 1GB is apps, so I don't know if that makes a difference. Especially since I can use the music and videos, just not the apps when this happens.

    Good Luck to you and please let me know if you find a more permanent solution.
  6. Orical

    Orical Active Member

    There's obviously one thing in common that all of you are using that is causing the issue with it, I'm wondering if your all using ap2sd or something like it. If that's the case then what ever app it is that launches the apps from the card has an error reading the path from SD to Phone. Once the incorrect path is saved it won't work at all but if you go to Application manager, find the app your using and clear data then uninstall it, this will lose the incorrect settings and find an earlier release of the same app.

    I'm just guessing here but it sounds like that's the case from reading the posts, some app updates aren't always better I always read the reviews when one tries to update on me.
  7. Sorraia3

    Sorraia3 Member

    I have no app called ap2sd. I have been use the original app manager to move only the apps it will let me to the SD card. I have not force moved any using an outside app or through Root. So any thoughts on how to find out if one specific app is causing this?
  8. Orical

    Orical Active Member

    I think if you go to the computer using a SDcard reader and back up all of the files as they are (some will have a path that's to deep to back up, just ignore those as the system will reinstall the folder as needed.) Format the SDCard in Fat32 NOT NTFS, when you put the SDcard back in the phone it will ask to reformat the card you want to say yes, then go in and see how you did, report what you find here and I'll see if I can figure it out from there.

Share This Page