1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

SD card not mounted - CM7


Last Updated:

  1. tessler65

    tessler65 Active Member

    When my CDMA HTC Desire dropped out of warranty in October, I rooted it using Revolutionary in order to use Titanium Backup to free up more space for apps on my phone. I wasn't interested in flashing roms because I was happy with HTC Sense 2.2 Froyo.

    Then I used TB to move apps out of the Dalvik cache into system rom to free up even more space. Oops, that didn't work like I thought, and there isn't an undo available. Oh well. Phone still works okay, so I'll just live with it.

    Friday night, TB updated and included an "undo move to Dalvik cache" so I did. My phone got stuck in a boot loop. I was too tired to do anything about it so I pulled the battery and dealt with it Saturday. All day. And all day Sunday, too.

    (LESSON: If it ain't broke, don't try to fix it!!)

    In the process, I tried flashing the rooted HTC Sense rom, an unrooted HTC Sense rom, and none of them would flash (depricated). So in desperation, I flashed an unrooted HTC Sense rom from another CDMA vendor. That worked, but now my phone thinks it's from a different carrier (splash screen). So I re-rooted the phone using Revolutionary and flashed CM7. Also in the process, I partitioned my SD card to have an EXT2 so I could move apps there and free up even more space since I was using only about 1GB out of 8GB for data.

    The phone works... sort of. It still thinks it's from the other carrier (minor issue that I don't really care about). The big issue I have is that the SD card isn't mounting. I can go into Revolutionary and tell it to /mount and I can access it, but when I reboot, it won't mount in CM7. I can't restore any of my apps using TB because TB can't find the SD card.

    Thoughts? Suggestions? I'm so sick of dealing with this when I really didn't want to ROM my phone in the first place; I just wanted to get rid of the bloatware so I could install more apps. :(

    Advertisement
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    try [FONT=&quot]fastboot oem enableqxdm 0

    you probably have a usb brick
    dont know how that is fixed on a cdma device as im not sure you have misc
    [/FONT]
    tessler65 likes this.
  3. tessler65

    tessler65 Active Member

    I read about that but I thought it was mainly for people trying to connect their phone to their PC and access their SD card as a drive. My SD card isn't mounting when the phone boots and is not attached to my PC. Could this be caused by the same USB brick issue?
  4. SUroot

    SUroot Well-Known Member Developer

    Are you sure its got no warranty? Our gsm desires have 2 years warranty and its not 2 years old yet
    tessler65 likes this.
  5. tessler65

    tessler65 Active Member

    I've had to do a warranty replacement on my Desire twice. The first time, it was because the power button stopped working and I couldn't wake up my phone any more unless I connected/disconnected power. The second time, it was because it was randomly rebooting, sometimes when I was using it, sometimes when it was just sitting beside me. When I did both warranty replacements, the C Spire store employee told me I only had ___ amount of time left on my warranty, even with the replacement phone.

    So I assumed that my warranty was up after 1 year. The week after my phone came out of warranty, I rooted because I couldn't stand the lack of space any more. Warranty violation? What warranty? :)
  6. SUroot

    SUroot Well-Known Member Developer

    I'd check with HTC to be honest. It should be 2 years
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    no its so android can see the sdcard
    you are confusing it as you are seeing it listed in the usb brick guides
    if you read any usb brick guide you should see that the command is used to enable sdcard connectivity to android and recovery so you can flash and move files
    tessler65 likes this.
  8. tessler65

    tessler65 Active Member

    Ahhh... Ok. I'll have to work on this later as I have to run an errand and then go to work. Thanks! I'll let you know if I have any stupid questions or whether or not I got it working. Appreciate your help!!
  9. tessler65

    tessler65 Active Member

    No luck. I tried the fastboot command and it said it was successful, but it still couldn't see the SD card when I booted into CM7.

    I tried the fastboot command again followed by a fastboot oem eraseconfig and rebooted into CM7. No SD card mounted.

    So I thought maybe it was the messing around I did with the SD card setting up the EXT2 partition, so I undid all that and formatted the SD card and reloaded it from the backup on my PC. Put the card back in the phone and rebooted. No SD card mounted.

    Any other suggestions?
  10. Rastaman-FB

    Rastaman-FB Well-Known Member

    flash a froyo RUU and see if you can still see the sdcard. otherwise its HW
  11. tessler65

    tessler65 Active Member

    Thanks. I need to be sure this is a CDMA RUU, right? Or does that matter?
  12. tessler65

    tessler65 Active Member

    I checked around on the HTC website. They had some toll free numbers to call for warranty service, but my provider (C Spire, formerly Cellular South) wasn't listed. All the text around warranty service indicated that you had to initiate the service through your cell provider. So I guess it doesn't matter what the HTC warranty is because your cell provider can override that with their own policy, apparently.

    But I'm S-OFF, rooted and flashed (and in the process, I wiped out the Cellular South splash screen) so I've completely voided any sort of warranty I might have had.
  13. Rastaman-FB

    Rastaman-FB Well-Known Member

    forgot this was cdma, yeah
  14. tessler65

    tessler65 Active Member

    UPDATE

    It's fixed now. I have NO clue how it happened, either.

    I spent some time searching for a Cellular South (CDMA) RUU for the Desire and all I found were a bunch of other people begging for the exact same thing. I kept telling myself that at least I could make and receive phone calls and text messages, and I would get it fixed one day.

    This morning I was just idly messing around shifting icons on the home screens. I decided to try opening Titanium Backup for the nth time and when I did, I noticed an update had been downloaded. I went through all the screens and when I got to the main TB screen--there it was! My SD card!! I immediately exited TB and tried the camera, then the gallery, and everything worked. Then I went into the file manager and ta da! SD card!

    So I'm no longer USB bricked. The scariest thing to me is that I have no idea how or why it got fixed, so I don't know if I trust it to keep working, especially if it was a hardware glitch. :confused:

    Thanks to Rastaman-FB and SUroot for the advice!!
  15. Rastaman-FB

    Rastaman-FB Well-Known Member

    hmmm, very odd
    glad its fixed for you tho

Share This Page