SD Card not reading. Please help.Support


Last Updated: 2012-11-28 22:24:16
  1. RainbowWarrior

    RainbowWarrior New Member

    I just upgraded from my Captivate to a shiny new S3, and I am so excited, but I'm having a problem with my microSD card. When it's in the Captivate and mounted, I can go into the directory mnt/sd and see all the things on the card, including my photos and music, etc. When I unmount the card and move it into the S3, the directory shows only 4 folders - LOST.DIR, DCIM and a couple others. All these folders are empty. I have tried unmounting and re-mounting the SD card, turning the phone off and on again, but it just is not reading the files. When I put the SD card back in the Captivate, boom, it works fine, I can see everything right there in the directory.

    I have checked both the mnt/sd and mnt/ext_sd directories in the S3, with no results. It simply is not recognizing that this SD card is full of information.

    Can anyone help me fix this? I will be really sad if I can't transfer all my pictures and music to my new phone.

    Advertisement
  2. Shotgun84

    Shotgun84 Well-Known Member

    Try transferring everything from your sd to your pc, then put the card back in your gs3 and format the card. Then transfer everything back on.
  3. greggebhardt

    greggebhardt Well-Known Member

    Mine was the same. Removed my SD card from my S2 and put it in my AT&T S3 and it said card error. I moved everything to my PC and formatted the card in the S3 and moved the files from the PC to the S3. All is good.
  4. RainbowWarrior

    RainbowWarrior New Member

    I'm not finding USB mass storage mode on the S3. How'd you move everything back, if you don't mind my asking?
  5. Shotgun84

    Shotgun84 Well-Known Member

    I don't think the external card in a gs3 shows up on a pc unless you are rooted and apply a fix, unless something has changed. So try connecting your captivate.
  6. XplosiV

    XplosiV Master X is Watching You VIP Member

    Take the micro SD card out the phone, insert into an SD/micro SD adapter, insert into laptop, it should show as a removeable drive. Copy everything, insert micro sd back into phone, format, and repeat the above to copy everything back onto the micro SD via your laptop.

    Or of you have a digital camera that handles SDHC you can insert the micro SD into the adapter, insert that into the camera, then USB the camera to laptop and it will still show up as a removeable drive.
  7. tyboo84

    tyboo84 New Member

  8. kct1975

    kct1975 Well-Known Member

    Just my two cents....the methods in the posts above are the way to go.

    For whatever reason it seems that SD cards need to be formatted to the specific device for the SD card to work
  9. hopeican

    hopeican New Member

    it seems you should take out your card from the phone and back up your files on a pc before going any further.

    with the phone on and the cover off take the battery out. then insert your microsd card back into the phone. insert battery and then start your phone hope this helps.:):):):)
  10. geneius

    geneius New Member

    It's not just a formatting problem. I have a class 10 32gb sandisk micro sd. it worked fine to start, then it started saying "blank sd or unsupported file type". My tablet could still read the files on it, but I deleted them, reformatted on the s3 and loaded it up with stuff again. A few days later it started again. Its clearly a phone problem. If the jb update doesnt fix it, ill just root it I think.
  11. lespaul00

    lespaul00 New Member

    I have this same problem. Have you found a solution?
  12. WAWood8

    WAWood8 Well-Known Member

    I don't believe there is a solution -- other than switching to another phone.

    I'm on my second S3 in only a few months, because the first one overheated and not only fried the SD card it also corrupted the internal file system. And then, a short while ago, my wife's S3 also fried its SD card.

    I've seen and used other smartphones with SD cards ever since the Dinc 1 came out, and this is the ONLY phone I've seen that fries SD cards. A friend has a Galaxy Nexus and he's never had any SD card problems -- same is true of folks I know with other Samsung phones, with HTC phones, and with Motorola phones.
  13. lespaul00

    lespaul00 New Member

    The strange thing is, my card isn't "fried". Randomly, it says it's ready to unmount and can be safely removed, and then it's not accessible (no photos, etc.). After some time (days), it's working again as normal.

    This has happened twice already --- with no indication of the problem and what corrects it.
  14. OverByter

    OverByter Resident Slide Rule Guru

    It's a common problem with the S3 screwing with sd cards. Including "frying" them so that they're unreadable and unformattable, even after removing and trying on the computer or another phone.

Share This Page