SD Card not workingSupport


  1. micahdiablo

    micahdiablo Well-Known Member

    I brought a XPeria play from Amazon.com that is supposed to be new and appears to be that way. I was super excited to get it...

    Except one thing...

    The SD Card that the phone come with is not being read properly. It comes with an 8GB card.

    I am not sure what brand of card it is. It says 8 GB microsd HC

    I even tried using my current SD card that I have in my other phone, also 8 GB made by kingston. Class 4 I believe

    Everytime i stick it in there it says SD CARD CAN NOT BE ACCESED

    I go into settings and it will at first show 7.40 GB available and then it will change to unavailable.

    What can I do?
    It is an R800i

    Advertisement
    :
  2. Josh-SonyXperia

    Josh-SonyXperia Well-Known Member

    Since you tried more than one SD card and the result is the same it could be maybe the memory card slot on the phone that is defective. Try the Repair Phone option on PC Companion to confirm whether this is a software or a hardware problem.
  3. micahdiablo

    micahdiablo Well-Known Member

    Oh no it was me :D

    I did some googling around. Apparently the battery cover wasn't all the way on or something and it wasn't reading the card right.

    I somehow got it up there and it is working fine now :D
Loading...

Share This Page