SD Card Problem


Last Updated:

  1. Bosniarasta

    Bosniarasta Member This Topic's Starter

    Joined:
    Dec 10, 2012
    Messages:
    14
    Likes Received:
    1
    Hi there, today I tried to play Need for speed game, but I got warning message it needs 2 Gb memory free.
    I have 8 Gb SD card in slot.
    In preferences (storage) of box (refee M6 smart tv box) I have only 2 Gb SD card. (it is internal I suppose).

    Why is internal (2Gb) card instead of external (8Gb)

    Weird thing is that my 8 Gb card is mounted on sdcard/external_sdcard folder.

    How can I fix this?

    Android 4.0.4.

    Thank you.
     

    Advertisement
  2. stane1983

    stane1983 Well-Known Member Developer

    Joined:
    Mar 18, 2012
    Messages:
    527
    Likes Received:
    216
    If your box is rooted, edit /system/etc/vold.fstab file and switch internal/external sdcard. When you open vold.fstab you'll see what I mean.
     
  3. Bosniarasta

    Bosniarasta Member This Topic's Starter

    Joined:
    Dec 10, 2012
    Messages:
    14
    Likes Received:
    1
    It is rooted, do I have to transfer data from sdcard to sdcard/external_sdcard
    before I do that?
     
  4. stane1983

    stane1983 Well-Known Member Developer

    Joined:
    Mar 18, 2012
    Messages:
    527
    Likes Received:
    216
    No, just switch mountpoints for sdcard and flash (or media, don't know how it's written in your vold.fs), so internal sdcard will be in sdcard/external_sdcard and real sdcard will be in /sdcard.

    Not to be confused, mountpoint is probably not /sdcard but /mnt/sdcard or /storage/sdcard0, /sdcard is only symlink to real mountpoint.
     
  5. Bosniarasta

    Bosniarasta Member This Topic's Starter

    Joined:
    Dec 10, 2012
    Messages:
    14
    Likes Received:
    1
    Oh, It is easy, thank you.
    I edit it with ordinary text editor.
    But when I try to save file it say :"file is not writable".

    How can I get privileges to edit this file... box is rooted, I check it with "root checker".?
     
  6. stane1983

    stane1983 Well-Known Member Developer

    Joined:
    Mar 18, 2012
    Messages:
    527
    Likes Received:
    216
    Download es file explorer from market, menu, options, root explorer, enable it and mount system as rw and check 'Up to root' option. After that you'll be able to edit system files.
     
    Bosniarasta likes this.
  7. Bosniarasta

    Bosniarasta Member This Topic's Starter

    Joined:
    Dec 10, 2012
    Messages:
    14
    Likes Received:
    1
    It works! Thank you sir
     
  8. parkland

    parkland Member

    Joined:
    Nov 25, 2012
    Messages:
    13
    Likes Received:
    0
    what about if a device isnt rooted?
     
  9. stane1983

    stane1983 Well-Known Member Developer

    Joined:
    Mar 18, 2012
    Messages:
    527
    Likes Received:
    216
    You have to root it first :) Or before installing firmware package, edit vold.fstab in update.zip and resign it.
     
    Bosniarasta likes this.
  10. parkland

    parkland Member

    Joined:
    Nov 25, 2012
    Messages:
    13
    Likes Received:
    0
    is there generic firmware available, its a no name imported media player.

    a9 , thats all i know.i could do what you said if i knew where to find firmware.

    i run linux on all our home computers, i'm not real green, but never rooted an android yet haha.
     

Share This Page

Loading...