SD card problemsSupport


Last Updated:

  1. Aleksandr

    Aleksandr Member This Topic's Starter

    Joined:
    Sep 12, 2010
    Messages:
    7
    Likes Received:
    2
    Hello all,

    Time to time upon turning my GT540 on I can see notifications "SD card was unexpectedly removed" then fololwed by "Preparing SD card". Sometimes only "Preparing SD card" can be seen.
    As result if this happens when somebody is calling me phone plays default ringtone instead of one assigned to calling person. Also if application which was last on screen when phone went off is using some data from SD card it misbehaves upon turning on.
    I tested SD card both inside phone and outside by moving in and out a lot of data. All went smoothly.
    Anybody experiencing same problem?
    Any ideas how to solve it?
     

    Advertisement
  2. anandaravi

    anandaravi New Member

    Joined:
    Dec 24, 2010
    Messages:
    1
    Likes Received:
    0
    I hv exactly the same issue, no solution found so far. Please keep updated.
     
  3. Nirob

    Nirob Well-Known Member

    Joined:
    Sep 13, 2010
    Messages:
    539
    Likes Received:
    167
    Try formatting the SD with PC...
     
  4. clunkercar01

    clunkercar01 Well-Known Member

    Joined:
    Feb 14, 2011
    Messages:
    98
    Likes Received:
    6
    Has anyone found an answer to this yet as I have suddenely started experiencing this too after a week of having my new Sandisk 16gb MicroSDHC card.

    Any solutions worked for anyone?
     
  5. simon194

    simon194 Well-Known Member

    Joined:
    Feb 10, 2011
    Messages:
    63
    Likes Received:
    12
    I've found that if the card has a capacity of 8MB or larger it has to be Class 6 or higher. I'm currently using a Lexar 16GB class 6 card and have had no problems at all so far.

    For a 4MB card you can get away with a class 4 card.
     

Share This Page

Loading...