SD card removed unexpectedly!! Please help!!!Support


Last Updated: 2013-11-06 20:18:26
  1. jdnoriega

    jdnoriega Member

    Please guys. I have no idea what happened. One minute I took a picture..sent by text...then I saw a 3G fix on here that said to get MSL reader and change a couple settings then run a speed test....everything went well...then I'd say about 15 minutes after that I noticed a red triangle in my notification bar....said sd card unexpectedly removed. I have not done anything to the card. My pc won't read it...the phone won't read it...what gives??? Is there any hope?? I've seen a couple of threads on here where people say it's the sd card gone bad. Will a card go bad from one second to another?

    Advertisement
  2. akazabam

    akazabam Well-Known Member

    Have you tried rebooting? Start with that. If it doesn't help, take the battery out, take the card out, and put it back in. Then boot back up, and see if it works.
  3. ScorpDX

    ScorpDX Well-Known Member

    Turn the phone off, remove the card, reinsert, try again.
  4. jdnoriega

    jdnoriega Member


    Thanks, Akazabam. And, yes I have already tried all of those options. That's why I find it so odd. It's like the card disappeared. I used my mp3 player on Saturday quite a bit...took some video of my daughters school performance...Sunday night...took a picture, sent it via text...worked fine. Then I did that 3G fix that's on here...worked fine.....20 minutes later....BAM...SD card issue.

    Any help, would be GREATLY appreciated. C'mon oh 'GREAT ONE', I know IF there's anybody that can help It's you AND all you other EVO saviors.

    Has no one else had this issue???
  5. akazabam

    akazabam Well-Known Member

    Well, let's see. When you say the PC won't read it, is that when you connect the phone via usb or are you using a card reader? Do you have a card reader? If so, try that. Let's try and determine if it's the card or the phone. It would also be helpful if you have another card to test, but I assume you don't, or you probably would have said so.
  6. jdnoriega

    jdnoriega Member

    Okay. I do have a card reader. PC will not recognize. Will read...then as I click on open folder to view files...says cannot find drive. Insert my wife's card into reader..then to pc...no problem. Insert MY card into my wife's Hero...NO PROBLEM!! BUUTT....MY phone will not recognize the card...AND pc also will not recognize it.

    So, if my wife's Hero has NO problem with it...it would have to be my phone...right????
  7. akazabam

    akazabam Well-Known Member

    Maybe. Have you tried the card from the hero in your phone?
  8. Mr. Ed

    Mr. Ed Well-Known Member

    It doesn't make sense though. If the pc wont read it it would appear to be bad. But the hero reads it.

    Try opening it from within this program....
    Free Partition Recovery Software - Recover Deleted FAT/NTFS/Ext2/Ext3 Partition.

    I am not near a computer but I use this all the time with my multiple hard drives. You may be able to get into the card and retrieve your data. Then format it on the pc....then put it in the phone and format it.

    Is.this the stock card or have you replaced it?


    Oh and for the record.the 3g fix would have absolutely nothing to do with your sd card :)
  9. Mr. Ed

    Mr. Ed Well-Known Member

    dduh...didn't even think

    ...if.the hero reads it....hook the hero to the pc and extract everything that way. Format. Install in phone. Then Format via phones menu.
  10. Carpe Nocturnal

    Carpe Nocturnal Well-Known Member

    I had the same problem happen to me. I took out my SD card and put it into my PC with the SD Adapter. When my PC recognized the card reader it gave me an option to scan and fix bad sectors, so I chose that. Then I was able to view my files on my PC. So I reinstalled the SD card back into my EVO and it has been working fine since.

    Bear
    Mr. Ed likes this.
  11. jvc1263

    jvc1263 New Member

    I've changed display setting to shut down screen in 30 minutes,and i think this work.It look like there is bug in sleep mode/battery saving during the call.
  12. robmclain1975

    robmclain1975 Member

    I had this problem happen to me a lot too...I noticed it would happen more frequently when my SD card was right around 3 Gig. I tried putting it in my computer too and it would recognize the card, but it would move like a turtle. Odd thing is, when it did it the last time, I put the card in my FireFly 3 and it read the card just fine. Put it back in my EVO, no issues since.
  13. psych20

    psych20 New Member

    I HAVE SOLVED MY GALAXY Y ERROR, but before that let me tell you the solutions that I had tried that did not work for me:

    The error did not occur on my original memory card but when I switch to a Kingston 8GB Class 4 the error started. My co-worker uses the same phone and switch to the same mem card and also experiencing the error since changing it.

    At first i didn't mind the error but when i rooted my phone to extend my internal memory by partitioning my micro sd the problem became a big impact on linked apps on my sd card so started asking solutions to google.

    Sorry for the long introduction, this what I have tried to my phone:

    1) Updating my firmware - DID NOT WORK
    2) resetting my phone to factory settings and formatting my sd card inside the phone - DID NOT WORK
    3) Using SD-Booster and tried setting the cache to different numbers 1024, 2048 and 4096 -DID NOT WORK

    There 1 option left that I have read on 1 of the forums that works
    CHANGING MY MICRO SD CARD- IT WORKS (YEHEY)

    someone said that TRANSCEND and SAN DISK is very much compatible for android forums so I have tried it.

    I bought TRANSCEND 8GB CLASS 10 ULTIMATE - REALLY WORKS AND I ALSO TRIED PARTITIONING IT AND WORKS PERFECTLY FINE.

    The conclusion here is some of the android phones are not compatible to some micro sd card.

    Hope it helps :) tell me if it works for you... please indicate your memory card so we can know what brand is not compatible for android phone especially Samsung Galaxy Y :)
  14. KCP884

    KCP884 New Member

  15. wwfjdraw

    wwfjdraw Member

    Same thing with my htc evo 3d sprint. Here is what I did, I took out the 32gb class 10 sd card. and I tried some other sd card from my pantech pocket, and that it worked in my pocket but not in my evo. So now a 32gb class 10, and a 2gb class unknown both did not work in my evo. But then I tried a 512mb class unknown card and it works.

    I heard somewhere that some htc phones can not use an sd card that is class 6 or higher.

    Also the sd cards that did not work in the evo worked in my S3 for the 32gb class 10. And the 2gb in my pocket. Interestingly the 32gb class 10 would not work in my pocket but it did in my s3.

    I earlier in the past tried methods that did not work before. And these were reformating, erasing, unmounting, remounting, scanning sd card viruses and malware, factory data reset on the phone, rebooting and even cleaning the sd card with water and a micro fiber towel. So far those failed. Only this worked. Only switching the cards worked.

Share This Page