"SD card unexpectedly removed"? WTF? I didn't touch it!Support


Last Updated: 2012-09-14 01:06:57
  1. bird jam

    bird jam Well-Known Member

    The last couple of days I have been getting this warning and it is very annoying, as I can't use any apps from my SD card and it changes my ringtone so I don't recognize when my phone is ringing.

    I am unrooted, running froyo with the most recent (November) software update. I have also been getting the annoying "low on space" warning from time to time, which I've generally been able to remedy by clearing app caches as recommended on this forum.

    Does anyone know what's causing this and how to make it stop? I have loved this phone since I got it on release day, but this is annoying enough to make me want to switch phones.

    Edit: I have occasionally been able to get the phone to recognize the SD card by re-booting, but I just did that just now and about 5 minutes after I did it I got the warning again.

    Advertisement
  2. xac501

    xac501 New Member

    I am having similar problem with my htc legend :(. My stock 2gb card works just fine. But with my 8gb sd i get this very same error. In my analysis i have noticed this only happens. When any of the application tries to write to the SD card.

    Please do share the solution if you find any. I have posted the issue on xda as well. If i shall find a solution i will let you know. Keep us updated.
    bird jam likes this.
  3. sdrawkcab25

    sdrawkcab25 Guides Guide

    Copy all the data off your sd card and reformat it to fat32, then copy it back.
  4. bird jam

    bird jam Well-Known Member

    Pardon my n00bishness, but what is fat32?
  5. AeolianReflex

    AeolianReflex Well-Known Member

    It stands for File Allocation Table 32 bit and it's the file structure format for high density memory. You can format it using a Windows PC. Not sure if Mac uses the same format though.
  6. Joshuahist

    Joshuahist Well-Known Member

    Just starting having this problem myself. My original phone I never had a problem, however I recently received a replacement phone (not refurbished), and this started.

    I called and they are sending me a new phone today. Should be waiting when I get home after work.
  7. Joshuahist

    Joshuahist Well-Known Member

    New phone did not fix the problem. WTF?!?!
  8. AeolianReflex

    AeolianReflex Well-Known Member

    Are you using the same SD card that you were using on the original phone?
  9. sdrawkcab25

    sdrawkcab25 Guides Guide

    Your sd card is the problem....
  10. Lgally93

    Lgally93 New Member

    I am getting the exact same problem. I've used the same sd card in two phones before the Incredible and never had a problem. I already had this problem two weeks ago so i tried to copy everything to my computer, unsuccessfully, and formatted it to FAT32 and it worked fine until last night. If anyone finds a solution, let me know so i can save my money instead of spending it on a new card.
  11. wayrad

    wayrad Well-Known Member

    FWIW, you can error-check a card in Windows (right-click on drive letter, Properties, Tools). Be sure to NOT defrag it.
  12. bird jam

    bird jam Well-Known Member

    Thanks to all who have responded.

    The SD card message hasn't popped up this week, but the stupid "low on space" warning has showed back up and won't go away no matter how many data/caches I clear. So annoying. Do other Android phones have this problem, or just the Incredible?
  13. marknhl

    marknhl Member

    I'm having this same issue!! It just started and I haven't found a resolution yet. I've been doing a lot of rebooting, taking out the card for second, putting it back in, rebooting with the battery installed, rebooting without the battery installed, nothing has fixed it yet.

    As far as the low application data space, I have extra room for everything but.... I just started uninstalling programs that I don't use and after about 10 of them (I have quite a few apps), the low space indicator went away.

    Now I just want my sd card back!
  14. marknhl

    marknhl Member

    Well that didn't take long since I posted, now the low space message is back and it seems I'm having some other problems as well. When I try to launch Angry Birds sometimes it launches, sometimes it doesn't. However, just as I'm about to play it freezes and gives me a force close saying that HTC Launcher has stopped unexpectedly; then it reformats all my desktops, removing the text below icons, my power bar changed slightly, and the bar at the bottom for apps, phone, and add has squished to the right side of the phone. It did this twice. Did a reboot and its ok thus far but I won't bother with Angry Birds anymore....
  15. bird jam

    bird jam Well-Known Member

    I've had that exact same thing happen to me several times too. This stuff is really annoying. Wish they'd fix it.
  16. xpavar

    xpavar Active Member

    I had the same SD card message after installing the latest Verizon update. Reformatting the card solved the problem.
    marknhl likes this.
  17. marknhl

    marknhl Member

    Ok, I reformatted the card and everything appears to be ok at the moment. Angry Birds lags a little but I'm not seeing that as a big issue. Perhaps something was running in the background causing it. Couldn't get my music off the card but I have it backed up anyways. Hopefully I'm all set! Thanks!
  18. marknhl

    marknhl Member

    doh, low space message is back. Now Google Talk doesn't work, Angry Birds does. I'll have to run through other applications and verify what is not working, no problems with other programs thus far. Is there a place that I can download Google Talk from? I would like to uninstall it but then I don't know how to reinstall it because I can't find it on the market.
  19. olbriar

    olbriar Moderator Moderator

    I thought Google Talk was an OEM app and couldn't be removed. Perhaps I'm wrong.
  20. fnfr

    fnfr New Member

    Had the same issue. Ended up running chkdsk /R <drive> (in DOS against the SD Card) and saw that I had some bad files (images).

    I thought that would work, but still had the SD Card crap out on me again. However, running this did show me the names of the bad files, so I just deleted those files (again, in DOS) and haven't had an issue since.

    Note: I did use another phone (running Android) and connected to my PC as a disk drive. My Incredible kept bombing out on me when trying to connect and run chkdsk, but the other worked --- guess you could try removing the card and inserting into your PC (if you have an SD Card reader).

    What a pain...hope this helps.
    MikeyrInFL and bird jam like this.
  21. km2002

    km2002 Well-Known Member

    My SD card is already formatted as FAT32. Not getting low-on-memory errors as described above, but getting other strange behaviors ... like adding a favorite to my phone listings, only to have it disappear within hours (happened four times; and I only have three favorites -- two when the third one gets dropped); like having programs I've moved to the SD card suddenly seem to disappear, causing me to reinstall them and move them -- again -- to the SD card; like tonight, suddenly having the phone not recognize the SD card it's been reading from all day. Any idea what might be causing this? It's so frustrating. HTC Incredible.
  22. marknhl

    marknhl Member

    That's possible, I was just trying to think of a way to troubleshoot the issue.

    now I notice that gmail isn't updating automatically or manually. I will be reconfiguring that. Hopefully that issue doesn't stay :)
  23. marknhl

    marknhl Member

    brought the phone back to factory settings. took forever ~3 hours to get the phone back to where I had it customized, etc. looking good so far.

    I was told to remove the sd card before reformatting or something will get messed up. not sure why.
  24. This_Is_Kyle

    This_Is_Kyle Well-Known Member

    I just started having this problem today. I've tried removing the SD card and then putting it back in and the phone will recognize it for ~30secs and then it will "unexpectedly remove" again. I dont have Windows so cant try the things that were said above me. Any one know how to fix this problem using a Mac?
  25. ThoFre97

    ThoFre97 New Member

    My Incredible just started doing this a couple days ago. The error message would pop up within 30 seconds after a reboot. I put the SD card in a Windows laptop - it appeared to mount but the files were all size zero. I ran chkdsk /R on it, which found a whole slew of files with bad clusters, all but one in /trimble/... (I have Trimble Outdoors installed). I ran chkdsk /R again and it found no problems. All the files/folders now look normal but I lost about half of the 300 photos that were on it. No matter since the important ones have already been offloaded to a desktop (iPhoto). Will report back if it fails again, but so far so good.

Share This Page