SD Card Unexpectedly removed.Support


Last Updated: 2012-04-05 16:19:33
  1. JustEli

    JustEli New Member

    I know there have been other posts about this but I feel I might have new information (but then again I haven't read every post). Like everyone else my phone will tell me that my SD card has been "unexpectedly removed". It happened before and I did temporarily fix it by backing up my data and reformatting it.

    What I noticed when I reformatted it was that it would go so far and then disappear again. This is when I had it out of my phone and in a card reader on my computer. Certain files made it disappear. I don't remember which ones did it but I think I just deleted it.

    Anyway, it's happening again. I was going to try defragging it just to see what would happen and every time it will stop at the same point and then disappear. If I don't choose to defrag it my computer is still able to read that it is there. After about the 5th time of trying to defrag it I decided I will just back it up again. It just keeps disappearing now when I try. I'm going to assume it's a certain file again and just backup each folder one by one and see if I can locate which file makes it disappear. If I can I will post what it is.

    Phone: HTC Incredible
    Micro SD: SanDisk Mobile Ultra 16GB Class 4

    Edit: In the Android folder the com.google.android.apps.genie.geniewidget.news-content-cache folder and the com.google.android.apps.maps folder

    Edit: In the download folder the Amazon_Appstore-release.apk file

    Edit: a .png file in foursquare

    Edit: something in the folder rerware

    And that's it. I don't know if this helps. I know most people won't have what I have in my download folder but maybe it will help whoever figure out what's wrong. I guess those files are corrupted.

    I was able to eat all the folders except the folders in the Android folder so I'm going to reformat the whole card.

    Edit: I would have just changed "eat" to "delete" but I'm making cookies so I thought that little Freudian slip was funny.

    Advertisement
  2. jvc1263

    jvc1263 New Member

    I've changed display setting to shut down screen in 30 minutes,and i think this work.It look like there is bug in sleep mode/battery saving during the call.
  3. psych20

    psych20 New Member

    I HAVE SOLVED MY GALAXY Y ERROR, but before that let me tell you the solutions that I had tried that did not work for me:

    The error did not occur on my original memory card but when I switch to a Kingston 8GB Class 4 the error started. My co-worker uses the same phone and switch to the same mem card and also experiencing the error since changing it.

    At first i didn't mind the error but when i rooted my phone to extend my internal memory by partitioning my micro sd the problem became a big impact on linked apps on my sd card so started asking solutions to google.

    Sorry for the long introduction, this what I have tried to my phone:

    1) Updating my firmware - DID NOT WORK
    2) resetting my phone to factory settings and formatting my sd card inside the phone - DID NOT WORK
    3) Using SD-Booster and tried setting the cache to different numbers 1024, 2048 and 4096 -DID NOT WORK

    There 1 option left that I have read on 1 of the forums that works
    CHANGING MY MICRO SD CARD- IT WORKS (YEHEY)

    someone said that TRANSCEND and SAN DISK is very much compatible for android forums so I have tried it.

    I bought TRANSCEND 8GB CLASS 10 ULTIMATE - REALLY WORKS AND I ALSO TRIED PARTITIONING IT AND WORKS PERFECTLY FINE.

    The conclusion here is some of the android phones are not compatible to some micro sd card.

    Hope it helps :) tell me if it works for you... please indicate your memory card so we can know what brand is not compatible for android phone especially Samsung Galaxy Y :)

Share This Page