sd card wont mountSupport


Last Updated:

  1. pokermac

    pokermac New Member This Topic's Starter

    Joined:
    Aug 18, 2010
    Messages:
    2
    Likes Received:
    0
    just got my 2.2 update this morning and now the droid won't use the sd card. notification bar say "safe to unmount sd card" but it wont access it.
    I'm old and a newb so please be nice and type slowly.
     

    Advertisement
  2. jellyhead

    jellyhead Active Member

    Joined:
    Apr 23, 2010
    Messages:
    36
    Likes Received:
    6
    This seems a bit obvious but.....did you try unmounting it? It should automatically unmount when you disconnect the USB. You could try plugging in the USB and mounting it then unmount it. If that doesn't work try rebooting if you haven't already.
     
  3. daveoneeighty

    daveoneeighty Member

    Joined:
    Jun 9, 2010
    Messages:
    15
    Likes Received:
    2
    Try this, it worked for me, it seems to be a common problem with the SD cards, but it's a little involved, and must be done every time before you mount the SD card.

    Please Note! Make sure before you start your Droid is not connected to your computer.

    You need to uninstall the drivers each and every time you want to mount your SD card, but in order to uninstall them you need to be able to uninstall hidden devices in your device manager.

    In order to uninstall hidden drivers do the following:
    (Note: this step must only be done the first time, it allows you to view hidden drivers permanently)

    1) Open the
     
  4. SporkLover

    SporkLover Well-Known Member

    Joined:
    May 9, 2010
    Messages:
    498
    Likes Received:
    98
    I dont think his issues are with Windows recognizing the Card.

    All of us Evo owners just went through this.

    Bottom line, copy contents off SD card (like back it up to a PC!). Format SD card in Windows using default settings. Plug card into Droid. Format Card on your Droid by going to Menu>Settings>SD & Phone Storage.

    This fixed a ton of our issues.

    Welcome to Froyo!
     

Share This Page

Loading...