SD card won't mountGeneral


  1. Melnits

    Melnits Member

    So i got this problem that phone(Sony Ericsson Xperia Mini Pro), doesn't read the sd card, last thing i did to phone was rooting, seperating sd card into 2 partitions so i could store apps on the sd card. But i think the problem is in the phone not in the sd card. i fixed the sd card, turned it back into 1 partition, even bought a new one 4 gig instead of my 2 Gb card, still nothing, but my friend android phone is reading it. So i would like to get some help in this thing. what should i do to the phone? I hope there is no chance that in some way i damaged the sd card slot.

    Advertisement
    :
  2. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    It may be a damaged SD card slot, however it would be worth running a software update before having the handset looked at by a repair agent.
  3. Melnits

    Melnits Member

    How can run it over air? Becaus i can't run it via usb, phone wont connect without SD card.
  4. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

  5. Melnits

    Melnits Member

  6. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    No problem, glad to help :)
  7. Melnits

    Melnits Member

    Do you think, i could try to do the process to get my apps stored on sd? Wouldn't it go wrong again?
  8. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Thats up to you, I cant advise you to root the phone.
  9. LYNDELL

    LYNDELL New Member

    Hi guys im having the same problem please explain how i should do it cause im not that clued up with technology...
  10. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Please follow this link, run the application and follow the prompts it provides. This will update the firmware and should resolve the issue for you. Unfortunately the link for the tutorial on this down for maintenance at the moment, but you can find out more about this function through here:
    Sony Ericsson
  11. Hi there.

    I have a vit of a similar problem, but it's been pushing the limits of my logic...

    ___________
    So first things first, I was used to charge my phone on the pc since I didn't have the mains plug thingy I used to unplug it without using the dedicated icon on windows. (but hey it never did anything to my flash drives or whatever)
    And one day I wake up and I get this little sign saying the card has been removed... but damn you it's still there !

    I tried to read it with the pc and no problems whatsoever, so after making a backup I formated it (checked the right format online to be sure), but still the same problem.

    A work colleague has the same phone so I thought I could try to identify the problem by comparing the reactions of both.
    The obvious thing would be a malfunction of the card reader, since the card was read in the pc. So I borrowed his card and surprise !

    Yes the card started mounting straight away...


    So now I'm left with a micro SD card for my phone, that can be only read by my laptop... I haven't tried my "faulty" card on his phone though.

    Does anyone have any idea what could be the problem ?

    (not that the card itself is worth a lot, but 1) every little bit helps 2) I don't like it when I don't understand what's happening and the only solution appears to spend more money)

    Cheers guys !
  12. sin0emp

    sin0emp New Member

    yes, same problem here, i got an 8gb toshiba SD card, it is working fine with every goddamn cell phone but my u20i ! It even works on my parent's old dummy sumsong cellphone but not mine! Man, i'm so pissed off and trolled!
    Come on sony guys, it's obviously a malfunction in the phone! Please fix this!! I can't buy another SD card! And if I could, what's the guarantee that the new one will work??!
  13. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    @sin0emp and doandroiddream - please try formatting the card with the phone itself. I am aware you have formatted the card already doandroiddream, however it appears you did this via PC.

    Main Menu > Settings > Storage > Unmount SD Card > Format SD Card.
    doandroiddream likes this.
  14. thanks for taking the time to answer !

    Trouble is I couldn't format it with my phone because it didn't recognize the card (which is kind of a massive flaw since without a card there is no market, no camera/video... you can't even access pc companion !!

    I tried with another card (luckily a work colleague has an xperia mp too), and this card worked fine on my phone.

    So it was obvious it was a problem specifically between my phone and that one card.

    So my first hunch was right, there has been some form of corruption on the link between the two, most likely because of repeated unpluggings without unmounting.

    Never happened on any other support before but I guess the smaller they are the more fragile...

    At least that'll teach me it's actually a real thing (not like not being allowed to use a psp on a plane or whatever, which is total b******s)
  15. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Sad to hear that, but at least now you know the cause of the problem.
    doandroiddream likes this.
  16. the good news is it means the phone will accept (and has) a different micro SD, since the problem only occurs with that specific card.
    I made a copy of the contents of the phone card before formatting it (on the pc then), and I just transferred those files to the new card and tada !

    So now I'll ALWAYS use the safe unmount option, you can bet on that !
  17. ironjoe

    ironjoe New Member

    I'm having the same problem with my Droid razor maxx. I've had this for for 6 months and just noticed that my phone doesnt detect my SD card..?
  18. JASMINPATEL

    JASMINPATEL New Member

    i have same problem. i m trying the same thing but it dosent work. still SD card not mounted(not detected)
  19. temporary2010

    temporary2010 Active Member

    I've found the X10 Mini Pro to have a flakey card reader. It doesn't play well with some cards. For example, I've used a Kingston Class 4 card that works fine with other phones, including a cheap Nokia, but the X10MP constantly corrupts data on it. Same with a Lexar Class 10, although the corruption doesn't happen as often.

    I've given the Lexar card to a friend, and she's been running it fine in an Xperia Pro. I've bought a higher capacity Lexar, also Class 10, and it's been fine in my Xperia Mini Pro.
  20. leonehal

    leonehal New Member

    Corrupt SD card? Corrupt micro SD card? Corrupt mobile card? Mobile can not read sd card? Can not access to sd card? Want to fix sd card?
    Use this trick hope it works for you. It work for me.

    No need to format. Would not loose any data. Just restore file system.

    Open up command prompt (start->run->cmd.exe) and type
    chkdsk /X /F X: (Where X is SD card drive letter)
    My SD card reader is X:\ drive, so i wold use the following command:
    chkdsk /X /F X:
    and hit enter. It will fix your sd card.
    Right click on drive letter and click on safely remove.

    If your computer says can not directly access this drive ....do following.

    1) Try SD card adapter or micro sd card adapter
    2) Try different card reader
    3) Try different computer

    It works .....it works for me by using micro sd card adapter and save my 32 GB sd card.
  21. nvrau

    nvrau New Member

    If there is no driver letter assigned, are there any other options?

    Secondly, do you know if a similar process be performed on OS X?
Loading...

Share This Page