sd-ext.img not found. cant flash recovery, PLS HELP!


Last Updated: 2012-06-14 09:27:13
  1. carizma

    carizma Member

    Hi, I'm new here and at a loss. Please help me, Im going to have a breakdown! Apologies for the length of this but best you know full issue.

    I rooted my phone today using these instructions - YouTube - TheGadgetsReviews's Channel

    Essentially, I turned on debugging, installed all relevant drivers (PC and phone), installed and launched unrevoked 3 (rooted fine), installed ROM Manager and made backup (tried Titanium but it said I needed something I didnt have), then I installed the Cyanogen 7 ROM (using their own instructions). As I said, I made a backup. The rooting was fine and Cyanogen installed and ran successfully (and looked great might I add).

    However, none of my contacts, data nor my apps had moved over onto the new ROM. I understand that this is becasue my phone essentially wiped itself and made a clean install (I should have opted for an update not a clean instal but I didnt know that!). Anyway, in hope of rectifying this, I opened up ROM Manager and tried to load the recovery/back up file. Phone turned off and then tried to "revert" itself (little pic of box with files coming out). It said the process was complete. Phone turned off once again and tried to start up. It returned to my original O2 welcome screen and that is as far as it went and that happens everytime I start my phone.

    So I tried using EBOOT and flashing recovery from there (holding down power and volume -). I can get to the black and green recovery screen (ClockworkMod v2.5.0.7) but when I try to flash the recovery, the phone loads up the blue O2 screen and freezes. I have tried to run the .zip file on the SD card but it doesnt do anything and just loads up the recovery menu again. I can see the back up image in the restore menu but when I click it, again I see a small box with data coming out and the process completes but I get this message at the end "sd-ext.img not found. Skipping restore of /sd-ext.img". When I then select "reboot system now" the same thing happens, blue screen freeze.

    Please please please help me. I backed it up so that I dont have this problem but I cant even get to my back up! Any advice please.

    Bravo PUT 1 SHIP S-ON
    HBOOT 0.93.0001
    MICROP-031d
    TOUCHPANEL - SYNW0101
    RADIO - 5.11.05.27

    Many thanks in advance

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    OK, first thing: there's a pretty comprehensive FAQ here, which is worth reading.

    Now to clarify, you did the right thing wiping before installing CM7. If you hadn't, it would almost certainly have failed even to boot. Also to install the thing Titanium is missing (busybox) you press the "Problem?" button in Ti. If you sync contacts with google you can transfer them that way, otherwise a local backup tool (Ti or MyBackup) is needed.

    As to your problem, I'm puzzled by what you say about "flashing recovery", but perhaps that's a matter of terminology. Clockwork 2.5.0.7 is your recovery, so you don't need to flash that. Likewise I don't know what you mean about running the zip file.

    But I digress - the main thing is that you find the restore menu and can see the backup. It sounds like you have done this, but can I confirm the steps: boot into recovery (clockwork 2.5.0.7), select "backup/restore", then "restore", select backup and procede. Unless you had created an ext partition on your SD card you don't need to worry about the sd-ext messages - if that isn't there, it won't be in the backup, so this is normal.

    If you've followed these steps, and it hangs on the splash screen, then I'm not sure what to suggest immediately. Do you know what version of clockwork you installed with ROM Manager? If it was 2.5.0.7 (recommended here) then that should not be the problem. In case you wonder why I ask, UnRevoked will have installed 2.5.0.7 when you rooted, but ROM Manager puts its own copy on the SD card, so it's not obvious that it will be the same.

    We can certainly get your phone working again: put a ROM zip on the SD card and install it using clockwork and you'll be up and running. The problem is purely how to recover your data from the backup. I have an idea, but want to do a little checking first, and this post is already too long...

    One thing that worries me is that you aren't the first person recently to report something like this. And the common factor seems to be ROM Manager. So one definite piece of advice for the future: do not use ROM Manager.
    carizma likes this.
  3. carizma

    carizma Member

    Hadron, thank you for the fast respone. I am very relieved to hear you say that this is rectifiable. If my data is lost (which will be a crying shame), at least I will have a working phone.

    To confirm, yes, I have followed all these steps and it just hangs. To confirm:
    Go to HBOOT, select Recovery (I get blue screen O2 temporarily), clockwordMod opens, backup and restore, restore (it does its thing and says complete but gives sd-ext message - I did not create a partition so that solves the sd-ext issue). I then select reboot system now and it hangs - same blue O2 screen. Im forced to do a battery pull. As I said, I can see the image listed there in the restore menu. [Interestingly, when I get to HBOOT, it reads my SD card very quickly and I think it says "no image found" but it flashes up so fast I dont see it clearly].

    Re zip file, when I get into recovery menu (clockwordMod) I have option to install zip from sd card (which is what I thought was some save point if you like) but it doesnt do anything.

    Re version of clockwordMOd - sorry I am not sure what version ROM manager installed. I can only tell you that I have version 2.5.0.7 when I load up through HBOOT.

    OKay, so how do I go about getting a ROM zip on my SD card. What ROM zip should I get?

    Thanks again for your help. I have been sat here for about 5 hours trying to work this out! :confused:
  4. Hadron

    Hadron Well-Known Member Contributor

    OK, if nobody else comes by with anything else, here's an idea you could try. Please note that this just me trying to think my way round this problem, and not a tested solution, and comes with no guarantees. So I'll explain my thinking as I go.

    Firstly, I'm assuming that we can't get the phone to boot after a restore, i.e. that nobody spots what's wrong and identifies a solution. I am also assuming that if you copy a ROM .zip onto the SD card (which you can do by mounting it from clockworkmod and then copying over usb) you can then flash that ROM from clockwork and boot the phone (you can test this using your current CM7 zip).

    So, the nandroid recovery backs up separate images for the different storage partitions. If you go into the "backup and restore" menu there's an "advanced restore" option. This allows you to restore just one of your storage partitions. Your apps and information are in "data". So the idea is, can you install a suitable ROM, check the phone boots OK, then go back to clockworkmod and just restore the "data" partition? If it works, you have your apps, contacts etc back, and you can then back these up using Titanium, and/or MyBackup, reflash CM7 and then restore your stuff.

    As I say, there is no guarantee. It really depends on why the phone hangs on the restore. If it's something in /system that's been messed-up it should in principle work. If the problem is in /data however, this procedure would just restore the problem and so leave you back where you are at the moment.

    One important thing: I said "suitable ROM". You presumably were running a stock HTC Sense ROM (rooted) when you made the backup, so for this to have any chance you'd need to install a Sense ROM - restoring /data from a Sense backup when running CM7 is unlikely to work (because this is what we wipe before flashing CM7!). I usually recommend teppic74's ROM when people need a rooted stock.

    Finally, I'd strongly recommend reading the FAQ and making sure you understand what's being discussed here. If you need the phone working you should be able to reinstall CM7, and as long as you don't delete your backup (or format your card) the situation should be stable. So if there's anything you don't understand, ask before charging in.
    carizma likes this.
  5. Hadron

    Hadron Well-Known Member Contributor

    That's the option for flashing a ROM (or any other installable zip). If you know where your CM7 ROM zip is on the sd card, you can use that option, select the CM7 ROM, and install it. That will put you back where you were before you tried to restore.

    Yeah, there's a lot of detail when you are new to it. Like most things, it gets easier with experience.

    As I say, hopefully you already have one ROM zip on your SD card. Otherwise, download one to your computer, boot into clockwork recovery, and you'll see a menu called "mounts and storage" or something like that (I've booted my phone again so don't have the menu in front of me). There's an option in there that will let you mount the SD card so you can copy files to it from the computer via usb (prob. connect the phone when in recovery, then use this menu). If it's just a matter of getting the phone going, and CM7 seemed OK to you, I'd use that. Only thing to avoid is ROMs which require an ext partition (such as the a2sd version of LeeDroid), because you don't have one, and putting one on will reformat your card and delete your backup, which you may not want to give up on yet. I've linked to a rooted Sense ROM in my previous post if you want to try that instead, or want to try out that potential recovery method.
    carizma likes this.
  6. carizma

    carizma Member

    Once again I appreciate the responses and advice. I certainly follow your line of thought and am happy to try your suggestion (given I am completely stuffed right now).

    Seeing as I cannot seem to get my apps/data/numbers etc by using CM7, I will try the teppic ROM and do the mount thing as you advise.

    With regards to the Teppic ROM, can I just check that I should stick to the 2.10.405.2 Stock ROM with Radio version? There are few options in the link you provided and it is all a little daunting for me right now.

    Finally, the instructions state that I should do a full wipe in recovery before installing the ROM. Again, I am not sure what this means and concerned that a "full wipe" may delete my SD card data. This is not the same as a format is it?
  7. Hadron

    Hadron Well-Known Member Contributor

    I'd pick a version without a radio - there's no need to reflash the radio, and it's a slightly riskier operation. One of the init.d ROMs should be fine - if you can remember what original software your phone was running pick the one that's closest, but I don't think it will make much difference.

    It's pretty standard advice to wipe before flashing a new ROM - it's "safe" because wiping all apps and settings avoids the risk of carrying over settings from the old ROM which are incompatible with the new one. And if the last thing you were running was CM7, I think this is probably a good idea - Sense and CM7 are likely to be incompatible. It's the "wipe/factory reset" option in the clockworkmod menu, and is equivalent to doing a factory reset of the phone when it is running Android. It won't delete the SD card, just the data and cache partitions. Avoid anything that says "format"!

    (Edit: but don't worry if the wipe operation produces messages about "formatting /data" - it's just the sd card that we don't want formatted).

    You could play safe by mounting the card from recovery and copying the backup to your computer - then if anything goes wrong you still have the backup. It should be in clockworkmod/backup on the sd card, and will be a folder with name = date and time the backup was made. It's also likely to be several hundred MB is size.
    carizma likes this.
  8. carizma

    carizma Member

    I am sorry to bother you with this further but the link you provided does not have one without the need to flash a radio. Am I reading it wrong?

    In any event, I have come across this - [ROM-FroYo] Official Froyo HTC Sense ROM (16/07 v1.0c | OpenDesire Team) - xda-developers - it seems to me that this is the closest thing to what I had before (Froyo 2.2). Again, I am not sure if I need radio. Can I have your view/advise please? (I owe you a pint!). I cannot find any O2 stock ROMS that are not RUU types (yes, I read the FAQ page :D)

    I think copying the backup to PC is a good idea. I will do that.

    Cheers Hadron, really appreciate this.
  9. Hadron

    Hadron Well-Known Member Contributor

    The "2.10.405.2 INIT.D ROM" in teppic's thread doesn't include a radio - that's in a separate link below it. I don't know that OpenDesire one, except that it's pretty old (the radio they link there is older than the one that went out with the first official UK 2.2 update).

    The ROM threads often talk about upgrading radios, but that's usually because they started out when many people's phones were still on 2.1, and 2.2 does require a newer radio. But if you started out on 2.2 you don't need to change radios.
    carizma likes this.
  10. carizma

    carizma Member

    Great stuff. I will dl and report back once I carry out your recommended fix. Likely to be tomorrow as brain is fried now. Info overload. Fingers crossed.
    Thanks again.
  11. Hadron

    Hadron Well-Known Member Contributor

    OK, good luck. As I say, no promises - it's just the only thing I can think of if the full restore doesn't work.
    carizma likes this.
  12. carizma

    carizma Member

    Hi - It worked! I now have a rooted stock HTC ROM (the one you recommended) - looks exactly the same as my standard Froyo ROM before rooting so am familiar with layout etc. Cheers for that.

    So, now that my phone is up and running, can we try and recover my apps and data etc?

    Should I get Titanium Pro or My Backup Pro and try it from there? Will it recognise that I have a backup saved on SD card? Or should I try to recover now from EBOOT as before? I will wait to hear from you before attempting anything myself. No more questions!

    Cheers
  13. SUroot

    SUroot Well-Known Member Developer

    Take a backup now, manually using nandroid via recovery itself.

    Your previous backup should still exist no?

    What you can TRY, is to do an advanced restore via clockwork mod and restore ONLY the data partition. This MIGHT work.

    Titanium is a must, but I have both Ti and My pro versions. They're both worth it even if you dont use them often. I would go for Ti over My though.
    carizma likes this.
  14. Hadron

    Hadron Well-Known Member Contributor

    The only way to get the data from your recovery backup ("nandroid") is via recovery. So to try what I suggested you should boot into clockworkmod (i.e. into HBOOT and select recovery from there), then into "backup and restore" -> "advanced restore" and try to restore just "data". And hope.

    If it works, you'll need Titanium or MyBackup if you want to transfer apps and data to a different ROM. Titanium is generally used, but I find MyBackup simpler for contacts/SMS, so actually have both. Both have free versions you can start with (MyBackup is time-limited, Ti lacks some of the convenient features of the paid version).

    These types of backup are quite different. The nandroid backup is a snapshot of the entire state of your phone (apart from radio and hboot). It allows you to revert to a previous ROM, and can be used to recover if a ROM flash goes wrong and you can't boot. But you cannot extract individual apps or data from it. Hence the idea I propose is to try to restore the whole /data partition, and hope that the problem is not in there. But there's no way of just extracting, for example, your contacts from that, so if whatever is stopping the phone booting is in that partition I think we're stuck.

    Titanium and MyBackup are apps which make a copy of your apps and data on your SD card. They can be used to just restore a single app or type of data, and because of this they can be used to transfer apps and data between ROMs (a full nandroid restore will overwrite the ROM, and even the partial restore we're proposing here will restore alll of the settings as well as user data, which is why we needed a compatible ROM). However, they also require that you are running Android, so if you are unable to boot they are no help.

    So both types of backup have their uses.

    As a footnote, I realised after I went to bed last night that there may have been a quicker way: if you'd already restored the nandroid, then the /data had already been restored. So you could have tried wiping cache and Dalvik, then flashed the ROM (which would have overwritten /system but left /data alone). But it occurred to me too late! Still, at least this way we've confirmed that a ROM flash gets the phone back.

    One more detail you could try. After restoring data using the advanced restore menu, before booting use clockworkmod to wipe cache (which I think is in the main clockwork menu) and wipe dalvik cache (which is in the advanced menu). I doubt this will make much difference, but it will put the phone in the cleanest state we can have it after restoring data. Wiping dalvik will make the boot slow (as that will be rebuilt during the boot), so don't worry if it takes 10 minutes or so. But if it sticks on the O2 splash screen that long then it's probably not going to work - I'd expect it to get to the boot animation before hanging around.

    Edit: and you can tell from the time of SUroot's post how long I spent typing that!

    He's right, by the way - taking a second nandroid backup now will do no harm at all (they don't overwrite earlier ones).
    carizma and SUroot like this.
  15. carizma

    carizma Member

    Thanks to the both of you.

    I have made another backup using clockworkMod - so at least I have a working ROM backup now.

    Re my data - I did as you suggested (went into HBOOT, backup & restore, advanced restore and selected data only. It looked like it was working and it said restore complete!

    I then booted (top option in clockworkMod) and got the same HTC welcome screen/set up options that I got before (when I flashed the new ROM). Did all the usual set up stuff but no data has been restored. None of my apps, contacts, nothing, just a blank canvas as before.

    Did I do it wrong? Did I miss a step? As I have said, i can see the original backup that I did on the SD card (just after rooting and before installing Cyanogen using ROM Manager) - how come its not pulling the data across? Can it really be that the backup ROM manager made is worthless?

    If I download ROM manager now and try to restore from that, would that maybe work?

    Thanks

    (EDIT - ps - Hadron - I did try clearing cache/Dalvik but it made no difference)
  16. SUroot

    SUroot Well-Known Member Developer

    I think it is possible that rom manager did a dodgy backup. Its looking more and more likely.

    Personally, I recommend cutting your losses on this one. Stay away from rom manager, add everything manually, and put this under your belt as a learned-from experience.
    carizma likes this.
  17. carizma

    carizma Member

    You're kidding!? The whole point of me rooting was to get a backup of app data and save all my stuff! I cannot believe this! Whats the point in offering a backup service when the reliability of the backup is so crap!?

    Would you normally expect the apps and contacts etc to move across automatically or do I need to instal one of the menioned apps to get them to transfer? Android Market knows what I have purchased so apps not really an issue I suppose but app data and contacts!? I need my contacts!!! Contacts is all I care about right now.

    Please, any last ideas?
  18. mbatson89

    mbatson89 Well-Known Member

    If you synced your contacts with Google then these should just re-populate when you log into your Google account on the phone.

    As for the Back-up, backing up through recovery and also using Ti is perfectly reliable, it's using ROM manager that causes issues. RM used to be okay(ish) but for quite a while now it has been a PITA and caused more issues than its solved. Like others have said, remove it completely so the temptation to use it is gone. Do everything through recovery manually.
    carizma likes this.
  19. shauny13

    shauny13 Well-Known Member

    Sorry to say, I agree with SU Root, hard lesson learnt. That's why we all stay well clear of rom manager in this rooting section it's crap!
    carizma likes this.
  20. SUroot

    SUroot Well-Known Member Developer

    Sorry, but not my fault you decided to use ROM manager. We all recommend not using it. Wouldn't recommend trying to use it to correct an error that it may well be responsible for.

    We know that particular backup on your SD card is pretty much worthless. Chalk it up to experience, bite the bullet and move on.
    carizma likes this.
  21. Hadron

    Hadron Well-Known Member Contributor

    I could understand the advanced restore restoring the data, and I could understand the phone not booting afterwards, but nothing changing is a real puzzle. Are you sure you restored from the right backup? If you took another nandroid before the restore it should have asked you which one you wanted to use for the advanced restore: if your finger slipped on the trackpad and it selected the new one instead that would produce this result. Otherwise I don't understand this.

    I've never had a problem with a nandroid backup (and I've made and reloaded a lot of them!), but I've also never used ROM Manager - I was put off by it asking me to download recovery when I knew I already had that, did a bit more research, and decided that I was better off avoiding it.

    I take it your contacts aren't synced with google, because if they were they should just restore over the air after changing ROMs. If they are not, then you need Titanium or MyBackup to transfer them between ROMs (or between ROMs where a wipe is needed, e.g. between Sense and non-Sense). And the problem now is that the only backup is that problematic nandroid.

    All I can suggest is try the advanced restore again, and make sure it's using the right nandroid (should be identifiable by date and time).
    carizma likes this.
  22. carizma

    carizma Member

    I hear what you are all saying and thanks for the time and advice.

    Forgive me for my frustration, its not directed at you! I am a newbie but honestly did my research before rooting etc. I followed all the guidelines and instructions. I did everything right save for trusting a well known app like ROM manager that turned out to be total farse!

    My contacts are not linked with google - I moved them all over to SD card before installing ROM - not sure how to get them back (this is in addition to the back we have tried to restore).

    There must be a way that my numbers can come back, any ideas where they may have been put on SD card (not talking about the backup now).

    If this is doomed then so be it. Worth asking the question.

    Thanks again everyone! Excellent forum and very good advice.
  23. shauny13

    shauny13 Well-Known Member

    If you exported all your contacts to SD, then you can simply import them back again with the contacts app
    carizma and Hadron like this.
  24. carizma

    carizma Member

    Ok, I will try again. I made several backups. First one with ROM manager and other with Nandroid (only I think the nandroid backup was made when I had the problem at the outset so it may not boot properly). Will report back.
  25. Hadron

    Hadron Well-Known Member Contributor

    The backup through ROM Manager should be a nandroid also.

    But look at shauny's post, as I think he may have the answer there. If you copied your contacts to SD using the HTC contacts app, and are now running a Sense ROM (so have the HTC contacts app back again), you should just be able to import them back from SD into that app.

    If that works, do a Titanium/MyBackup backup of these straight away!
    carizma likes this.

Share This Page