Security Message Alert - Need HelpSupport

Last Updated:

  1. benlee123

    benlee123 Member

    Need some help here. I keep getting this error/alert message on my S4 recently.

    Security Information
    An application attempted to access system on your device without authorisation. This attept has been blocked. Deleting applications obtained from unauthorized sources may improve security.

    There is a button "View Apps" to click and it basically list all the apps in my phone but doesn't tell me which one is causing the security alert. I have tried to delete all recently installed applications but still this alert message keeps popping up. :confused::(

    Any ideas what's wrong? Thanks in advance.

  2. Funderbolt

    Funderbolt Well-Known Member

    I'm getting a message that says:

    After tapping:

    Then there's an Update policy button. Every time I click it I get:

    This is total crap.
  3. PrissyPJ

    PrissyPJ Member

    I've had the same issue since I udpated to 4.3. Would love to know what is causing it and how to correct it. Thanks,

  4. Petrah

    Petrah Psychotic Female

    Found this on another forum, see if this helps any;

    Go to Settings > More > Security > Security Policy Updates > Check For Updates.
  5. benlee123

    benlee123 Member

    My settings is already on auto update. Still it appears.
  6. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    You can use the hidden App ops feature to disable the notifications. If you have a launcher that that enables shortcuts to Android Activities (e.g., Apex or Nova), you can access it that way. If not, you can use xShortcut FREE to do the same thing.

    Access the shortcut, slide over to the Device listing, and then scroll down to Security policy updates and Knox Notification Manager; disable "Post notification" for both.
  7. Hamiddg

    Hamiddg Well-Known Member

    Have you tried scanning your phone with any Anti Virus app?
  8. psinsyd

    psinsyd New Member

    Looks like a known issue that Samsung is working on a fix for. Has to do with the 4.3 update on S4s, since it installs a Knox software suite.

    Long time lurker but first time poster so I can't post links yet, but do a search on galaxy s4 4.3 Knox and you'll see everyone is having the problem.

    Samsung has issued a statement via their Twitter account saying they are working on a fix.

    I'm trying to dig to see how to uninstall it from my wife's s4. I won't be updating to 4.3 until there is a known resolution to it.

    I did try the following based on another site's recommendation and it seemed to have lessened the number of notifications so far, although she did receive one after I did this, though not as frequently:

    I did a live chat with Samsung technical support today. Its one of those sessions where the person on the other end isn't a technical expert and just has various scripts to try. This is the script they suggested I try this evening:

    1. Power the device off (remove and re-insert the battery)
    2. Press and hold the Volume Up key and the Home key, then press and hold the Power key
    3. When the device vibrates; release only the Power key
    4. When the Android system recovery menu displays; release the Volume Up and the Home key.
    5. Navigate witth the Volume keys to the WIPE CACHE/PARTITION reset option and press the Power key to select
    6. After user data deletes, press teh Power key to reboot system now.

    Hopefully Samsung's engineers move quickly on this. I'd much rather not even have Knox on the phone.
  9. psinsyd

    psinsyd New Member

    I also just did a force stop on any Knox instances via settings, more, application manager, all. That only stops it until the device is rebooted IIRC.
  10. biz_kid1

    biz_kid1 Member

    Not sure if this is the "fix", but what seemed to work for me was (I'm on Android 4.3 on a Samsung Galaxy Note 2 and I was getting the Security Policy Update pop up):

    1) Make sure you're logged in to your Samsung Account
    Menu > Settings > Accounts:
    If you have a Samsung account listed here, click it and make sure it has your credentials entered correctly and can log in OR if you don't have a Samsung account listed here, click Add Account > select Samsung account and log in
    *Note: When I did this first step, before I could even log in, I had a pop up to install the Security Policy Update, which I did; however, I got the pop up again in my Notifications later, so I proceeded to do the following:​

    2) Open up the Samsung Store
    Apps > Samsung ? (it might have said something else - it looked like a red and white Pokemon ball) > Update

    3) Update the apps within the Samsung Store
    There was an Update All option for me to select; I suspect the "SEAndroid Policy Update" was the one causing my Security Policy Update pop up, but if you're getting an option to "View Apps", then I suspect whatever app may be causing your pop up will be here and an update to them should clear it​

    I am currently waiting to see if the pop up returns, but so far, so good!

    Good luck!

    Edited to add: I received the pop up again, but a lot later this time (like 12 hours). This time, tried: Menu > Settings > More... > Security > under Security update service, Security policy updates > uncheck or disable Automatic updates - pop up did NOT re-appear after a reboot this time!
    Last edited: Jan 24, 2015
  11. Jay Coventry

    Jay Coventry New Member

    Solution that worked for me on my Samsung Galaxy Note 2 (T-Mobile)

    Developer Mode was on. Just turn it off!

    Settings> More> Developer Options appears at the very top of the screen, to the right of which is an On-Off toggle.

    Somehow, as my phone was in my pocket and I was fidgeting around for it, I had slid the Developer Mode to "On."

    It took 3 calls into T-Mobile but finally I found a super-smart Tech Support rep who immediately knew the solution. A previous rep had no solution, and the other wanted me to do a master reset, which the last rep said wasn't necessary, and gave me the solution that immediately worked.

    The other solutions offered in this forum did not work for me, and I was about to desperately try a master reset So glad I didn't, as that would have been a hassle at best, and would not have necessarily fixed the issue.

    I hope this helps you!
  12. dwsimpso

    dwsimpso New Member

    So what was the solution he gave you. I would like to try it. Nothing else has worked.
  13. cobalt904

    cobalt904 New Member

    I posted it and it is right in front of you, yet you asked me for the solution. Good luck. :)

Share This Page