1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Sending MMS messagesSupport


  1. mted558

    mted558 Well-Known Member

    Has anyone found a SMS app that sends pictures and video without an issue. Every app I've tried I've had issues sending pictures. Tried Handcent, Chomp, GO SMS and I've had issues sending pics, keep getting errors and the pics don't send. Thanks for any suggestions.

    Advertisement
    :
  2. Ageless Stranger

    Ageless Stranger Well-Known Member

    Can you send MMS with the stock app?
  3. bradyapba

    bradyapba Well-Known Member

    Im having the same problem. For me, it seems to be a wifi vs 3/4g issue. This phone seems to hate sending pics through wifi, soon as i change to 3/4g it seems to work.
  4. mted558

    mted558 Well-Known Member


    Sometimes they'll send other times not which I know could be a carrier issue.
  5. masturblastur

    masturblastur Member

    If you're on Sprint, I know that the stock apps usually switch off WiFi and send the MMS through 3G or 4G, then switch WiFi back on.

    Perhaps the 3rd party apps don't do this?
  6. mted558

    mted558 Well-Known Member

    I'll have to try this. I'm not in a good area signal wise so that could be the issue too.
    Thanks for the tips everyone
  7. Slacker1313

    Slacker1313 Active Member

    I had lots of issues sending mms also. Then realized for whatever reason that mobile data wss not enabled. Go to settings/connections/more networks/mobile networks/ and make sure "mobile data" has a check in it.

    Don't know why this was not enabled to begin with but it solved all my issues.
  8. speedlever

    speedlever Well-Known Member

    Mobile data has to be enabled to send MMS messages. I learned this the hard way on my first Android.. S720C. I was so focused on saving battery power that I used a battery saving app.. Juice Defender... which did a nice job. Well, other than switching off my data radio which I eventually discovered was the source of my MMS difficulties. I didn't realize that MMS requires data... and won't work over wifi.
  9. mted558

    mted558 Well-Known Member

    I have always had this checked so it's not my issue. I'm just wondering if I should change the network mode? My says Preferred network mode "CDMA/LTE/EVDO
    I don't have 4G or LTE in my area yet so should this be a different "preferred network mode"
    And under network operators it's grayed out so I can't change that.
Loading...

Share This Page